Question about 2005 Kymco Stryker 125

1 Answer

Tgb 101S - no spark

Running fine.
Changed spark plug rode about 20 miles no problem
suddenly will not start.
checked - no spark.
Replaced CDI module - nothing
coil looks fine -
kill switch - in proper position - looked at switch, but not sure how it works.
Cranks over and has compression, 888 miles ran it only 6 months.
What else controls the ignition?

Thanks,

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 128 Answers

Did you try another plug maybe the plug is dead or check fuses there might be a blown fuse or a burnt fusable link

Posted on Oct 03, 2009

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 48 Answers

SOURCE: I Have a 2004 KTM

if it wasn't either of those then replace your coil that is only thing other than timing

Posted on Jan 14, 2009

  • 3567 Answers

SOURCE: My son's 2005 Kymco TGB 50cc scotter hit a good

Normally, one goes to the carb, one to the gearbox and one to the battery. What sounds really weird is the diameter of the hoses. Three quarter and one inch diameter? Normally 1/4" to 3/8".
Hope this helps!

Please rate this solution. Thanks locjaw69!

Posted on Apr 04, 2009

  • 3 Answers

SOURCE: TGB 101S 2006 50cc

new plugs first, put problem a bad coil

Posted on Jun 14, 2009

  • 15 Answers

SOURCE: My 2003 WR 450F was easy to kick start/push button

Did you check the carb? The float might be stuck traping liquid in it, causing it to act like its flooded. Or the Jet could be plugged up?

Posted on Nov 06, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How to derestrict the CDI of a 50cc TGB Bullet RS. Model 2013 or 2014


derestrict the CDI of a 50cc TGB Bullet Anon, Check the attached links,instruction and guides, Good luck
"I hope this helped you out, if so let me know by pressing the helpful button. Check out some of my other posts if you need more tips and info."
ScooterCommunity
How to replace the cdi box on your scooter with performance cdi box
How to derestrict 50cc Scooter TuningMatters com

Jul 28, 2016 | 2006 TGB Laser

1 Answer

I recently bought a used tgb 101s power scooter and had a new battery installed the carburator cleaned new air filter blinker and brake cable, my problem is the scooter will not stay running


sounds like fuel starvation. Look for kinks or air in the fuel line or a faulty fuel tap. Also check the vent in the fuel tank cap.

Jul 01, 2016 | TGB Motorcycles

1 Answer

Bike stops firing once it gets hot.


fuel system is blocked, carb not refilling at speed necessary,. check fuel lines not kinked, check fuel tap, check vacuum pipe not split, clean carb

Mar 06, 2013 | Honda Motorcycles

1 Answer

Tgb 101s pinging and missing at medium to high revs


maybe it went to low revs cos the plug was fouling, if so upping the idle will just make the problem get worse quicker

Feb 14, 2013 | 2011 TGB 101S 50

1 Answer

Dose not excelerate


check your air filter if not that your jets in the carb could be clogged you can run some carb cleaner threw it while its started for quick fix.Or what i rather is cleaning the whole carb

Dec 18, 2012 | 2010 TGB 101S 50

1 Answer

Hey guys i was just wondering if you could give me a hand with this problem i have been having for at least 2 months now, the problem is that my scooter doesnt start off the electric, but will start off...


Hi, For_shi_zo before testing any electrical component in the Starter Circuit it is "IMPERATIVE" that you have a fully charged battery of 12.5 volts or more and be able to pass a proper "LOAD" test because your battery may have 12.5 volts or more but little or zero amps causing the battery to be faulty and must be replaced, especially "AGM" batteries.
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter.
4. Bank angle sensor needs a reset or is faulty.
5. FOB battery low or dead.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Security alarm needs a reset.
10. Starter relay, solenoid or starter circuit wiring faulty.
11. Starter armature or field coils have failed.
12. Main fuse or circuit breaker may be blown or faulty.
13. The electric starter is working but starter clutch has failed.
14. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Scooter Troubleshooting Scooter won start All about Scooters
TGB R50X Part 1 Won Start Scooter Putting The Wiring Back To Standard On...
TGB Service Manual 101S BH1 303R 50 BR1 Delivery 50 BK1
https://www.ajsutton.co.uk/spares/chooseModel.asp?make=tgb&uID=0
TGB 50 2006

Apr 28, 2017 | 2006 TGB R 50 X

1 Answer

TGB 101S 2006 50cc - no spark


new plugs first, put problem a bad coil

Jun 14, 2009 | 2005 Kymco Stryker 125

1 Answer

No spark


I too have a 1087 Honda Shadow and after we rebuilt, cleaned and painted the bike, it would not spark.

Behind the battery, check the CDI box. Look inside and shake upside down, looking for the presence of water. Once we completley dried out the unit. The bike runs like a champ.

the other day I rode in the rain for 160 miles. Engine died. Went to the CDI, water was there. Dried it out and again the bike runs fine. I am going to seal my cdi unit now. and hopefully the problem will not come back.

Richard
Colorado

Mar 30, 2009 | 1987 Honda VT 1100 C Shadow

Not finding what you are looking for?
2005 Kymco Stryker 125 Logo

675 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kymco Experts

yadayada
yadayada

Level 3 Expert

76132 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Kymco Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...