Question about Suzuki Boulevard C90 Motorcycles

1 Answer

MY BIKE STARTS MOST OF THE TIMES, BUT THEN ONE DAY I PUSH THE START BUTTON AND NOTHING YOU CAN HEAR THE FUEL INJECTOR COME ON ALL THE LIGHTS WORK BUT NO START.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It cud be your coil are bump it

Posted on May 20, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bike felt like it ran out of gas on the freeway and now won't start . I push start it and it seems like it wants to start. But nothing, it started once and was back firing


Fuel filter? Trash in the tank? Other fuel delivery system devices. Ecu (computer) fuel injectors? DYIer get the repair manual from your parts supplier.

Jun 13, 2015 | 2004 Yamaha YZF-R6

1 Answer

2001 Moto Guzzi California EV won't even try to start.


pushing the start button dims the lights is a sure indication that the battery is faulty
have it load tested or replace it
charging a dead battery after a 2 year period of being flat causes what is known as sulphation of the plates and the battery will not accept a charge regardless of the charge time.

May 22, 2015 | Motorcycles

3 Answers

My 2005 Suzuki Boulevard Will not start most of the time. I have replaced the battery, pulled and checked the Starter Relay, Decompression Relay and the combination Turn Signal/side stand Relay, I have...


Same problem here ... 2008 C90T ... dealer no help ... in 3rd or 4th, ignition off, force it to roll backwards until you hear the piston shift ... should start then. Told it's the rear piston stopping at or near top dead center, but also told adjust the decompression will "solve" the issue; anyway, a rolling forward-start in 4th will work, too, otherwise try rolling the bike backwards until you hear, and you will know when the piston moves and then it will start.

May 08, 2010 | 2005 Suzuki Boulevard C90T

2 Answers

My silverwing won't start or even turnover


I have the same problem on 2007 Honda Silver Wing. It will start and run just find, let it set for a day and it will not start, I have the same problem. H ave you found out the reason for this problem? Kenny, I think it could be the starter brush problem.I have been a bike machanic for 37 years, and this is the only bike , or scooter that has me stumped.

Apr 13, 2010 | 2005 Honda Silverwing 600 ABS

3 Answers

Car running on three cylinders with good spark.


unplug the spark plug wires from the coil pack one at a time and see if the engine speed changes. you will also be able to see/hear the spark each time you do that. if you see/hear one that doesn't effect the motor you likely have a failed or failing coil pack.
might be a good idea to wear some type of rubber gloves when you do that so you don't get "zapped".

Sep 14, 2009 | Chevrolet Cavalier Cars & Trucks

1 Answer

My 94 s-10 4.3 wont spray fuel?


you can purchase what is called a noid light not to expensive they plug into the injectors conection the noise your hearing is called a two second run . if the light don't come on the ignition modual needs replaced that is mounted under the distributor cap .

Aug 26, 2009 | 1994 Chevrolet S-10

1 Answer

Bike wont start


when I tried to start it yesterday it would not start; pushing the ignition causes just one *click* sound and then nothing. The battery is reading 12.65V or so so that seems fine. I did some research and I think it's either along the lines of the spark plug(or ignition area) or maybe water in the float bowls from fueling up(?). I tried it again today and this time there was no *click* sound. I also noticed that the -neutral- and -check engine oil- lights which normally light up quickly at start up take a few seconds before lighting up. Now I think it's more in the electrical section but not exactly sure which area. I'm going to take a look at the spark plug and maybe try to drain any water out, but was wondering if anyone had any other ideas? ,When you press start, the churning sound you (typically) hear is from the starter motor forcibly turning the crankshaft. While the starter is physically turning the engine, the engine is also injecting the fuel/air mixture into the cylinders and firing the spark plugs. If the plugs successfully ignite the incoming fuel/air mixture, the engine will begin turning itself over. If you press the button and nothing happens, or you just hear a click, the starter motor is not cranking the engine. The click you heard was probably the starter solenoid attempting to engage the starter to the flywheel of the crankshaft. The problem is probably the starter. It may be a bad battery. Reading the open voltage with no load on the battery tells you nothing. Put the voltmeter across the battery terminals and read the voltage while holding the Start button.,,,

Nov 10, 2008 | 2007 ATK 450 Motard

Not finding what you are looking for?
Motorcycles Logo

Related Topics:

179 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76846 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...