Question about 2004 Yamaha YZF-R6

1 Answer

My bike turns over but won't start

My bike went from running to not even starting and shows me a 19 trouble code displays on my speedo. i've checked almost everything if someone could help me?

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 40 Answers

19 Black/red ECU lead (broken or disconnected) A break or disconnection of the black/red lead of the ECU is detected.

Posted on May 19, 2009

  • Jeff Policky
    Jeff Policky May 19, 2009

    The bike will not start untill this code is fixed.

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

This morning I tried to start my bike.Yamaha R6 06 model . But it don't want to start. I've tried by pulling the clutch and lift the stand but stil it won't start... Can any 1 help me pls.


Hi, Jan and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
http://www.r6messagenet.com/forums/welcome-center/161248-please-help-bike-wont-start-turn-over.html
http://www.r6-forum.com/forums/46-general-discussions/165925-r6-wont-turn-over.html
2006 Yamaha YZF R6 Service Manual R6 Moto Data Project
OEM parts for Yamaha
http://mybikemanuals.com/yamaha/yamaha-yz-owners-manuals

Jan 28, 2013 | Yamaha YZF-R6 Motorcycles

1 Answer

Bike won't start. No voltage to fuel pump fuse on 2008 Ultra Classic Electra Glide. Have power on all other fuses. Any suggestions?


Get some good electrical cleaner spray displays that connection scrubber with alcohol, make sure the fuses good and try again pulled a plug-in out, even though you charge the battery make sure the battery has 12.67 V of starting juice. How was your battery may be needed. New battery

Sep 29, 2012 | 2008 Harley Davidson FLHTCU Ultra Classic...

1 Answer

When i turn my key to the start position all speedo lights go out and bike won't even click. it sat in 10 minute rain shower but it started after that.


Check here 2...sorry I do not know...http://harleytalking.com/login.php?do=logout&logouthash=1313501436-eb7a83064e08c13f62cc323a7bbce4a8d217cd8d

Aug 15, 2011 | 2004 Harley Davidson XL 1200 C Sportster...

1 Answer

The instrument panel lights went of on my 1999 r1, the rev needle went off and felt like bike was running out of petrol, eventually cut out and when i pulled over, the bike would not start, but did start...


Hi, Tom and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a load test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have nice a day.
Bike won start
http://www.r6-forum.com/forums/57-garage-mechanical-help/162715-will-not-start-good-battery-no-clicking-but-no-turn-over.html
1998 1999 Yamaha YZF R1 Service Manual R1 Moto Data Project
OEM parts for Yamaha
http://mybikemanuals.com/yamaha/yamaha-yz-owners-manuals

Jun 16, 2011 | Yamaha YZF-R1 Motorcycles

1 Answer

The check engine lite won't go out after removing the power comander module. 2005 dyna wide glide


Chances are the PC created a trouble code that has not been cleared.

Use your speedo to check for codes.

1. With the bike off, push and hold in your odometer reset button.
2. with the button pressed, turn the ignition on, make sure your run/stop switch is on.
3. your speedo will do a sweep and when it comes back to 0, let your finger off. You should see a variety of letters, PSS ect. if you push the button briefly you can toggle between letters, you need to check every letter. So when the letter is blinking, press and hold the button untill the screen changes. Codes will show up as P0112 or B1110 ect. keep pushing the button untill you have all the codes. You will know when your done with the letter because it will show a part number, Example, P/N 19999-03 ect. Once you go thru every letter like this, writing down the codes, you can look them up online as follows: Harley DTC P0099 ect.
4. If no codes are present, it will go staright to the P/N. and you can click out of that to the next letter.
5.To clear the codes at this point, while you are looking for codes under the different letters, Simply press and hold the button, once it shows you the code.


So show the code, press and hold button till cleared, then press and relese button quickly to move on to the next number.

If after that, you turn the ignition off, then back on like normal, and the light should come back on shortly, but, once you start your engine the light should be off.

May 11, 2011 | 2005 Harley Davidson FXDWG - FXDWGI Dyna...

1 Answer

2008 harley when l tun on ignition then press run the yellow malfunction light comes on for 4 seconds then goes out for 2-3 seconds then comes back on for 4 seconds then goes out and stays out even with...


this means you have a trouble code. please verify year of bike...if a 2008, perform a wow test to get the trouble code: to do this you have to hold in your speedo reset button and turn ignition on and it will show you the code. (ck owners manual for code breakdown)

Dec 26, 2009 | 2000 Harley Davidson FXSTB Night Train

1 Answer

2002 r1 code 19 on speedo and no fire


19 is associated with the sidestand interlock

The bike must be in neutral or have the sidestand up. These interlock the starting cut-off relay.
Does your neutral light work? If it does not, that needs to be resolved, but bike should still start if the sidestand switch is made (stand is up).
If bike still does not start, then you may have problem with the diode assembly or the starting circuit cut-off relay.

Aug 16, 2009 | 2002 Yamaha YZF-R1

2 Answers

Speedo, turn signals, brake lights, horn stopped working. All else is fine.


Gap your plugs to 38 thou. Check all your bulbs (one burned out will affect the rest) Take a look at all your fuses and make sure they are all ok. Otherwise you are probably looking at a wiring short which will require trouble shooting of the elctrical system. Buy your self a service manual for your bike, this will help you a lot.

Jun 03, 2009 | 2005 Harley Davidson XL 1200 C Sportster...

2 Answers

Electrical trouble


If all the fuses turn out good especially the main fuse then you might want to check your starter solenoid. Try jumping the two leads on the solenoid if the bike starts then most likely the solenoid is bad. If it doesn't start then it could be two other things. 1- your Ignitions might be shoot. tell tail signs. Bike cutting out during the ride and bike loses power when you hit the starter button but power returns when you turn the key off then back on. 2- The Rectifier might be gone. The rectifier will cause many different problem that might have you chasing carb problems, to the bike won't start at all with no cranking

Nov 10, 2008 | 2001 Yamaha Drag Star Four

Not finding what you are looking for?
2004 Yamaha YZF-R6 Logo

Related Topics:

563 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...