Question about 1997 Suzuki GSX-R 600

Open Question

1997 gsxr 600 gauges don't work, they light up but no led and no speedo or tach

Posted by on

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 10 Answers

SOURCE: 1998 gsxr 750 speedo problem

speedo pick up , is in left/hand front sprocket cover.

Posted on Mar 10, 2009

goalie39
  • 469 Answers

SOURCE: 2006 Screamin Eagle Fat Boy- tach, speedo, blinkers not working

You've blown a fuse, check the fuse block. it should be an accessory fuse.

Posted on Apr 13, 2009

DickCanFixIt
  • 948 Answers

SOURCE: 2006 Gsxr 600 gauge not working

The first thing to check is your battery. A failing battery can cause all kinds of strange electrical behavior. Post again if you load test the battery and it is good.

Posted on Sep 10, 2009

TimtheStick
  • 83 Answers

SOURCE: 07 gsxr 600 no power to the fuel pump or coils put

Start with the basics. Check the fuses, then use a digital multi meter to check continuity from the fuse panel to the fuel pump and coils. If you have good power/ground/continuity, the next step is locating a complete wiring diagram to find out what other components are in the loop. But if you start with the basics first, you won't be dropping hundreds in parts for a $.12 fuse.

Posted on Dec 10, 2009

  • 45 Answers

SOURCE: My 2004 gsxr 600 turn signals don't work. I have

have you changed the flasher relay to run led indicators if not you will need to you cant run standard bulb indicators and led together. and with the brake like sounds like pulling on the cable when on lock causing switch to stay on check that location of the wiring is correct and sufficient freeplay

Posted on Dec 16, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Headlights work fine. Why are all gauges/ electronic dash out?


Electrical issue - no headlights, tach, etc - HCS Snowmobile Forums

www.hardcoresledder.com > ... > REV Chassis

Feb 2, 2009 - 12 posts - ‎2 authors
There is no voltage at the harness with the relay at all. ... Previous Sled(s): 09 f1k SP,07 f8 SP,fusion 600@900 ... We havea 2006 600sdi and everything works but the headlights. ... relay is good, But this just happend to me sled starts and runs fine ... As soon as I rev it up the dash, tach, headlamp go out.Missing: 600headlights ‎electronic

06 fusion 600 bad volt regulater [Archive] - JohnDee.com ...

www.johndee.com > ... > Discussion Board > Tech Talk

John Dee
79 posts - ‎8 authors
I believe I have a bad voltage regulator going out on my sled. lights are diming and ...I'm under the impression that polaris has replace the old regulator with a new ... They are way down under the oil tank, brake, and all that stuff, up tight ... While riding, my sled had dim lights, no hand warmers, gauges would go in and out.Missing: 600headlights ‎electronic

Polaris Fusion 600 HO LED tail lights - YouTube

? 0:31
https://www.youtube.com/watch?v=oG2BWF4xVKg
Sep 28, 2011 - Uploaded by Trent Robinson
Most Fusion 600 HO owners at some point have issues with their ... This makes sense but the electrical system is AC on this sled AND people complain of the brake indicator on the dash stays onall of the time. ... Not sure on the indicator, mine works fine. ...2006 Polaris Fusion 900 that we are parting out.Missing: 600headlights ‎gauges ‎electronic

battery light blinking with full battery - TrackShare.com

www.trackshare.com/forum/showthread.php?t=32645

Jan 01, 2016 | Polaris 2006 Fusion 600 HO

1 Answer

97 plymouth breeze speedometer,tach gauge,temp gauge,brake lights, dont work.


circuitry behind the gauge panel. you will have to pull the dash to see behind there and track the problem down

Nov 28, 2013 | 1997 Plymouth Breeze

1 Answer

1997 k1500. I started it today, negative temps, and I don't have 1st, or overdrive.


unplug the trailer first to see if it is something in it''s wiring.
not going into OD could just be that the load is too much to handle in OD.
speedo and tach I would start by checking fuses.
sounds like the problems are all related.

http://www.fullsizechevy.com/forum/general-discussion/technical-maintenance/472951-97-k1500-no-speedo-wont-shift-abs-ses-lights.html

Jan 31, 2013 | 1997 Chevrolet K1500

1 Answer

I was riding my 2001 gsxr and my panel just started blinking on and off speedo tach temp would go dead battery is shot would that cause it


I had this problem before it turned out to be a bad coupling from the generator, but also check earths are good and tight and voltage check that battery to be sure.

Feb 22, 2012 | 2007 Suzuki GSX-R 600

1 Answer

1998 Plymouth Grand Voyager.........Dashboard instruments quit working and don't light up. Speedo, tach, fuel gauge, temp gauge, and mileage indicators and lights for same stopped working. ABS...


You have some wiring problems shorting out that is coming from the dash board so if you or anyone you know how to use a multimeter to check the wireing harnesses plus check any connectors that might be just very touching the connector of dashboard which means a bad connection to dashboard.

Jun 04, 2011 | 1998 Plymouth Voyager

1 Answer

Tach & speedo not working


Had same problem with my 2000 dodge stratus 2.4 liter and transmission would not shift out of 1st gear. Solution was ignition fuse under the hood was blown, one side of fuse working, replaced 10 am fuse everything works, tach, speedometer, gas gauge and transmission started back to shifting.

May 27, 2010 | 1996 Oldsmobile Achieva

2 Answers

How do you fix a broken odometer and speedomter in a '97 cbr600 f3?


It sounds like the cable to the the speedo and the tach may need to be replaced. check them and replace if needed.

Mar 24, 2010 | 1997 Honda CBR 600 F(3)V

1 Answer

2006 Gsxr 600 gauge not working


The first thing to check is your battery. A failing battery can cause all kinds of strange electrical behavior. Post again if you load test the battery and it is good.

Jun 22, 2009 | 2008 Suzuki GSX-R 600

1 Answer

Speedo Problem


check the connections for the tach and spedo the mileometer is tied in wit the spedo and the tach should have some connection wit the coil

Nov 12, 2008 | 1994 kawasaki ZZR 600

Not finding what you are looking for?
1997 Suzuki GSX-R 600 Logo

Related Topics:

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75117 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...