Question about 2004 Aprilia RS 125

1 Answer

Hi! I have xr200 2002 model. No problem at start and idle. But when I throttle mid high to shift gears, I notice a loss of power and feel that the carb not giving enough gas. When I rev high to overtake, it just runs well, but when I return the throttle back; it misfires. Please help.

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 34 Answers

If your vehicle is fitted with a choke try releasing it, it controls the amount of fuel going to the carb, let it off the give it the throttle mid ride

Posted on Oct 23, 2013

  • 1 more comment 
  • Rexan Villalus
    Rexan Villalus Oct 23, 2013

    Thanks. I checked the choke, it's off. Still the same. I checked air filter, good. Spark plug good. but still same.

  • Matt Fitzsimons
    Matt Fitzsimons Oct 24, 2013

    Then the next step would be to check if your carb is blocked with residue, I would recommend that you remove it and inspect it

  • Rexan Villalus
    Rexan Villalus Oct 27, 2013

    Thanks very. my bike is running fine again! I get my carb cleaned and put new hoses. Now its running great again. thanks very much.

×

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
luckyluke78
  • 333 Answers

SOURCE: Aprillia SX125 spluttering Mid revs too

Can you confirm if this has a 28mm Dell'Orto carb ?
I would think that you might be possibly running too rich in mid range between ¼ and ¾ throttle opening in which you could try to drop your needle (raise the clip)by two notches,and if this helps but not eliminates the problem,maybe a slightly smaller main jet.

Please get back to me if you need more help.

Thankyou

Posted on Aug 10, 2009

SOURCE: Aprilia RS 125 Power Loss

I guess youwillhaveto adjust the clutch cable so as to open the plates more at the pressure plates to let the clutch plate rotate freely instead of binding thus the low rpm.
Hope this helps!

Posted on Oct 30, 2009

agent91
  • 2100 Answers

SOURCE: s reg aprilia rs 125 derestrited misfires between

You have upset the air fuel flow by changing the exhaust, I would try placing a piece of paper over the air filter to change the intake first, to see what happens, then if that doesn't work, you will need to rejet, and sometimes the factory setting won't work, so you will need an adj jet, Find an aftermarket for your carb I think dyno tune has one. They work great. I hope this helps.

Posted on Apr 06, 2010

  • 738 Answers

SOURCE: hi all i have a aprillia sx125 it is a late 2008

hi, know it sounds silly but you are turning the choke off, or does it have an automatic choke. Can you hear the slide hitting the stop inside the carb when you let go of the throttle, try lifting the cable ontop of the carb and not the twistgrip if it goes down straight away, you could have a sticking cable, otherwise check for a split in the vachume pipe if fitted as an air leak may cause this, or a loose clip securing the carb, leaking gasket, or a gumed up slide, the standing could have caused the slide to stick if the fuel in the carb had started to go off and become sticky, remove slide and check , remember to replace it the same way as it only fits 1 way

Posted on Jan 31, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

01 Kia Spectra When I start it cold it stays high idle. Have to press the accelerator to bring down the idle When shift into gear it hesitates to go It feels like it wants push gas through but putters


Ok that to me sounds like you need to clean the throttle body it easy buy carburetor clean just srap a little inside the throttle body n clean it that will help you the problem is the trottle body gets dirty sticky and won't idle good n stall remember don't put to much. Just a few spats inside the when you put the hose back it might take a few minutes to start because of the amount also don't accelerat it to high when it start good luck

Oct 03, 2015 | Kia Cars & Trucks

1 Answer

What is wrong wIth my Honda xr 125 idle?


have carb cleaned ethenol kills carbs

Mar 22, 2015 | 2005 Honda XR 125 L

1 Answer

LOSS OF POWER WHEN SHIFTING GEARS IDLE AUTOMATICALLY STARTS RISING REALLY HIGH BUT VERY LITTLE POWER


Every time the RPM rise but no power start with vacuum leak. Start the engine and listen for vacuum leak. The car is equipt with air flow sensor and if air buypas the sensor the engine loses power

Apr 19, 2014 | 2003 Hyundai Santa Fe

1 Answer

2001 Taurus 3.0 dohc idles high sometimes and once in gear transmission seems to shift at idle.


I think it may feel like that because it is idling high. For you high idle problem there are a few thinks you can look at one a vacuum leak. Two look at the throttle body plate and idle air control motor. If the throttle body plate are dirty the seat for the idle air control motor my be dirty. I would try cleaning the throttle body.

Nov 10, 2013 | 2001 Ford Taurus

1 Answer

2008 Ducati 1098s loss of power


check throttle cable and all wiring
by the way im 11 yrs

Jun 23, 2013 | 2008 Ducati 1098 S

1 Answer

2001 Nissan Altima idling high in parking or neutral


I have the same problem with my harrier 3000cc car. We have changed the idling sensor, airflow sensor. air filter, we have had the throttle checked, spark plugs, wiring and nothing works. The smell you are getting could be from your gear box, have it checked out early and if the gear shift is noticeable then you will need a gearbox specialist to open it and change the clutch plates. Good luck.

Aug 23, 2012 | Nissan Altima Cars & Trucks

1 Answer

P0068 on a 2006 Dodge Ram 1500 SLT. Rough "hunting" for idle. Momentary lag/loss of power from a stop. Random RPM changes while at a constant speed. Sometimes it feels like it drops out of gear...


P0068 Symptoms - Engine Light ON (or Service Engine Soon Warning Light)
- Lack/Loss of power
- Engine rough idle Possible causes - Large vacuum leak
- Leaking air duct system
- Mass Air Flow (MAF) poor electrcial connection
- Manifold Absolute Pressure (MAP) poor electrcial connection
- Faulty Mass Air Flow (MAF) sensor
- Faulty Manifold Absolute Pressure (MAP) sensor
- TP sensor not seated properly.
- Faulty Throttle Position (TP) sensor.
- Dirty throttle body
When is the code detected? The Powertrain Control Module (PCM) monitors operation rationality check by comparing sensed throttle position to mass air flow readings
P0068 DODGE Description The Powertrain Control Module (PCM) monitors a vehicle operation rationality check by comparing Throttle Position (TP) to Mass Air Flow (MAF) readings. If, during a self-test, the comparison of the TP sensor and MAF sensor readings are not consistent with the calibrated load values, the test fails and a diagnostic trouble code is stored in continuous memory.

Jul 10, 2011 | Dodge Ram 1500 Cars & Trucks

2 Answers

The idle is very high when i go from park to drive it is very hard ****. and the gears are not shifting the same its winding out . and does not go in to passing gear and using a lot of fuel my first...


Check the vacuum lines, intake, and the idle/air control valve. This can cause a loss in power and fuel economy. The transmission issue sounds like it is either slipping or you have a faulty shift solenoid.

Mar 30, 2011 | 1995 GMC Jimmy

1 Answer

My vstar 1100 doesn't throttle down while shifting gears so I am power shifiting. Also while coasting to a stop the idle stays high till I bog it down with first gear. Is this the throttle position sensor?...


Hi, Prvtpilot199 and the usual suspects are:
1. Throttle cables improperly adjusted, pinched or need lubrication.
2. Idle adjusting screw needs to be backed off.
4. Air fuel mixture adjusted too lean start with 2 full turns.
5. Intake system air leak.
6. Fast idle choke ramp is not releasing.
7. Broken throttle return spring.
8. Damaged diaphragm or slide.
9. Faulty MAP, TPS, ATS, O2, sensors or wiring/connector
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
Yamaha Star 1100 Throttle problems
http://www.starbikeforums.com/forums/49-v-star/1194-rpm-slow-return-idle.html
Yamaha XVS1100 Service Manual
OEM parts for Yamaha
YAMAHA XVS1100 Owner Manual

Sep 27, 2010 | 2004 Yamaha V Star 1100 Custom

3 Answers

Car will not accelerate past 30 miles an hr what is wrong with it?


check your throttle sensor and proper fuel pressure. check distrubutor unit, it tend to fail over times.

Aug 27, 2009 | 2000 Mitsubishi Galant

Not finding what you are looking for?
2004 Aprilia RS 125 Logo

130 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilia Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you an Aprilia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...