Question about 2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic

1 Answer

1999 ultra classi fuel injected twin cam

Magneto Marrelli... When I start it in the morning it fires right up and goes to 1400rpm for 4 seconds, then props to about 850rpm. It struggles to stay running for about 7 seconds then jumps up to 1200rpm and is fine. It goes down as bike warms up. Eventually idleing at 850 as bike is fully warm. It only happens the 1st time u start it then is fine all day. Please help?

Posted by on

  • Gar
    Gar May 11, 2010

    Is the check engine light on?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Harley Davidson Master
  • 41,660 Answers

Hi Bbbabe66, for more information about your question please visit the websites below. Good luck and have nice day.
Harley Davidson Magneti Marelli Fuel Injection Settings
https://www.youtube.com/watch?v=X1a9kBx_Lb4

Posted on Jun 21, 2015

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 2 Answers

SOURCE: Bike running rough 96 Wide Glide

check plugs and wires, also coil my be weak, sometimes a bad ground will cause this also and weak battery. I've had these problems before on my older Harleys that I built

Posted on Jan 16, 2009

  • 1 Answer

SOURCE: High idle below 72 degress

If this is still a problem. I had a similar issues with my 06 Road King. Mine ran extremly hot and the idle was horrible too. On cold mornings five miles in I had to get off the bike because it felt like I was going to burn up. Two years dealing with Harley dealerships, who were completely worthless, and nothing. I even got to the point I told them to come pick the bike up I was not making anymore payments. Well that did not work.

I called a chopper shop, PeteG's in Longwood FL, told them what was happening. I had the carb drilled out, a new breather put on, and pipes (of course those were what the hell). Anyway, since the work was done, I don't run hot, my idle is normal, and fuel consumption has improved by almost six miles per gal. I just hit 43 mp/g this week. Since the repairs were comlpeted about three weeks ago I've put almost 1500 miles on the bike no problems yet.

One note... Do not deal with Harley if your bike is out of warranty. Ask around and find the names of some independant shops. Ask them. The benefit is they usually will give you a straight answer and two they cost a lot less.

Hope this helps.

Posted on Apr 22, 2009

v2iper
  • 150 Answers

SOURCE: 1999 road king wont start

Its your fuel pump if you can't hear it. And its inside your tank. Not a hard fix if you have a book that tells you how to remove it. Alot of procedures to follow to get it right. And yes it does work off a relay.

Posted on Jun 14, 2009

  • 269 Answers

SOURCE: 1998 roadking fuel injected idles to fast after it

One item you might want to check is for a vacuum leak. All the rubber plugs and stuff on the module sometimes wear and leak. If the change was sudden or recent this might also be the culprit.
The IAC motor is not that difficult or expensive to replace if you feel you need to do that just let us know. Hope this helps,

JP

Posted on Aug 21, 2009

wd4ity
  • 4565 Answers

SOURCE: 2009 Dyna Super Glide Custom starting problems:

Does the start quit turning or does it continue to sound like it's turning? If the starter quits turning, I'd suspect the battery. Take it out and have it tested. Usually no charge for this service at most any auto parts house.

If the starter sounds like it's still turning but the engine isn't, that's an indication that the "starter clutch" is bad inside the starter. This is the "one way bearing" unit that turns the engine to start it but then freewheels when the engine starts. I've seen many of them go bad. If the bike is still under warranty, take it back to the dealer before the warranty runs out. At least have a documented complaint of the problem within the warranty period. That way, if the warranty runs out you may can still get it fixed under the warranty.

Posted on Oct 09, 2009

Testimonial: "Very informative and explained the possible issues in plain English very well. I will check your suggestions follow your advice. Thank You very much."

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have overhauled engine for Isuzu bighorn 1998 petrol/gasoline engine. the 6VE1.timing belt is ok. Still it has a had start.


is this the Single head cam or twin version?
no photo of engine, so answers will be weak.

double posted. is this the single cam or twin cam engine?????? per side, the twin cam has 4 cams. 2 /bank.
i can not understand your questions, at all.
ok you overhauled the engine,
nor can i understand , still hard start.
does that mean it cranks slow and turn runs and drive perfectly ?
or cranks fast, but hard to start and runs perfectly?
or does that mean it cranks fast, starts, then misfires and runs crapppy-pappy?
hark, the devil really is in the details, no?

Generic answer.
all the wires and sensors , hoses not put back correctly.
oil full, coolant full, fresh gas in tank,
then you crank engine with no spark (I pull fuses)
and the crank it until oil pressure is good. yah, do that.

if really savvy, we check for top end oiling next. cranked only.


ok looks like oil pressure is good,(I don't want to wreck a new engine) (also check compression on a new engine, to see if we messed up., if not 150psi or more, you timed it wrong)



then we crank it, ok, it cranks and don't start
I check spark and it's timing using my timing light, it's wrong, i retime it, no and its ok. as is ..
ok sparks good, on all 6 cylinders. checked carefully and for static time.

so now start engine on test fuel,
if fails, see above for why.!
ok it runs for say 2-3 seconds and stalls. good.
We yell at the gas engine gods. O'BOY my engine seems to be OK ! progress....

next is fueling , ill stop now, as typing a book on fuel injection
is not easy here.
but fuel pressure is next. on all EFI engines. as is good fuel.
when did car last drive perfectly, 1 month ago,
10 years. what?
if long ago, the gas is bad. as are related parts all gunked up, like filters, and injectors.
and even the pump, or its sock packed in GUNK.
as you can see we have no history on the car, so.
really anything is possible. even vandalism.

btw we never just throw and engine in a car.
we check.:
1: compression, gee even sitting on a pallet.!
why install (6hr labor) a dead engine,?
2: then cranked oil pressure, spark/fuel off line.
same reasons.
3: then if all that is ok, I do check top end oiling now, if not any top end, the cams will not last very long. they will smoke and seize up in a flash.

this is how its done correctly, ask how.

Aug 20, 2016 | Isuzu Cars & Trucks

2 Answers

How do I fix a P1475 exhaust actuator position error on my 2014 harley Davidson electra glide ultra classic after installing an after market exhaust.


Get set up from someone who has died oh machine and they can set the fuel injection system whatever kind of fuel system you have to regulate the amount of fuel your mixing the pipe has changed the timing and other things on your bike you can't just throw pipe on a bike especially a Harley database set up properly retuned the best way is dino

Feb 14, 2015 | 2014 Harley Davidson Electra Glide Ultra...

1 Answer

Have got a joe hunt magneto and i want to put it into my triumph 750 1970 model is there a diagram for this or is there instructions on how to install it


I ran one of those on several 60s-70s Triumphs.....great ignition!

Both plugs fire at the same time so there is no left/right to worry about.

Remove spark plugs and gap .018. Remove timing cover (right hand side of engine) over battery ignition points.
Disconnect and tape (insulate) all battery connected wires. Better yet, unhook battery hot wire from battery terminal.
Hold breaker cam in opposite direction of rotation (advanced position) and rotate engine until the points on #1 cylinder just start to open. Note: Use .0015 feeler gauge.
Remove breaker plate, breaker cam advance mechanism, and dowel pin from internal taper if your model used a dowel pin to position breaker cam and advance mechanism. CAUTION Do Not Rotate Engine. If engine is rotated, reverse rotation until piston is down and the cylinder at least one inch before top center on the compression stroke.
Rotate engine in normal direction of rotation until piston is 5/16 from top center on compression stroke. Install magnetos adaptor plate and adaptor shaft in cam taper. DO NOT TIGHTEN SHAFT. CAUTION 1963 to 1970 Triumph unit construction twins have a different length taper on shaft and internal threads are dissimilar. Suggest checking threads and taper. 1963 to 1970 bolt has BSF 1/4 x 26 threads. 1971 and later bolt had 1/4 x 28 thread. Early shafts are marked with the letter "A". Later shafts are marked with "B".
NOTE: Some applications will require drilling and tapping engine with 1/4 x 20 for better security of magneto mounting adapter. Some customers with severe service report that they heli aced adaptor to cam cover with approximately one inch length bead, top and bottom for security.
Remove Magneto cover. With shaft slightly loose in taper mount Magneto so that points are just starting to open and bolts are approximately in center of slot (for timing adjustment later).
Carefully remove Magneto and tighten center bolt in shaft. Re-install Magneto and time. Install cover and plug wires. Hook up ground wire to a separate kill switch to ground only. DO NOT HOOK ANY BATTERY CURRENT TO MAGNETO.
Point Gap .012 to .015

Aug 02, 2011 | Triumph Bonneville Motorcycles

3 Answers

I have a Briggs & Stratton 18.5 HP Twin Cylinder engine that has no spark. How can I check the magneto? And, there is a wire that goes to the magneto. Should there be 12v to that wire? If I replace the...


It all depends on the model of engine. If it is a twin engine doesn't it have two magnetos.Very unusual for both to go bad It will depend on the type of ignition(points or solid state) The wire going to the magneto could be the kill switch (kills when grounded) Disconnect it and see if you get spark. IF so then it is in your safety/ignition circuit. If you replace magneto usually the gap is .008-.012

Aug 18, 2010 | Garden

1 Answer

Ultra classic starts and runs for about two minutes shuts off


Check the vent in your fuel cap. If the vent is stopped up, a vacuum will build up in the tank and no fuel will flow even with a pump.

Good Luck
Steve

Jul 19, 2010 | 2000 Harley Davidson FLHTCUI Electra Glide...

2 Answers

Cam timing my 2003 yamaha yz450 how do i do it


take magneto cover off find tdc on the magneto and look at the cams it should be after the inlet valve shuts and goes on the firing stroke just put a rod in the cylinder and see if the piston reaches the top off the bore when the magneto is at tdc then its fine buddy any probz im here to answer

Oct 08, 2009 | 2003 Yamaha YZ 450 F

1 Answer

Slow start after warm up.


perform a fuel pressure test at the fuel pressure port.
if is low pressure remove the fuel tank and check return pressure line clips conections

Jun 15, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Bmw 318t1 sport. cold start problem and cutting out.


i would try getting the ecu checked over and check the dizzy cap for cracks.

Jan 21, 2009 | 1999 BMW 318 ti

1 Answer

1988 Accord hard starting


possibility your distributer is on its way out...the cam sensor in it gets hot and isnt sending the correct info...same with the coil ...cech for spark and fuel on next hard start

Oct 01, 2008 | 1988 Honda Accord 4 Door

Not finding what you are looking for?
2000 Harley Davidson FLHTCUI Electra Glide Ultra Classic Logo

245 people viewed this question

Ask a Question

Usually answered in minutes!

Top Harley Davidson Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4521 Answers

Mike

Level 3 Expert

4339 Answers

yadayada
yadayada

Level 3 Expert

76070 Answers

Are you a Harley Davidson Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...