Question about 2006 Aprilia Pegaso 650 Strada

1 Answer

Speedometer the lights are all working but no info on the speedo and there is a small amount of mousture inside the clock itself

Posted by Anonymous on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Aprilia Master
  • 40,748 Answers

Hi, Anonymous for this situation I would call my local dealer or reputable shop's service/parts department and inquire about any possible quick fix/test or parts inquiry. If necessary transport your vehicle to the dealer or shop and have a professional technician take it for a test drive, if it is in running condition, and give you a written estimate of repairs and answer any specific questions you may have about your issue. For more information about your issue please visit the website below. Good luck and have a nice day. DOWNLOAD 2006 Aprilia Pegaso 650 Strada

Posted on Oct 26, 2015

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedo not working at sll no movement even on rrdet


Hey Chris,

No make, model, year... engine, transmission or other clues as to veicular configurations came through with your comment/question...

Assuming you know the history of this (UNIDENTIFIED) vehicle...
herein after called "car"... and no RECENT hands have been working up inside the dash...

"Modern" Speedometers have sending units
(generally located where those speedo-cables USED to be... on the output (tail) shaft of the transmission.

Everything from serious road hazards, old-folks' walkers to plastic bags at HIGHWAY SPEEDS can disconnect those impulse wires...
rendering your speedometer an isolated (useless) space-taker in the midst of your gauges...

Beg, borrow or buy a "spare" sender & put it in place of your existing unit... to see if that changes things...

ELSE

Input your car's info on BBB INDUSTRIES (registration required) and see if they have your SCHEMATIC DRAWINGS to locate any SPECIFIC fuses you could try first.

Hope this helps.

BBB Industries Premium Alternators Starters Power Steering Products


RockAuto Parts Catalog

Jul 02, 2016 | Cars & Trucks

1 Answer

Speedo stops working at times and when turning on ignition, the needles refrain from wiping across the clocks. then all of a sudden all works fine again. What to do?


Hi, William and the usual suspects are:
1. Contaminated speedometer sensor.
2. Corroded, broken or loose connector pins/sockets in the wire harness between the speedometer and the ECM and the sensor.
For more information about your issue and valuable "FREE" downloads please visit the websites below. Good luck and have a nice day.
Speedometer sometimes doesn work
Star Speedometer not working
Speedo and tach are not working
How to FIX For Scooter Speedometer and odometer Stopped Not Working

Mar 11, 2016 | Motorcycles

1 Answer

1981 kz 1000 4 cylinder


Speedo probably has a running light wire going to it to iluminate it at night, the speed sensor itself is cable driven. As for the tach it is probably cable driven too and needs a running light to power it. Look inside your headlight and plug the tach/speedo wires into a ground and running light wire.. once the headlight is off follow the running light (small bulb)'s wires, those are the wires you need.

Sep 10, 2012 | 1981 kawasaki Csr 1000

1 Answer

The speedometer is not working inside the car


Hi, you probably have a broken cable or a bad speedometer..

Check the cable that runs from the gearbox to the dash, (the connection IN the dash looks like a green receptical for a light bulb, its HARD to miss) make sure that it turns properly and that, when in its correct position, turns the small brass coloured part inside the speedo mechanism (the end of the cable should be a square-ish prong that is should insert into a hole in the extreme rear of the speedometer mechanism).
If the unit doesnt work (if the cable is fine and the mechanism bares no apparent defects then you have to replace the speedometer)

Jul 24, 2011 | 1989 Toyota Camry

2 Answers

Speedo starts off fine for a couple of miles and then moves round the clock to max speed slowly. Next time out same beginning but it sticks at 65! Any idea? Chris


Thsi is likely a problem inside the speedometer guage internally with the driven gears. They use drive motors to drive the needles inside. If it is pretty continuous then the speedometer is in trouble and will require a speedometer specialist to rebuild the unit or replacement of the unit.

May 10, 2010 | 1999 Bentley Arnage

3 Answers

1995 Buick Lesabre Speedo inop


It may be a faulty speedometer with a short inside, or a short on speedometer wirings or connector.

Whenever car vibration cause the wiring to short, there you lose speedometer and trans functionality.

You need to access the speedometer connector and wirings to
instrument panel to fix this.

Feb 01, 2009 | 1995 Buick LeSabre

1 Answer

My speedometer reads 0mph at all times


i believe you speedo cable is broken, if it is electronic you either have a broken wire since the clock is flashing also or a bad speedo sensor.

Jan 25, 2009 | 2001 Honda CBR 929 RR Fireblade

4 Answers

95 subaru impreza ;speedometer quit,engine light stays on


i had this problem with mine if your cable spins wen the car is moving its not the gear box end or the cable its the speed sensor in the speedo its self its very easy to fix you have to strip the speedo out of the case the sensor is only small and on the under side of the speedo the sensor is about 50 mm long and 10 mm wide change that and it should be ok
oh remember to reset your ecu

Nov 15, 2008 | 1995 Subaru Legacy

1 Answer

Speedometer senser is jumping erraticaly


I had an Audi doing exactly the same. What happened was that through time, especially if the vehicle gets older with a higher milage, dust and dirt gets into the speedometer itself and causes all the small gears to get sticky. I opened it and lubricated all the small moving parts inside and all were ok. Try it before buying a new speedometer. (I'm talking about the speedometer clock itself) Hope this info might help.
Akirfa

Sep 02, 2008 | 2002 Hyundai Santa Fe

Not finding what you are looking for?
2006 Aprilia Pegaso 650 Strada Logo

Related Topics:

78 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilia Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Fabrice Wolters

Level 2 Expert

163 Answers

Are you an Aprilia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...