Question about 2006 Yamaha MT-03

Open Question

2006 mt-03 the instrument cluster has stopped working. the only bit of life is the imobliser lamp.Thanks

Posted by on

1 Suggested Answer

  • 1 Answer

SOURCE: mt-03 km/h not mph

Place the key in the ignition switched off. Press and HOLD both the select and reset buttons before turning the key to the on position. Now let go of both buttons and the on screen digits should start flashing. Now press select to toggle between kilometres and miles per hour.

Posted on Jun 26, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Anyone have a wiring schematic of yamaha mt-03 2006


Sorry I do not have one but I suggest that you buy a service manual and you will get one that way for not too much money.

Sep 16, 2014 | Yamaha MT-03 Motorcycles

1 Answer

Mondeo dash diagnostic codes


http://www.manualslib.com/manual/611281/Yamaha-Mt-03.html?page=20#share

Apr 18, 2014 | 2006 Yamaha MT-03

1 Answer

Bmw instrument cluster GS650 2005


If it is just the light that has stopped working, then it cld be a fuse or the bulb inside has simply burned out. If it's the light, the rpm, the mph, and everything inside the cluster that has stopped working, then you either have a bad cluster and will need to replace it. This normally happens when there is a short in the wiring that leads from the wire harness to the back of the cluster. Sometimes, after you find and fix the short, the cluster will begin working properly but the chance of that is very rare. You can use a volt meter to find the short. Make sure if a short is the problem you fix it before plugging in the new cluster or you will just fry the new one as well. Also check the voltage regulator to make sure it is working properly. Hopefully, it is just the light and you can replace the bulb. Good luck

Sep 17, 2013 | BMW F 650 GS Motorcycles

1 Answer

Yamaha mt 03 engine light flashing


from my experience that spells code 55

Jul 25, 2012 | 2006 Yamaha MT-03

1 Answer

2009 Yamaha MT 03 blew the main 10amp fuse it stopped & all instrument lights went out. I changed the fuse it was ok. I rode apr 4 miles stopped for a few minuets then started it again rode it for...


i had to run a inline fuse on my bike with a 15 amp fuse, but there is a short somewhere. check all connections at solenoid make sure nothing is touching

Mar 18, 2011 | Yamaha MT-03 Motorcycles

1 Answer

Brand new MT-03 dies on my while driving!


They apparently fixed nothing . Call them again. Where are you?

Jun 02, 2009 | 2008 Yamaha MT-03

2 Answers

Mt-03 km/h not mph


Place the key in the ignition switched off. Press and HOLD both the select and reset buttons before turning the key to the on position. Now let go of both buttons and the on screen digits should start flashing. Now press select to toggle between kilometres and miles per hour.

Mar 23, 2009 | 2006 Yamaha MT-03

3 Answers

Yamaha mt 03 will not turn over, shows electrical problem


Have you placed it in ,say 2 nd gear with clutch lever pulled in, ignition on run alongside, jump on & release clutch lever?---If this has Automatic transmission disregard the Info above!--Proceed then to carry out Compression test of engine, via spark plug hole & Note down ther reading ., IF it appears low on the guage, then BEFORE YOU Dismantle Engine ENSURE no Person has Blocked your Exhaust outlet pipes with Potato or some other "Prankster Method!--If by chance Your Engine has SIEZED , Squirt in Oil With Kerosene 1/4 cup full & allow it to settle, IF THEN, Engine turns over, recheck OIL LEVELS & Quality of OIL!-May need to drain & pour in fresh oil!-Don't be Despondent, these are Challenges in Our Lives, You will learn much now that will remain with You throughout your long life!--Stay Upright"-Des.

Jan 05, 2009 | 2006 Yamaha MT-03

1 Answer

My MT-03 is vibrating an making a bit of a rattling sound


Hi Mattandem

Best approach to working out these sorts of problems is to pull the tank off again,and carefully check all your work. Particularly any new wiring, or wiring that you may have disturbed whilst installing the grips. Check also that all of the rubber mounts for the tank are correctly in place. Cabling has a tendency to rattle quite loudly against any and everything on your bike. Vinyl insulation tape lagging new cables to existing looms is an effective way to stop them rattling, and strategically placed cable ties, particularly about the front end and headlamp fitting. Good luck with the de-rattle. Let me know how you got on. Cheers

regards
robotek

Dec 06, 2008 | 2008 Yamaha MT-03

1 Answer

My MT-03 is vibrating an making a bit of a tattling sound


Hi mattandem

I have replied already to your other post... didn't see this one... not sure what the vibration through the peg could be caused by as they mount directly to the frame. The frame being a substantial structure to the bike means that the vibration is being created anywhere on the frame,and you are feeling it in your foot peg. The only thing that comes to mind is that perhaps one of the tank mounting rubbers is not seated properly, or inadvertently rolled away on the garage floor. This is what I would be checking for.

regards
robotek

Dec 06, 2008 | 2008 Yamaha MT-03

Not finding what you are looking for?
2006 Yamaha MT-03 Logo

Related Topics:

44 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

D. E. Hev

Level 3 Expert

1059 Answers

mikeuk

Level 2 Expert

61 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...