Question about 2005 Hyosung GT 650 R

1 Answer

Have a 2007 650R

I got electrical for the display but only a clicking sound fromthe battery area. It won't start have any ideas why??

Posted by on

  • Anonymous Apr 18, 2009

    have same problem. when i hit the startbutton i only get a clicking noise at the right side area near battery. Have enough powersupply to light up displaylights and turnsignal and headlight. I recharged battery and bike started at first attempt but 3 days later i encountered same problem of not starting. So i guess its the battery wich runs flat and doesnt recharge while riding ??

×

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 66 Answers

Sounds lie the battery has a low state of charge, not providing enough cold cranking amps to turn the starter motor under load.

Posted on Feb 19, 2009

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Not start hear clicking sound behind glovebox


-Possible battery cable has bad connector, corrosion and or bad starter.

Good luck

Mai

Mar 25, 2014 | Honda Accord Cars & Trucks

1 Answer

Audi a3 no start


How do you know the battery is fine? Sure sounds like you have a weak battery- the symptoms are all the electrical bits work- except starting the car. All your electrical systems don't need much current, but your starter needs a lot. If your battery isn't fresh then your car won't start, but everything else will appear to work. You can test the battery by looking at voltage across the terminals when you try to start the car, if it's less than 12 volts your battery needs to be replaced. If your battery is more than 5 years old it should be replaced anyway. Good luck, let us know how it goes.

May 13, 2013 | Audi A3 Cars & Trucks

1 Answer

New battery won't start clickig sound buick century 99


If the clicking sound is coming from the engine area, it is most likely the starter solenoid. If you are sure that the battery is fully charged, then you need to clean your cable ends with a small metal brush and a mix of baking soda and water. the surfaces should be metal looking not chalky or green. It sounds like you just are not getting a good connection. You could also replace the two bolts on the cables.

Feb 08, 2013 | 1999 Buick Century

1 Answer

Clicking sound but engine won't start


This actually does sound like the battery is low on charge. A battery which is quite low on charge will still light the headlights and run many other electrical accessories, but will not engage the starter (which requires much more power than other accessories).
I would start by making sure that an electrical device, such as interior lights, glove box lights, trunk light or something else has not been left on. Then carefully jump start the engine. It is also possible that the battery might need to be replaced for not holding a charge.

Nov 25, 2012 | 2006 Subaru Outback

1 Answer

Maxima won't start, wiring, key lock cylinder


It sounds like your starter relay could be bad.

Jul 14, 2012 | 1989 Nissan Maxima

1 Answer

2005 honda metropolitan won't start


Hi, Anonymous before testing any electrical component in the Starting System it is "IMPERATIVE" that you have a fully charged battery of 12.5 volts or more and be able to pass a proper "LOAD" test if necessary, you may have a preliminary reading of 12.5 volts or more but little or zero amperage, the battery is faulty and must be replaced. AGM type batteries fall into this scenario more so than lead acid batteries.
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter.
4. Bank angle sensor needs a reset or is faulty.
5. FOB battery low or dead.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand, clutch, neutral safety switch.
9. Security alarm needs a reset.
10. Starter relay, solenoid, starter motor or circuit wiring faulty.
11. Starter armature or field coils have failed.
12. Main fuse or circuit breaker may be blown or faulty.
13. Faulty ignition relay.
14. The electric starter is working but starter clutch has failed.
15. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need for viewing or printing please click on the blue links below. Good luck and have a wonderful day.
Scooter Troubleshooting Scooter won start All about Scooters
Scooter won start
http://www.family-motorsports.net/GY6-50cc-150cc.pdf
http://www.partsfish.com/page/oem-parts-for-honda
http://absolutelyscooterparts.net/pdf/CGEN_dawg_scooter_manual.pdf

May 20, 2012 | 2006 Honda Metropolitan

2 Answers

I have a 2004 pontiac sunfire with a few problems. First, when I turn the ignition to start the car all I get is a fast-paced clicking sound from the dash area and the engine doesnt even turn over. This...


as fo the idle, there is a IAC ( idle air control to maintain idle. you may have to remove this and clean the carbon out of it, and the intake as well. as for the clicking there are 3 solutions to fix it. battery if it is ok, the solinoid is bad on starter or the starter itself. but it does sound like a bad starter solinoid, because a bad battery will make the same clicking from solinoid. but make sure battery is ok first. when engine is off voltage at battery should be at least 12.6 or better. when running and alternator is ok, it should read about 14.2 to 14.7 if lower then 14 volts alt. is bad. have a very good day !! hope this helps!

Jul 09, 2011 | 2004 Pontiac Sunfire

1 Answer

Electric promblem: The battery is being drained.


try checking ur alternator its what charges ur battery..Tip start ur car remove the pos cable from battery while car is on and if it turns off its ur alternator

Feb 02, 2010 | 2004 Volvo XC70

2 Answers

No Electricity


Will it jump start?
if so bad battery, if not bad connection..

Sep 13, 2009 | 1999 Honda Accord

Not finding what you are looking for?
2005 Hyosung GT 650 R Logo

321 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hyosung Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

yadayada
yadayada

Level 3 Expert

77169 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22258 Answers

Are you a Hyosung Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...