Question about 2006 Aprilia Leonardo 300

1 Answer

Hard to start from cold

Hi My Leonardo 150cc 1999.28k kms. Takes ages to start,but when it does, it runs well. Ticks over good. Slow runs well. Good at full thottle too. Starts first time when warm. Plug is new. I think maybe problem is with the fuel taking time to come up from tank to carb. Any sugestions as to what the trouble could would be welcome. John

Posted by on

  • brownboots Feb 03, 2009

    Hi Knight. thanks for quick reply. No choke control on this model, must be automatic. regards John

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Aprilia Master
  • 767 Answers

Hi brownboots,

Have you tried using the choke to start it when its cold?

Secondly the air-fuel mixture may require to reset, but before you do tht after a spin , remove the plug and examine it ....it should be brownish and dry!
Also make sure the saprk plug is of the correct type per manufacturers specs.

Hope this would help.

Knight.

Posted on Feb 02, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 125 aprila Leonardo the spanner and oil light stay on and so does my warning light.but the oil is full and my bike wont start because it's all electric is there any way I can start it


Hi, Ben you may have triggered a fault code that's keeping the bike from starting for this situation I would call my local dealer or reputable shop's service/parts department and inquire about any possible quick fix, answers, or parts inquiry. If necessary transport your bike to the dealer or shop and have a professional technician take it for a test drive, if it is in running condition, and give you a written estimate of repairs and answer any specific questions you may have about your issue. For more information about your issue please visit the website below. Good luck and have a nice day.
http://www.apriliaforum.com/forums/showthread.php?284376-Mana-ECU-Error-Codes
aprilia leonardo 125 1997 service manual pdf 8 43 MB
Products at Aprilia Genuine Parts Aprilia Parts Aprilia Spare Parts...
2003 Aprilia leonardo 125 150 250 Owners manual

Dec 09, 2015 | Motorcycles

1 Answer

My aprilia leonardo 1996 150 cc engined.scooter does not start easily unless it is warm.i hav to start it with easystart when cold.is this a choke prob.


Hi, Anonymous for this situation I would call my local dealer or reputable shop's service/parts department and inquire about any possible quick fix/test or parts inquiry. If necessary transport your vehicle to the dealer or shop and have a professional technician take it for a test drive, if it is in running condition, and give you a written estimate of repairs and answer any specific questions you may have about your issue. For more information about your issue please visit the website below. Good luck and have a nice day. https://www.tradebit.com/filesharing.php/search/0/2005+aprilia+leonardo+125

Aug 25, 2012 | 2005 Aprilia Leonardo 125

1 Answer

My Leonardo Aprilia 150 can't attain its top speed, it just stops at 60km/h?


Hi, Anonymous and the usual suspects are:
1. Severely drained or faulty battery.
2. Faulty regulator/rectifier or high output coil.
3. Faulty power valve, solenoid or installation.
4. Clogged air filter or exhaust.
5. Cracked or incorrect float level.
6. Float needle is not seating.
7. Faulty reed valve.
For more information about your question please visit the website below. Good luck and have a nice day.
DOWNLOAD Aprilia Leonardo 125

Jul 27, 2012 | Aprilia Leonardo 125 Motorcycles

1 Answer

Aprilia leonardo 125 2000 fork oil capacity


Hi, Anonymous I am sorry you can't find the first and best tool you ever bought for your Aprilia but despair not for a mere $10 you can download another one. For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2000 Aprilia Leonardo 125

Jun 08, 2012 | Aprilia Leonardo 125 Motorcycles

1 Answer

Bike ticks over on choke but won't run if a touch


Hi, Gerard and the usual suspects are:
1. Fuel cap or fuel tank is not venting properly.
2. Fuel filter clogged.
3. Fuel line pinched or kinked.
4. Float needle and seat sticking.
5. Float level too low.
6. Carburetor bowl vent line clogged/blocked/pinched.
7. Idle adjusting screw set too low.
8. Air/fuel mixture screw set too lean.
9. Idle port, transfer ports, slow air jet clogged.
10. Slow fuel jet clogged.
11. Faulty fuel pump.
For more information about your issue and valuable "Free" downloads that you will need please Click on the links below. Good luck and have a nice day.
http://viragotech.com/newtech/Only%20starts%20idles%20on%20choke%20dies%20when%20you%20give%20it%20gas%20(SOLVED).htm
Yamaha XV535 runs only on idle choke
Yamaha XV 535 DX Virago Service Manual
OEM parts for Yamaha
http://www.starmotorcycles.com/assets/service/manuals/2005/LIT-11626-18-21_1000.pdf

Oct 08, 2011 | 1994 Yamaha XV 535 Virago DX

1 Answer

My aprila leonardo 125, takes ages to respond to the throttle when 1st started. then takes ages to reach 50mph. iv been told the carb needs cleaning, bu then heard it could be a crack in the air in take...


Hi, Danny and the usual suspects are:
1. Throttle cables misaligned or misrouted (may also affect idle speed).
2. Damaged or restricted fuel tank venting system.
3. Inlet system air leak.
4. Vacuum piston malfunction.
5. Accelerator pump leaking or no output.
6. Plugged bowl vent.
7. Fuel level in bowl too low.
8. Restricted fuel supply passages.
9. Plugged jets or passages.
10. Worn or damaged needle or needle jet.
12. The enricher valve not seated or leaking.
For more information about your issue please visit the websites below. Good luck and have a nice day.
https://www.tradebit.com/filesharing.php/search/0/2005+aprilia+leonardo+125

Aug 04, 2011 | 2005 Aprilia Leonardo 125

1 Answer

Aprilia 150 leonardo, flat battery and not charging, only 11.5 volt when running. Is it the rectifier and where is it fitted to bike? Thanks


Hi, J33pkk and the usual suspects are:
1. Voltage regulator/rectifier not grounded.
2. Engine ground wire loose or broken.
3. Faulty voltage regulator/rectifier module.
4. Loose or broken wires in charging circuit.
5. Faulty stator and/or rotor.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD Aprilia Leonardo 150

Jul 07, 2011 | Aprilia Leonardo 125 Motorcycles

1 Answer

What are the valve clearances on an Aprilia leonardo 125 (1998)


Hi, Gambothejamb I am sorry you can't find the first and best tool you ever bought for your Aprilia but despair not for a mere $10 you can download another one. For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 1998 Aprilia Leonardo 125

Mar 17, 2011 | 2005 Aprilia Leonardo 125

Not finding what you are looking for?
2006 Aprilia Leonardo 300 Logo

Related Topics:

292 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilia Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4471 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Are you an Aprilia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...