Question about 2006 Suzuki Boulevard S83

1 Answer

I run the batt down while tring to start, tried to jump, now the lights or nothing comes on when hooked to charger

Posted by Anonymous on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 37 Answers

Supposed to be under left hand side cover on 2005 S83

Posted on Jul 07, 2015

2 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 3230 Answers

SOURCE: I have an 89 GSX-R, won't start and lights/dash don't work

Hi there,

Well it seems that due to high voltage your bikes fuse must be blown, so suggest you first of all you check the fuse on your bike, fuse box is in the front, you have another set under your left tail fairing, which needs to come off, to get to the other fuse..... Follow your user manual to check location of your fuse box.

Post further comments for more help...

Good Luck!!

Thanks

Posted on Aug 28, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Motor blows fuse


there is a short in the system that is connected to that relay/fuse. Could also be melted wires if you tried to ever jump start it from a car, start position on a charger or jump start box. Jump starting a motorcycle should never be done. The gauge of wires on a motorcycle are much lighter than vehicles.
It is VERY rare but i have seen batteries that are reversed polarity. Check to make sure battery is 12v + when you test it. Not 12v -

Apr 03, 2014 | 2007 Suzuki Boulevard S40

1 Answer

05 dyna starter solenoid clicking, won't start or turn over.


Hi Anonymous, and the usual suspects are:
1.Ignition/Light Key Switch not in IGNITION position.
2.Engine Stop switch in the OFF position.
3.Discharged battery, loose or corroded connections check negative cable at both ends. (solenoid chatters).
4. Bank Angle Sensor tripped and Ignition/Light Key Switch not cycled to Off and then back to on.
5. Starter control circuit, relay or solenoid faulty.
6. Electric starter shaft pinion gear not engaging or over-running clutch slipping.
7. Security alarm not disarming
For a prime suspect please visit website below and good Luck.
Harley Diagnostic Codes 04 to Present

May 14, 2013 | Harley Davidson XLH Sportster 883...

1 Answer

The charger doesn't do anything. I've charged the charger then hooked it up to the battery (pos on pos, neg on neg) then tried to start the car. No reaction whatever. Is there something else I


It's possible you may have a poor connection from your car to your car battery. Check to make sure both battery terminals are on your battery tight. Tighten them if necessary, then try again. If either one was loose, that should fix the problem. Then there may be nothing wrong with your battery charger.

Jan 17, 2013 | RoadPro Road Pro 12 Volt Dc Portable...

1 Answer

2005 dodge ram wont start


Several Things
Check For Loose Ground Cable (other end not battery end.
There Is Also A Junction Involved (ground) Where Engine And Body Grounds Come Together--LOOK AT THAT FIRST.

Sep 25, 2009 | 1998 Dodge Ram 1500 4WD

1 Answer

Car will not start with brand new battery. Must jump.


check cable that runs from the starter to the batt, also check for proper ground to chassis and engine.

Jul 18, 2009 | 2000 Volkswagen Beetle

1 Answer

Presario f700 no fan/lights = nothing at all. The charger works


try to jump green and any black wire from the power supply...if the fan dont work..power supply is damage..need to change..

Jul 14, 2009 | HP Compaq Presario F500 F700 and G6000...

1 Answer

My Bike shut down while it was running fine!!


Check the voltage at the battery w/ a voltage meter...4 bucks at Harbor Freight...I doubt you have enough voltage to spin the starter. To prove my point put some jumper cables on the batt hook to a 12 volt source, cycle ,car,truck (engine off on donor veh)..should fire up..check tightness of all batt connections...I had a battery die right in the middle of a ride one time,and it was a harley....so if it starts w/a jump, time for a new batt...good Luck to you friend.....Tim

May 03, 2009 | 1993 Harley Davidson XLH Sportster 883

2 Answers

2007 Hyundai Elantra has to be jump started. Battery is fine


from your comment,theres 3 things that can cause this,loose batt.post connection,weak batt.or something in elect. circuit that stays on after car is off and drains batt.,like underhood light,dome or truck light,what u can do is when u park car unhook batt. cable,make sure batt. is well charged,hook it up next day if car starts,its something that drains batt.in car! if it doesnt start,batt. needs replacing.i ruled out starter,dealer should have checked it to see if it was pulling too much amps,and that its easy to jump.

Mar 29, 2009 | 2007 Hyundai Elantra Limited Sedan

Not finding what you are looking for?
2006 Suzuki Boulevard S83 Logo

Related Topics:

86 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

75051 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...