Question about 2003 Triumph Speed Four

Open Question

Triumph speed four speedo problems

I have 2003 triumph speed four. Speedo started reading erratically then stopped altogether. Since then I have replaced the speedo sensor drive, tried different clocks, two new batteries, ecu unit. Still no speedo, at wits end with the damn thing!!!! Help please..................
Many thanks sean

Posted by on

  • whitegamer Apr 18, 2009

    i have the exact same problem... started with eratic readings and put new speedo sensor in.. then ecu on bike was causing fuel pump issues so put new ecu in and now have no speedometer... works perfectly with computers off different bikes and with old computer but not with new one.... if you find an answer please post

×

3 Suggested Answers

  • 104 Answers

SOURCE: SPEEDO CABLE BROKEN IN SPEEDO DRIVE HOUSING CBR 125 R 05

take out the front wheel remove the drive it should tap out with a bit of gentle tapping they are not that tight fitting

Posted on Feb 07, 2009

jakeslimco
  • 56 Answers

SOURCE: I HAVE SOME TROUBLE WITH MY TRIUMPH DAYTONA 600

obviously you have some wire crossed straight to the positive side coming off the battery.. (probably before the ignition) trace the wire back from the speedo to make sure.. i recommend getting a wiring diagram to speed the process and make life simple...

you messed with any of the electrical?

Posted on Aug 24, 2009

  • 1 Answer

SOURCE: Hi having problems with the speedo on my 2002

This is a common problem with the Daytona's 2002+. Typically its the charging system and if the battery level gets below 12v the instrument panel will not function properly (LED display will read or flash something other than what is normal). Recommend charging the battery and checking the voltage @ the battery while running. If voltage drops as RPM increase: Replace reg/rect. The Stator my also go bad too. Too T/S (remove tail section disconnect the 3 wire connector coming from the stator and pin check a/c voltage across two pins at a time. check condition of connector and wires, if it feels stiff and brittle replace wire loom and check 3 pin connector under the fuel tank. If still bad, should be Approx 45v a/c @ idle, replace stator OR send it out for a re-wind. It's cheaper more durable and you get a 1 year warranty. I recommend Custom re-wind for this.

Owner of a 2002 50K+ mile and still runs like new

Posted on May 04, 2010

Testimonial: "Thanks I appreciate your advise,"

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Triumph Daytona 955i speedometer reading approximately 50% faster than it should


Hi, Neil you got apples and oranges here for this situation I would call my local dealer or reputable shop's service/parts department and inquire about any possible quick fix, answers, or parts inquiry. For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
Triumph Daytona 955i 2002 Service Manual
http://www.bikebandit.com/oem-parts/2002-triumph-daytona-955i/o/m21184
Triumph Daytona 955i Handbook
Triumph Daytona 955i T507 99 00

Sep 02, 2016 | Triumph Daytona 955i Motorcycles

1 Answer

Speedometor stopped working


Hi, Gary you may have a faulty speed sensor or broken drive cable for more information about your question and valuable "FREE" downloads that you will need please visit the websites below. Good luck and have a nice day.
Speedo and odomoter not reading right
http://meiguohosting.com/How-to-fix-a-malfunction-speedometer-for-your-2001-Triumph-Trophy-1200
speedometer cable
Triumph Trophy 900 1200 1990 2004 Factory Service Manual PDF Download...

Mar 26, 2016 | 2001 Triumph Trophy 1200

1 Answer

Motorhispania rx125


HI Reece,

I had the same problem with my RX125r, the speedo would jump all over the place and cause the bike to buck and jump. Try looking on the speed sensor cable for any signs of damage. mine had a small tear right next to the fron wheel which allowed for water ingress causeing the speed sensor to read the incorrect value.

I bought a new cable for about 30 pounds and its been fine ever since, still occasionally get the CDI NO CDI error though. Hope this is of some use

Jan 28, 2013 | Motorhispania Motorcycles

1 Answer

How to change from mph to kph


As the triumph is a British bike, the speedo reads in MPH. You can get stickers off the internet (ebay) that you can stick on the speedo glass to remind you of the KPH speeds.

Also be aware that my Triumph speedo from around 12 years ago read faster than I was actually doing any way, even at speeds of only 50kph!

Jul 11, 2011 | Triumph Street triple Motorcycles

1 Answer

I have a 97 harley flhri and my speedometer only work sometimes or it goes erratic and reads the wrong speed. Tach is working fine. Any suggestions?


Your speedo head is either bad or your speedo drive cable is bad. Remove the cable and check it. If it's good, then the speedo head is going bad.

Good Luck
steve

Aug 27, 2010 | Harley Davidson FLHR - FLHRI Road King...

2 Answers

I have a triumph daytona 650 speedometer problem


Sorry I don't have a solution, but I have a similar problem. At idle, I run about 14.2 volts and it stays that way up to around 5k, don't go higher in my garage. Anyway, my problem is when my fan kicks on. I have seen my volts drop into the low 10's when fan kicks on. If it is hot out and I am in dealing with lots of stop and go traffic, my fan will kick on a few times...normal so far. But, if this happens too many times without a good stretch of riding in between, my speedo will kick off or go to 188 on the gauge when the fan kicks on. As soon as I pull out the RPM's increase and all is well, but sometimes, I will actually loose my speedo all together. If I shut the bike off for a minute then start it back up, the speedo works fine. Any ideas???

Apr 05, 2010 | 2005 Triumph Daytona 650

1 Answer

Speedo shows 0 when moving on 2002 model


follow the speedo cable make sure it properly in place on the front wheel and speedo dial and if it is broken you will need to replace it or have it fixed

Dec 13, 2009 | 2001 Triumph 955i Speed triple

1 Answer

After starting the bike up and moving away the digital speedo stays on 0 and i have to keep stopping switching it of and restarting until it works


This is a known issue with Triumph Triples from 2002/2003 - there was a 'feature' in the ECM code called speedo error check which looks at the battery voltage and disables the speedo if below boundaries.
However this feature was extremely problematic from the very outset - even brand new batteries would suffer this issue.
It is exactly as you described - typically at first start it will disable - speedo reads zero; a subsequent re-start will restore. No in between - either works or doesn't work (a reading that is inconsistent to actual speed is more likely to be a speed sender issue).
Triumph received so many complaints that they disbaled the feature in subsequent revisions.
The solution is to have your dealer upload the latest edition of 'tune' for your model into your ECM.
Unfortunately this is not something you can do yourself.
Depending on your relationship with dealer, some will do this free - or charge a nominal fee around $50.

This will 100% fix your problem.

Aug 21, 2009 | 2003 Triumph Sprint RS

Not finding what you are looking for?
2003 Triumph Speed Four Logo

Related Topics:

535 people viewed this question

Ask a Question

Usually answered in minutes!

Top Triumph Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4497 Answers

yadayada
yadayada

Level 3 Expert

63291 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Are you a Triumph Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...