Question about 2003 Yamaha YZF-R6

1 Answer

Engine won't start

I was riding along, the engine light came on, about 10 seconds later my dials turn off, the engine runs for another 30 seconds then sputters off. I turn the key to the off position then back on, the dials come back to life but my mile indicator is not fully shown. Also the bike will not sart. I press the starter button and all I hear is clicking from the starter. What do you think the problem is.

Posted by on

  • 1 more comment 
  • nickadomat Jan 13, 2009

    It is a 2003 Yamaha R6

  • nickadomat Jan 15, 2009

    It ended up being my connections to my computer chip, I guess the computer has a kill switch if it senses trouble. Thanks bthoma 

  • chaz10 Mar 08, 2009

    i have the same problem where can i find the computer chip?

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Check all your connections and make sure they are tight and not all corroded.

Posted on Jan 13, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 2007 xb12s. Turn it on, injector light goes off, start it and within 30 seconds, this red light comes back on and stays on. After a hard ride, the fan does not turn on either now. Runs ok apart...


That red light is the CHECK ENGINE LIGHT. It comes on to WARN YOU THAT SOMTHING IS WRONG. Hard faults where the light stays on hard like that are usually SERIOUS. Take it in to have it looked at or buy yourself a ECMSPY/cable package so you can look at it yourself.

Jun 03, 2012 | Buell Lightning XB12S Motorcycles

1 Answer

I have a 2007 electra glide classic. Problem began, I accidently hit the kill switch and the ignition switch at the same time and noticed a "diagnostic code"... just the word diagnois, in the faring...


Hi Anonymous, call, take a ride or trailer your bike over to your local dealers service/parts department, I'm sure they will be happy to take your Harley Davidson for a test ride if necessary/possible and offer professional advice and assistance concerning your issue. Good luck have a nice day.

May 01, 2012 | Harley Davidson FLHTC Electra Glide...

1 Answer

Engine starts fine, runs fine for about 5-10 minutes of various speeds. Then it shuts down suddenly regardless what trottle possision. Engine will start right away again, but promblem will accure after few...


Could be so many things, I know on modern Harleys there is a shut off relay that turns off the engine if the bike is on its side. If that switch goes out, the motor won't run. Probably have to take it to the dealer.

Jul 08, 2011 | Honda Fusion Motorcycles

1 Answer

When rideing. If I twist throwtle.to go.a little faster small engine light comes on. Inside speedo. When I ease off. 10 seconds later it goes off. Bike runs fine.


You might be low on oil and losing pressure at higher revs causing the oil light to go on.
Find out what light it is so you have a better idea what's going on!

Mar 02, 2011 | 2005 Harley Davidson FLSTN- FLSTNI Softail...

1 Answer

2000 road king code 16 bike starts but won't stay running. not quite sure how to pull codes but it seems like I have a code 16(or I put it there during testing). crtank and cam sensors seem ok. resistance...


Code 16 indicates that the ECM has seen a battery voltage of less than 6.2 vdc or higher than 15.5 vdc. The most common cause of this is loose or dirty battery cables or shorted rectifier.
To access codes, turn the ignition switch on for about 3 seconds (one second after the fuel pump stops running) then turn the ignition switch off for three seconds. Repeat the above procedure. Then turn the ignition switch on again and about 8 seconds later the codes will start to flash through the check engine light.
If there are no codes present or there is a code and it does not appear again the code will clear its self in 50 start/run cycles. (Start/run cycle is defined as engine running for at least 30 seconds and off for at least 10 seconds.)

Oct 11, 2009 | 2000 Harley Davidson FLHRCI Road King...

1 Answer

Engine cutting out whilst riding along


Hi
If all the electrics go off then :-
A) Check tightness of battery terminals & condition of battery
B) Check for dodgy fuse or dirty connections
C) Check voltage across battery terminals when engine running - should be at least 12.5v rising with increasing revs to 15v max - if not then suspect the regulator/rectifier unit or the wiring from it to battery

I hope this helps, if so please mark as helpful.
Positive comments always appreciated

Ride Safe
Bike-Doc

Sep 19, 2009 | 1991 Honda CBR 250 RR

1 Answer

I was riding along and it was like the kill switch was hit.


spark plug buddy try new ones and get back to me

Sep 16, 2009 | 1986 Honda VT 1100 C

Not finding what you are looking for?
2003 Yamaha YZF-R6 Logo

Related Topics:

216 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

mikeuk

Level 2 Expert

61 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1128 Answers

D. E. Hev

Level 3 Expert

1132 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...