Question about 2006 Hero Honda Glamour

1 Answer

Morning start problem

My Glamour is getting starting very quickly in any cold environment. but the engine getting mis-fired till about 5Km. when engine is too hot no problem.

one mechanic told me it's due to Spark plug cap and the electricity leaked outside due to Oxide on connectors. He cleaned but the problem same.

other person told me it's because of my air screw has been opened bit more and have to close it.

Please tell me is it due to Plug Cap issue or Air screw?
If it is due to air screw, after adjusting it will my millage go down?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 2 Answers

Hey Bro, Your mechanic is wrong cause, if it is due to spark plug problem then it will continue your entire ride not for only first 5km.

Now come to the point for miss-fire, here you check these things:

1) Check your fuel.is it pure or not. Make sure that your fuel dose not contain Kerosene.

2) What fuel you are using Petrol Or Octane? If you are using petrol only then mix some octane with petrol(4:1) 4litter petrol & 1litter Octane.

3) Do not adjust your air screw. It will lead you to a serious performance problem.

4) Clean your Air Filter With An Air Blower.

5) Finally change your spark plug with a new one.

Posted on Mar 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Cold start problem with yamaha 1100fj valves checked carbs checked plugs checked still problem


If the plug wires are more than a couple of years old, I would replace them. You don't say where you are. If you are in a dry environment my answer might be different than if you are on the coast or near a large body of water.

Jul 20, 2014 | Yamaha YZ 250 F Motorcycles

1 Answer

Turning over but not firing


sounds like a fire problem pull plugs and see if there is fire, start there.
these bikes take alot of power to turn over engine so if using a lot trying to start will drain battery quickly

Jan 16, 2014 | Victory Motorcycles

1 Answer

Is my motorcycle fuel injected or carburetor? when trying to start my bike at a cold start it takes awhile to start. it sometimes back fires and makes a wierd sound.


irt is carbureted and all bikes dont like to be cold sharted you need to wait 3 min to let it warm up before you rev or leave on it. do you live in a humid/colder climate because that can have alot to do with the early morning and cold starts

Jun 03, 2011 | 2002 Harley Davidson FLHTCUI Electra Glide...

1 Answer

I have a 1998 Virago 250 in pretty good condition. I've been riding it for about 6 months and its started developing a firing/fueling problem. From cold it's become difficult to start, and when I try to...


You can check for intake leaks with carb cleaner. Spray a little near suspected areas and try to account for spray going in the carbs. A change in RPM is an indication of a leak.

Dec 12, 2010 | 2004 Yamaha Xv 250 Virago S

1 Answer

Engine vibrations


It is due to the spoilage of the bushes
which are made of rubber generally and this makes the contact with the chessi of the byke
so get thm changed

Jul 20, 2009 | 2006 Hero Honda Glamour

3 Answers

2005 ultra classic efi. Back fire thru throtle body during cold start up. Engine light comes on for about 1 sec. After bike gets warmed up runs fine.


This is caused by a lean run. Did you change pipes or the air filter to a hight flow filter? If so you would need to have the bikes ECM flashed to richen the air fuel ratio or instal a unit to do this yourself. A power commander is somethink most of the riders I know use. If none of these apply to you then you will need to check the bike for an intke leak as this can also cause a lean running engine

Jul 09, 2009 | 2000 Harley Davidson FLHTCUI Electra Glide...

1 Answer

Bike switching off when coming to a stand still when hot


Your fan is not comming on, check your Antifreeze.

Mar 26, 2009 | 2005 kawasaki ZX-6R

3 Answers

WONT START HOT


check youre valve adjustments,thenadjust youre fule screw on the carb 1/4 to 1/2 turns richer

Dec 18, 2008 | 2000 Yamaha WR 400 F

1 Answer

Starting problem


the self goes on running after switch goes on off ignition. and it goes on running till battery dies.After stopping of self i tried to start engine from kick start . but engine doesnt start. i chek the whole wires all are in correct position. please tell me whats wrong happening with my bike?clean battery cables and replace battery if needed,

Nov 10, 2008 | 2006 Hero Honda Glamour PGM-FI

Not finding what you are looking for?
2006 Hero Honda Glamour Logo

254 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hero Honda Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4497 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

chris

Level 2 Expert

232 Answers

Are you a Hero Honda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...