Question about 2006 Hero Honda Glamour

1 Answer

Morning start problem

My Glamour is getting starting very quickly in any cold environment. but the engine getting mis-fired till about 5Km. when engine is too hot no problem.

one mechanic told me it's due to Spark plug cap and the electricity leaked outside due to Oxide on connectors. He cleaned but the problem same.

other person told me it's because of my air screw has been opened bit more and have to close it.

Please tell me is it due to Plug Cap issue or Air screw?
If it is due to air screw, after adjusting it will my millage go down?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 2 Answers

Hey Bro, Your mechanic is wrong cause, if it is due to spark plug problem then it will continue your entire ride not for only first 5km.

Now come to the point for miss-fire, here you check these things:

1) Check your fuel.is it pure or not. Make sure that your fuel dose not contain Kerosene.

2) What fuel you are using Petrol Or Octane? If you are using petrol only then mix some octane with petrol(4:1) 4litter petrol & 1litter Octane.

3) Do not adjust your air screw. It will lead you to a serious performance problem.

4) Clean your Air Filter With An Air Blower.

5) Finally change your spark plug with a new one.

Posted on Mar 30, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Wont start in the morning when i go to work but starts right up when i get home


change your oil. if you have the wrong oil for your environment the cold will make the oil too thick to circulate and the engine wont start.

Nov 15, 2013 | 1997 GMC Jimmy

1 Answer

After starting the car this morning, it began to shake like there was a clogged fuel line or mis-firing, where do I need to start to look for a solution?


start by posting car year, and name , model and what engine option is in car.

but on all cars, the EGR likes to stick open , so clean it and close it.
what car?

Apr 10, 2013 | Cars & Trucks

1 Answer

Hi, I was cruising on the Motorway yesterday, when out of the blue My 1999 Jaguar 4.0 V8 started a serious mis-fire. Up to this point there had been no mis-fire and the tick over was smooth. The...


If a whole side has failed, as much as I hate to say it, the ECM/PCM has failed. More specifically the "drivers" for the injectors and should also fire spark. Let me know if you need anything else.

May 18, 2011 | 2000 Jaguar S-Type

1 Answer

2003 alero, won't start in the morning, unless i spray quick start into the intake, then it will start,, there is fuel pressure and good spark, when i get it running,, it will start up all day long,,,, but...


Next time it happens, turn the key to the "on" position. See if you can hear the fuel pump engaging, sending fuel up to the motor. If not, you have a fuel pump issue. It doesn't seem often this happens, but when a vehicle is started, the fuel pump feeds gas to the engine. After the engine is started, it's more of a pressure thing, letting the fuel just flow. It may not be getting that extra push, when the pump is cold.

I hope this helps, let me know if I can be of any more assistance! :)

Feb 22, 2011 | 2003 Oldsmobile Alero

3 Answers

I started my car this morning and it was idling rough. Then the check engine light came on and while I was starting to drive to work it was shifting quick and hard into and out of gears. Eventually it...


yes some times when initial cold start a sensor could get a mis read due to alot of variables,and it would cause trans to shift abrupt. the good thing is it did correct itself and the computer reconized this and detects no stored code. recommend to let vehicle warm 5-10 min before drive. In cold weather you should never just jump in and start car and take off. should always let engine and fluids get to operating temps before drive, This will prolong the life of the motor and trans from internal (expensive) repairs.

Jan 13, 2011 | 2002 BMW 3 Series

1 Answer

Cold start cranking problems 1987 toyota truck wont hardley crank when cold then fires fine after gets crunk till next morning


My 1987 truck I use to have had a choke and it would stick open some times. When you get in the vehicle, you have to press the gas pedal to the floor once to set the choke and add enough fuel to start the vehicle. I assume your vehicle has a carburetor and would suggest the following:

When your engine is cold, take off the air cleaner cover and base and look the butterfly valves. They are fist valve on the top of the carb air inlet. Go and step on the gas pedal once. Observe if the valves move to the almost closed position or not. If they don

Jan 05, 2011 | 1987 Toyota Pickup

3 Answers

Peugeot partner wont start first thing once


i presume its a diesel

i reckon its the glow plugs get them checked i am sure a new set will cure your problem

Nov 05, 2009 | 2006 Peugeot 604

1 Answer

I have a 1968 mustang with 1966 289 c. code .engine starts good .idels ,good till it reaches running temp. then it sounds like the rockers start to chatter .and mis fires till it dies.it has 40psi on oil...


Yes.sounds like the oil pump is laying down when oil gets hot,,,,,,but,,,,i would try changing oil filter..I have seen Oil filters will **** together after a few min. of run time.....I would never use a WIX oil filter,,have had 3 friends loose engines because of the same thing..........hope this helps......

Mar 01, 2009 | 1966 Ford Mustang

1 Answer

Starting problem


the self goes on running after switch goes on off ignition. and it goes on running till battery dies.After stopping of self i tried to start engine from kick start . but engine doesnt start. i chek the whole wires all are in correct position. please tell me whats wrong happening with my bike?clean battery cables and replace battery if needed,

Nov 10, 2008 | 2006 Hero Honda Glamour PGM-FI

Not finding what you are looking for?
2006 Hero Honda Glamour Logo

255 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hero Honda Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

venugopal durairajan

Level 3 Expert

464 Answers

chris

Level 2 Expert

232 Answers

Are you a Hero Honda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...