Question about 1979 kawasaki Z 650 SR

Open Question

Bike coughs and splutters in the rain. Sometimes quits altogether

Had to new coils, leads, caps and plugs also had the timing done. Fuel is flowing fine as well?

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Mechanic can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Mechanic (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
ollie reece
  • 1167 Answers

SOURCE: zxr 400 wont start

fuel not getting in the cylinder this could either be the float or mixture screw on the carb is a screw the air mixture screw turn this out 1 whole turn or just fiddle with it until it runs if not buddy get back to me c3568b1.jpg

Posted on Sep 14, 2009

Ad
prostreet 55
  • 299 Answers

SOURCE: 1991 KDX 250 uses alot

have u tried a hotter plug it worked on my car, also i add lead substitute to gas .try a performance coil and switch to electronic ignition also i did this to my bike and it ran a lot better.

Posted on Mar 20, 2011

Tri3mast
  • 747 Answers

SOURCE: Hi I

ultrasonic cleaning is only as good as the cleaner it's in, it might loosed the dirt, varnish or sediment but it's still there floating in the solution. Not only that if the solution has been used repeatedly then you will possibly get dirt from someone else problem deposited in yours. Ultrasonic cleaning may be a good thing but the carb still needs to be washed and rinsed in clean fluids.

Another thing did they strip the carb down to do this if not then they dislodged the partial but it's still trapped in the float chamber.

Further by not running smoothly through the rev's it sounds as if you have a fuel starve through out the range which could be improperly adjusted float heights.

I use to hate chasing these problems but solving the problem before it starts is the best way and that can be done with fuel stabilizer in the tank run the engine for a while and then run it dry of gas.

Best of luck with it

Posted on Apr 06, 2011

  • 35 Answers

SOURCE: kawasaki zzr600 1993 it has

carbs need to be pulled and cleaned, they might even need to be rebuilt

Posted on Apr 22, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Motor coughs and splutters upon acceleration


Hi Anonymous, if you have a carbuerator the usual suspects are:
1. Damaged or restricted fuel tank venting system (gas cap).
2. Inlet system air leak.
3. Vacuum piston malfunction.
4. Accelerator pump leaking or no output.
5. Plugged bowl vent.
6. Fuel level (float chamber) too low.
7. Restriccted fuel supply passages.
8. Plugged jets or passages.
9. Worn or damaged needle or needle jet.
10. Enrichner valve not seated or leaking.
Please visit the website below for a prime suspect:
Big Twin Carb EFI DTC Intructions codes Harley Davidson Forums Harley... Good luck

Feb 09, 2014 | Harley Davidson Motorcycles

1 Answer

Car starts running rough at idle, eventually quits running. Has new plugs, wires, cap, fuel pump, fuel filter, air filter, IAC Valve, and gas cap.


Back then, Honda suggested timing belt replacement every 60,000 miles. If your Honda has that much mileage or more and has never had the belt replaced, now may be the time.

Sep 11, 2012 | 1995 Honda Accord

1 Answer

Pegaso 650 2000 model none fuel injected between 1500 and 3000rpm the bike coughs and splutters and wont run replaced carb with second hand one valve clearances and re ground valves plus all electrics


Did you check the rubbers where the throttle bodies (carbs) plug on to? Are they ok? The rubber part usually separates from the metal base part of it.Use new spark plugs and also che the key switch's wires for damage (they appear to detach from the switch sometimes)

Feb 05, 2012 | Aprilia Motorcycles

1 Answer

Runs for few minutes down rode then dies get started again sometimes die sometimes fine if petcock diapham do i need to take off to check


To check the diaphragm, pull the fuel line off the petcock and connect a short hose leading into a catch can. Spin the engine with the starter or crank the engine for a few seconds and watch the rate of flow. If it looks like enough fuel, then the diaphragm is probably fine. Have you checked the tank vent in the fuel cap? If the cap vent is plugged, the bike won't run but about a mile or so before it quits. Loosen the fuel cap on the right side if your bike is a Softail otherwise loosen the fuel cap but don't take it completely off. Just enough to allow air to vent into the tank and take it for a ride. If the tank is full, I'd advise draining about half the fuel out or you'll have it in your lap. Not good. You can take the cap off, wipe it good and clean and try to **** and blow through it with your mouth. I've done it plenty of times because I didn't have time to ride the bike on the road. Might need to brush your teeth afterwards, and I wouldn't smoke for while, but it'll tell you if the cap vent is bad.

Good Luck
Steve

Aug 30, 2011 | Harley Davidson XL 883C Sportster Custom...

1 Answer

1991 KDX 250 uses alot of spark plugs.splutters and bogs down after riding at low rpm. plug comes out wet and black with no spark. new plug fixes problem immediately but happens again after about 5 litres...


have u tried a hotter plug it worked on my car, also i add lead substitute to gas .try a performance coil and switch to electronic ignition also i did this to my bike and it ran a lot better.

Mar 20, 2011 | kawasaki KX 250 Motorcycles

1 Answer

Zetec 1.8 16v,when reved above 2000 rpm's all power goes and coughs and splutters badly,have already changed plugs leads coil pack and airflow meter and its still the same


Could be a fuel problem, change fuel filter, air filter if old, check fuel pump pressure. Also check battery to motor and battery to body ground for corossion. Check condition ofmotor to body ground strap for corossion. Bad grounds can cause all sorts of problems.

Oct 08, 2010 | 1998 Ford Escort

1 Answer

Set on 08 ktm 450 sxf Cam timing


It could be a faulty coil inside the magneto, wrong timing or a problem ranging from cdi unit, wiring from the former up to the spark plug.Sometimes the cap that sits on the spark plug could cause this.Basically you are having a firing problem, which means combustion chamber is not getting the right spark for proper combustion.Sometimes even an improper ground from chassis to engine could be the cause of this problem.Hope this helps.Any questions then please ask..O I forgot, try a different spark plug,sometimes these could cause this problem.

Feb 13, 2010 | 2008 KTM 450 SX-F

1 Answer

Bike running rough 96 Wide Glide


check plugs and wires, also coil my be weak, sometimes a bad ground will cause this also and weak battery. I've had these problems before on my older Harleys that I built

Nov 27, 2008 | 2000 Harley Davidson FXDWG Dyna Wide Glide

Not finding what you are looking for?
1979 kawasaki Z 650 SR Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4536 Answers

yadayada
yadayada

Level 3 Expert

77499 Answers

bazzz7071
bazzz7071

Level 2 Expert

342 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...