Question about 2002 Yamaha Royal Star Venture

1 Answer

Yamaha venture backfire

I think timing maybe off but not sure in the morning it is a hard start but once it is running its fine.no marks to check timing what can i do or what should i do please help.

Posted by on

  • markrd125
    markrd125 Oct 30, 2012

    ok    not faremiliar with the bike but im asumeing it hasnt got timeing  and going by the symptums   id say air fuel mix  is far more likely i think i kno what the problem is  there abouts  tell me how it feels in low rpm take off through to top end  when warm and cold starting ? 

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Yamaha Master
  • 40,841 Answers

Posted on Apr 09, 2016

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

karan4aaki
  • 68 Answers

SOURCE: my yamaha xj600n was running perfect but when i

there may be a problem with the spark plug. did you wash your bike?? open up and clean ur bike's plug. or else get your carb/fuel injection repaired. Hope it works..:))

Posted on Mar 10, 2009

  • 3567 Answers

SOURCE: 04 yamaha 650 hard to start but once started runs

I don't know what model your bike is. If it has carburetors the do as noted below.

Drain the carburetors. There should be a screw on the lower side of each CARB float bowl. Remove the screw then replace it after the fuel drains. Remove the water trap bowl at the bottom of the petcock, (gas valve). Is there any water or trash in the bowl? Drain a cup of gas from the tank. Is there any water or trash in the cup? Dump it, clean it and re-mount it, (not all bikes have a water trap bowl). Turn the gas back on and wait a minute for the carbs to fill with gas. Install new stock NGK spark plugs and try to start the engine. If the bike doesn't start and run properly then shut off the gas and remove the carburetors from the engine.

FOR EACH CARB > Remove the float bowl and clean the entire
carb with a spray carb cleaner from the auto parts store. Wear protective goggles to avoid getting spray in your eyes. Spray into all the little airways and fittings in the carb. Remove the idle screw and the air screw on the outside throat of the carb and spray into the screw holes as well.
< < READ CLOSELY > >
Be sure to put these two screws back in the same hole they came out of. IMPORTANT > do not tighten these two screws down. Only screw these in until they LIGHTLY seat. Now turn each screw one and one half turns outward. Before putting the slide back in the throat of the carb, move the clip on the jet needle down one notch. Put the
carb back together, clean the air filter and install the carb. Let the float bowl fill then start the engine. This process should get you back on the road.

Please rate this solution. Thanks!

Posted on Apr 18, 2009

  • 743 Answers

SOURCE: I have a 2007 Yamaha Grizzly 660. It was running

It sounds like you got some corrosion going on, on the ground side. I would start with the battery cables first and see if they need cleaned up, then go to the connectors and unplug them and clean if necessary and put die-electrical grease in the sockets of the connectors before plugging them back in. I am assuming that the shifter is electrically assisted if there are problems going on with it as well...this is what makes me believe that it is a bad ground due to setting maybe in a damp inviroment.

Posted on Oct 19, 2009

Testimonial: "Great feedback and it has given me a different avenue to look that I had not thought of. The response was quick and not only did ?lylerwh? provide the direction to look he furthered explained what his decision was based on. Thanks "

co7196
  • 3433 Answers

SOURCE: I have a Yamaha TTR 225 4 stroke that is having issues starting

Carba/f ratio needs adjusting and use of the choke will help keep the idle circuits clean.

Posted on Nov 12, 2009

  • 5 Answers

SOURCE: carb

i have the same bike you need to remove and clean the pilot jet in the primary side of the carb so it starts and the 2 main jets need cleaned too one is by the pilot jet the other main jet is in that long tube on the bottom of the secondary side of the carb under the YDLS letters

Posted on Apr 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

No start on bear tracker 250 just backfires


then the timing is not set properly .

Jun 22, 2016 | ATVs

1 Answer

Chevy ventures backfires runs rough


U need to have the timing checked to be sure it is not the problem.

Apr 07, 2014 | 2003 Chevrolet Venture Passanger

1 Answer

2002 venture wont start when its cold and rainy


Probably not. If one of the sensors were faulty you should have a check engine light on and a trouble code for the sensor.
Have you checked the plug wires ?
And as a side note, I don't show a 2002 Venture mini-van having a 3.8 engine.

Jan 30, 2014 | Cars & Trucks

1 Answer

1989 regal backfires when starting


Sounds like the timing is to far advanced.****** the timing until motor turns freely when cranking it over.

Jan 25, 2012 | Buick Cars & Trucks

2 Answers

1986 yamaha royale venture...XVZ13DSC running a little rough when idle. Runs fine after up to speed... Backfires on delceleration sometimes... replaced spark plugs, all looked good with consistant tan...


The first thing that I would check is the choke. Is it sticking?? the backfire on decel indicates that it is getting to much fuel.
A new fuel filter is a very good idea but I would look at the old one and see if it is contaminated.
My concern is the fuel tank. If the carbs were done properly they should be fine. If there is a problem it could be rust in the fuel tank that is still polluting the carbs. I have had many bikes that age that require the fuel tank to be removed, cleaned and possibly coated inside.

I would also drain all of the carbs. Each float bowl has a drain screw and can be loosened up slightly to remove the fuel in the carb. Make sure to take a close look at the fuel that comes out to check for water or contamination.

I hope that this helps,
Steve

Jan 18, 2011 | Yamaha Royal Star Venture Motorcycles

2 Answers

Vstar 1100 idling rough and backfiring letting off the throttle


It sounds to me that your carbs might be a little gunked up - you mentioned the gas may have been old, so it's possible that the smaller (idle) jets are slightly plugged up. Fresh fuel might do the trick and/or you could try using a fuel system cleaner and water remover. This problem might 'solve itself' with a little time.

As far as the backfire - this might be either from the carb issue or it could be related to that rattle you mentioned - you could have a loose connection at or near the head - this can **** air and cause a backfire.

I hope this helped!

Jun 09, 2010 | 2003 Yamaha V Star 1100 Classic

2 Answers

93wrangler6cyl,auto when cold backfires, sputters until warms up


Check EGR value, clean or replace. Also PCV valve replace it is cheap.

Dec 16, 2009 | Jeep Wrangler Cars & Trucks

3 Answers

I have a 2007 Yamaha Grizzly 660. It was running


It sounds like you got some corrosion going on, on the ground side. I would start with the battery cables first and see if they need cleaned up, then go to the connectors and unplug them and clean if necessary and put die-electrical grease in the sockets of the connectors before plugging them back in. I am assuming that the shifter is electrically assisted if there are problems going on with it as well...this is what makes me believe that it is a bad ground due to setting maybe in a damp inviroment.

Oct 19, 2009 | 2007 Yamaha XT 660 X

Not finding what you are looking for?
2002 Yamaha Royal Star Venture Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Yamaha Experts

dhnguyen

Level 2 Expert

281 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

Tony

Level 3 Expert

2600 Answers

Are you a Yamaha Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...