Question about 2004 Suzuki SV 1000

1 Answer

No power to ignition

Turn on the key and everything is dead! battery all good, everything was working fine, then went to turn on and nothing!

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 29 Answers

Have you checked the fuses and wire connections?

Posted on Oct 30, 2012

  • mike teddy Oct 30, 2012

    yes! have checked all fuses and tried another battery, still nothing!

×

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 202 Answers

SOURCE: Dead, replaced battery and still dead

your fuse is blown near the battery is a fuse check if it is blown

Posted on Jul 24, 2009

  • 188 Answers

SOURCE: battery good, bike dead

At first glance sounds like the battery is bad. The voltage you read across a battery with no load is not a good way to test. Batteries should always be load tested. Also if you still have the original battery from a 2003 bike you definitely need to replace it.

Posted on Jul 27, 2009

  • 521 Answers

SOURCE: no power when i turn the ignition switch on, battery is good

main fuse
check all the fuses.

Posted on Sep 23, 2009

  • 18 Answers

SOURCE: I have a 2000 suzuki intruder 1500. When I turned

could be a bad connection to the battery or the starter solinoid cant think how to spell it but its where the positive battery wire hooks up

Posted on Apr 17, 2010

Testimonial: "Thanks for the information, sounds like it could be a loose connection. Where do I find the starter solenoid ? "

heimlich
  • 1978 Answers

SOURCE: My battery is good and

You may have a separate headlight fuse that is blown. You could have a dirty or broken contact base on your ignition switch that is not supplying power to that part of the bike. Or you could have a dirty or broken starter button . The starter button when pushed in half way, turns off the headlight. when it is pushed in all the way it engages the solenoid. If it the button try cleaning it. If that does not work you will have to replace the switch assembly.

Posted on Sep 04, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Just put a new battery in my Cadilla STS because I thought the old one was dead, but after putting the new one in everything seemed fine and trunk, doors, radio, lights all worked. I turned the key and...


Sounds like a loose connection on the battery. Clean and tighten them, and check the battery ground. Is the starter cable on tight? If still nothing, a shop needs to check the ignition switch for a defect.

Mar 22, 2013 | 1995 Cadillac Seville STS

4 Answers

My car wont start but has Power


DOES YOUR CAR CRANKS OR IS COMPLETELY DEAD ONLY LIGHTS? IF IT CRANKS AND DOESN'T ENGINE RUN THEN IT IS EITHER THE ALARM ( IMMOBILIZER )SYSTEM ACTIVATED,OR THE IGNITION KEY FAILURE. IF YOU HAVE A SPARE IGNITION KEY TRY AGAIN ( THE KEY TO BE THE ONE WITH CHIP INSIDE ).IF IT IS COMPLETELY DEAD THEN YOU NEED THE ASSISTANCE OF A QUALIFIED PERSON TO DIS ACTIVATE THE ALARM AND CHECK ALSO YOUR SMART KEY AS WELL .

Sep 02, 2012 | 2002 Chrysler PT Cruiser

2 Answers

My mercedes s 430 2001wont let the remote key turned everything was fine the everything went dead


If you mean key will not turn in ignition,charge or jump start
Car has electronic ignition switch
If battery is low/flat it will not turn

Apr 27, 2010 | 2001 Mercedes-Benz S-Class

3 Answers

Battery dead, key stuck in ignition.


I have had the same problem with my daughter's car. She inadvertnetly left the key in the on position and the battery went dead. Apparently an electrical current is neded to withdraw the key. I put a battery charger on the car for several hours and everything worked fine after that.

Sep 30, 2009 | 1997 Pontiac Grand Am

1 Answer

Car dead no power, just an audible beep when I insert key


the battery has failed, or the battery cables are corroded.or both.

May 15, 2009 | 2001 Toyota Corolla

1 Answer

2002 Pontiac Grand prix wont start; unable to remove key


On many cars, if the battery is dead, it locks the key in the ignition. Put a battery charger on the car or replace the battery and give it a shot.

Good luck.

May 15, 2009 | 2002 Pontiac Grand Prix

1 Answer

2001 grand cherokee ltd completely lost power


Check the connections at the battery. Be sure they're clean and tight.

May 09, 2009 | 2001 Jeep Grand Cherokee

1 Answer

Electrical Help Please


nada. No gauges no lights absolutely nothing. All that happens is when I turn the ignition switch off the tach bounces backward quickly about 6 or 8 times. I put the bike on the battery tender and within 20 minutes it was showing in good shape. Still nothing. Checked battery leads. No problem. I checked all the fuses around the battery and up next to the dash. Nothing there. I R & R'd all of the relays next to the dash and the 3 behind the tool kit with the same relays off of my Mille. Still nothing. I changed the odd relay next to the battery that says UP on it. Don't know what it is but it rattles. Maybe a tip over sensor? Nothing. I tried jumping the bike off with a portable jump start battery. Nothing. I switched the battery out. Nothing. I pulled the front fairing and checked all connections. Found everything to be just fine. Put a battery charger on the fully charged battery and suddenly got ignition lights and headlights. Turned the key back off and once again nothing. A few more times it would come back and show lights and gauges but when I went to start everything went dead again. I'm thinking maybe the ignition switch? It doesn't seem worn out at all. I jiggled the key didn't seem to make a difference. The bike only has about 10k miles on it. Any ideas? ,Some 'friend'... did this ever happen to him? Good diag work so far, and I don't have anything specific to look at. Hopefully one of the sm-m-m-marter members can assist. ,,,

Nov 10, 2008 | 2004 Aprilia Tuono Racing

1 Answer

Does not start


Make sure you battery is fully charged, and make sure that your alternator hasnt went south...

Battery or Alternator could be junk...

Aug 11, 2008 | 2002 Ford Taurus

Not finding what you are looking for?
2004 Suzuki SV 1000 Logo

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

76630 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4535 Answers

Richard
Richard

Level 2 Expert

83 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...