Question about 2005 kawasaki KLR 650

1 Answer

Low speed miss

I have a Kawasaki 650 BruteForce ATV it pops thru the exhaust at low speeds up to 5 or 6 MPH it seems to do better if I run the choke half open. Any help would be appreciated. Thank You corvettejake

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Contributor
  • 1,199 Answers

Timing needs a adjustment1

Posted on Dec 09, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Runs and starts great but won't idle


Hi, Emmett and the usual suspects are:
1. Idle speed improperly adjusted.
2. Inlet system air leak.
3. Leaking accelerator pump.
4. Loose low-speed jet.
5. Plugged low-speed jet.
6. Contaminated or plugged low-speed circuit.
7. Enrichner valve is not seated or leaking.
For more information about your issue and valuable "FREE" downloads that you will need please visit the websites below. Good luck and have nice a day.
Motorcycle Message Board Motorcycle USA
2 stroke dirt bike problem Won stay running Please help motorcycles
Honda 650 Won Idle
http://www.sportbikeworld.com/forums/179-atv-dirtbikes/30570-bike-runs-fine-wont-idle.html

Mar 21, 2016 | Motorcycles

1 Answer

Kawasaki teryx 2008 750 missing at low speed


Hi, Tony and the usual suspects are:
1. Throttle cables misaligned or misrouted.
2. Damaged or restricted fuel tank venting system.
3. Inlet system air leak.
4. Vacuum piston malfunction.
5. Accelerator pump leaking or no output.
6. Plugged bowl vent.
7. Fuel level in bowl too low.
8. Restricted fuel supply passages.
9. Plugged jets or passages.
10. Worn or damaged needle or needle jet.
12. The enricher valve not seated or leaking.
For more information about your issue and free downloads that you will need please visit the websites below. Good luck and have a nice day.Engine Mis or popping at low speed Kawasaki Teryx Forum
Low speed missing and jerky start Page 2 Kawasaki ATV Forum http://www.militaryatvparts.com/service_manuals/2008-09%20Kawasaki%20Teryx%20KRF750RAF%20Service%20Manual%2099924-1434-02.pdf
http://www.militaryatvparts.com/service_manuals/2008-09%20Kawasaki%20Teryx%20KRF750RAF-OWNERS_MANUAL.pdf

Jan 08, 2016 | kawasaki Motorcycles

1 Answer

Will idle & run at slow speeds, bogs down at higher speed.


Prairie 360 revs high but goes slow (45mph) - Kawasaki ATV Forum

www.kawieriders.com > ... > Kawasaki Brute Force/Prairie/Bayou
Oct 27, 2008 - 2006 Prairie 360, wife's ride, polar white, with 26" Swamp Lites on SS108's. ... that it has a low top-speed...45mph is about as fast as they seem to go. ....air cooled motor theres no real performance there, the P360 wts are light ... Can't put 2005 Kawasaki KVF 360 into gear
Jun 30, 2013
Prairie 360 speed/power issue?
Aug 28, 2012
06 Prairie 360, too many rpms???
Nov 30, 2011
2004 Prairie 360: WOT miss
Nov 9, 2011
More results from www.kawieriders.com

Oct 08, 2015 | kawasaki 2005 Prairie 360

1 Answer

Speed problem


check the alternator. if the engine is running fine no problems but stuck only doing slow speeds would check the charging. if this is fine check the spark coil.

Mar 11, 2014 | 2004-2006 Kawasaki Kvf700a B Prairie 4x4...

1 Answer

Yamaha tw 125, adjusted valves to correct spec, now exhaust dont sound right, bike not idling properly


Hi, Brian and the usual suspects are:
1. Idle speed improperly adjusted.
2. Air fuel mixture screws not properly adjusted.
3. Inlet system air leak.
4. Leaking accelerator pump.
5. Loose low-speed jet.
6. Plugged low-speed jet.
7. Contaminated or plugged low-speed circuit.
8. Enrichner valve/choke not seated or leaking.
9. Multi carburetors out of sync and need to be balanced.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
2005 carb issues slow to idle down
http://yamahaforum.com/forums/utility-atv/2475-1997-yamaha-timberwolf-idle-backfiring.html
Yamaha TW125 1999 Service Manual
OEM parts for Yamaha
YAMAHA TW125 Owner Manual

Feb 27, 2013 | 2001 Yamaha TW 125

1 Answer

1982 maxim 650 idles rough


Hi, Anonymous and the usual suspects are:
1. Idle speed improperly adjusted.
2. Air fuel mixture screws not properly adjusted.
3. Inlet system air leak.
4. Leaking accelerator pump.
5. Loose low-speed jet.
6. Plugged low-speed jet.
7. Contaminated or plugged low-speed circuit.
8. Enrichner valve/choke not seated or leaking.
For more information about your issue and valuable "FREE" downloads that you will need please click on the links below. Good luck and have a nice day.
Yamaha XJ650 Idle Problem
1994 xj600 seca 2 rough idle
Yamaha XJ750 Owners Workshop Manual
OEM parts for Yamaha
http://www.carlsalter.com/pdfs/Yamaha_XJ600SK_Owners_Manual.pdf

Aug 27, 2012 | 1982 Yamaha XJ 650

1 Answer

2011 Nomad 1700 lacks power in 6th gear especially in heavy wind or in mountains. Always shifting down to 5th to keep up. Only 33 mpg doing 70 mph. Improves to 39 MPG at 55. I had a 2003 1600 Classic...


nomads are heavy bikes mate and i feel all is as should be with yours, top gear is usually for on the straight and cruising, at a constant speed. my vtx 1800 does similar albeit only 5 speed i still have to pull down a cog and work the gears on hills. the mpg doesnt sound a miss for the nomad either. my vtx does similar.

Aug 05, 2011 | 2011 kawasaki Vulcan 1700 Nomad

2 Answers

1994 toyota pickup rattles at low speeds (~15-19 mph).


Check for loose heat shields the cover the exhaust. I find this is the source of many rattles. They are made of sheet metal and if they are not clip or tightened down the low vibration frequency when the car is running at slow speed will cause them the hit the exhaust pipe/ front mainfold.

May 08, 2010 | 2003 Acura MDX

Not finding what you are looking for?
2005 kawasaki KLR 650 Logo

Related Topics:

261 people viewed this question

Ask a Question

Usually answered in minutes!

Top kawasaki Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

yadayada
yadayada

Level 3 Expert

70374 Answers

chris

Level 2 Expert

232 Answers

Are you a kawasaki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...