Question about 1996 Suzuki GSX-R 750 T

1 Answer

Speedo intermintent sometimes it works then some times it dosen't where is sensor any idea of problem

Posted by on

  • robmar783 Dec 05, 2008


    Speedo doesn't work , but fuel gauge, rev counter etc. Does.

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 28 Answers

The sensor is reading off the countershaft sprocket. check the sensor, wiring, and sensor gap.

Posted on Dec 01, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedo not working


more info is this speedo mechanical or electrical. does is drive with a cable, this is mechanical, usually from the front wheel, there is an inner cable, sometimes if they aren't lubed they will twist off. electrical check connections.

Jun 06, 2013 | Suzuki Motorcycles

1 Answer

I have a 2000 flht.at 3,000 rpm my speedometer reads 40 mph.any ideas whats wrong,or what can i do?


Hello Galen... The digital speedo on your Harley goes thru a very short start up sequence. If you crank the bike before this sequence is complete, it will often make the speedo register incorrectly. Next time you turn on the ignition, watch the speedo needle, it will make a little ****, once this is done crank the bike. If it reads wrong going down the road, pull over, turn off ignition and crank it again while waiting for the needle.

You can also remove & clean the speedo sensor of debris (on top of the transmission). Sometimes the sensor will pick up small metal particles & cause the speedo to be off.

I hope this helps & good luck with your bike.

Aug 26, 2011 | 2000 Harley Davidson FLHT Electra Glide...

1 Answer

Hello. My digitalt speedometer dosen't seem to work. All the lights seem to work, and it's light in the display, but thats it. Whan i drive you can't se how fast you are driving (and so...


speedo tac issue first it might light up but its because the light runs off a battery the speed sensor at the end of the wire that comes out of the speedo might be broke but i would change out the speedometer first for a new one...now the signal light is either blown or needs the fuse changed i would change the fuse first.. let me know if this helps if not i will do my best to help you out

Jun 03, 2011 | 2007 Yamaha DT50X

1 Answer

Speedomitor stopt working on my bmw k1200rs bike! any ideas please.


Depending on the year of your K1200RS, the speedo signal is derived from a sensor on the final drive (rear) of the bike. Check the wiring to the sensor for damge etc. The speedo itself could be defective as well. You will need to test the sensor and associated wiring first to determine if there is a pulse output going to the speedo.

Sep 16, 2010 | BMW K 1200 RS Motorcycles

1 Answer

2003 fxstd speedo not working


This depends on whether the speedo is a mechanical or an electronic unit.

If it's a mechanical unit, it probably gets it's drive from a cable that runs to a cable drive unit on the axle that is driven by the front wheel. If this is the case, the problem could be in the speedo unit itself, the cable could be broken, or the drive unit could be broken. To find out which, you're going to have to gain access to the cable by either taking the front wheel off or the dash to get the cable loose from the speedo. Pull the cable out of it's housing and inspect it. Look at both ends, they should be "squared off". If not, the cable is broken and you'll need a new one. If the cable does not look broken, lubricate it some wheel bearing grease and reinstall it into the housing. Twist it a bit while pushing it into the housing to make sure it seats in the drive unit. Raise the front end of the bike and spin the wheel. Watch for the cable to turn. If it turns, your drive unit is probably alright and the speedo is where the problem is. Time for a new speedo in most cases.

If the speedo is electronic, this kind of simplifies things but not much. The speedo gets a pulse from a sensor in the transmission. The sensor is located on the transmission on the right side of the bike just behind the chrome shifting mechanism cover on top of the transmission. It is held in by one small bolt or screw. Remove the screw and work the sensor out of it's hole. There should be an o-ring on the sensor, don't lose or break it. Wipe the face of the sensor off with a rag. Sometimes they get a small bit of metal on them and they quit working. Reinstall the sensor. Take the bike for a ride and see if the speedo works now.

If the speedo is electronic and it does not "light up", then you need to trace the circuit that it gets it's power from. To do that, you need a schematic. I'll like to help with that but I do not have a schematic for this particular bike.

I hope this helps. Good Luck and Ride Carefully.

Nov 21, 2009 | 2000 Harley Davidson FXSTD Softail Duece

2 Answers

05 GSXR 750 Speedometer Reads 0


I just had the same problem 2004 gsxr 750. After massive troubleshooting and time I found out it was the gauge. So I then ebayed a gauge on ebay and bought on for 290 dollars. Speedo now works. I am just off on the actual speed, need to by a speedo healer.

Sep 17, 2009 | 2005 Suzuki GSX-R 750

1 Answer

The speedometer n my 1999 Sportster 1200 has stopped registering. How do I fix it?


This depends on whether it is an electronic speedo or a mechanical speedo.
The electric speedo has a sensor near the rear of the engine. Sometimes a very small piece of metal will get stuck on the end of the sensor and the speedo will stop working. Remove the bolt holding the sensor into the engine case and carefully pull the sensor out. Wipe it off and reinstall it. If the speedo still does not work, it's probably something in the speedo itself.

On a mechanical speedo, a cable from the front wheel drives the speedo. The cable or the speedo drive unit may be bad. To check the cable and drive, lift the bike off the ground, disconnect the cable from the rear of the speedo. Turn the front wheel and see if the cable is turning. If it is, it's probably alright. I'd still pull the cable out of it's housing and lubricate it with some grease. If the cable is turning, the cable and drive unit is alright. The speedo may be broken.

Jun 15, 2009 | 2000 Harley Davidson XL 1200 C Sportster...

Not finding what you are looking for?
1996 Suzuki GSX-R 750 T Logo

Related Topics:

113 people viewed this question

Ask a Question

Usually answered in minutes!

Top Suzuki Experts

yadayada
yadayada

Level 3 Expert

60960 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4477 Answers

Ed Nelson
Ed Nelson

Level 2 Expert

149 Answers

Are you a Suzuki Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...