Question about 2001 Ducati 996 S

1 Answer

996S fuel pump issues

Originally I was having an intermitant fuel pump issues. The pump would quick occasionally and the motor would stall. The good news is

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,712 Answers

It has quite all together. Does anyone have the schematic for the 99 996S so I could trouble shoot the system? Has anyone else experienced this? I have replaced the relay but dont think this was the problem from the beginning. Any help would be greatly appreciatedI had a problem with my fuel pump after I purchased my 2000 996S. Originally I thought it was the pump that was going out. But as tye1138 asked it's important to note if the pump is turning on and priming the system when you turn the key on. I removed the pump from the tank and checked it. Worked okay. After hours (and hours) of checking and re-checking the relays, fuses, grounds and wiring, it turned out to be the computer had died on me. I was lucky enough to know somebody who knew sombody who had a friend at a Duc shop who was willing to test out my computer and confirmed that it had died. I bought a used one off of flea bay and the problem was solved. It's easy enough to remove the computer and if you have somebody willing to test it then I would try that. Also check the relays located underneath the seat. Those can be tested but you'll need the service manual for the proper procedure. Hope it turns out better for you than it did for me!,,,

Posted on Nov 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Kymco S Peoples200, engine starts but fades very quickly


Hi, Dave the following applies to carbureted also fuel injected models and the usual suspects are:
1. Severely discharged or a damaged battery, should have 12.5 volts or better and be able to pass a load test if necessary.
2. Failed alternator/generator and or voltage regulator.
3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.
4. Failed main circuit breaker or ignition switch, check for loose connections and continuity.
5. Failed system and or ignition relay, check for continuity.
6. Failed ignition coil, ignition/electronic module.
7. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.
8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.
9. Air/fuel mixture screw improperly adjusted.
10. Accelerator pump damaged or not working.
11. Water or dirt in the fuel system, carburetor or filter.
12. Restricted, blocked or kinked fuel line.
13. Fuel tank empty.
14. The gas cap is not venting properly or fuel tank venting system blocked.
15. A failed fuel pump, pressure regulator and or fuel injectors.
16. Vacuum line from intake manifold to petcock broken, cracked, or not attached, carburetor vent line plugged.
17. Needle and seat stuck closed in the float bowl.
For more information about your issue and valuable "FREE" downloads that you need please click on the links below. Good luck and have a nice day.
s200 stalls after 5 10 minutes
GY6 stalls immediately after starting
problems with my Kymco 200 People
http://www.49ccscoot.com/manuals/Kymco_People_S_50-200_Service_Manual.pdf

Jun 15, 2016 | 2010 Kymco People S 200

1 Answer

St 1100 loose power occasionally and runs uneven what could be the reason ?


Hi, Marthinus the following applies to carbureted also fuel injected models and the usual suspects are:
1. Severely discharged or damaged battery, 9 volts or lower.
2. Failed alternator/generator and or voltage regulator.
3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.
4. Failed main circuit breaker or ignition switch, check for loose connections and continuity.
5. Failed system and or ignition relay, check for continuity.
6. Failed ignition coil, ignition/electronic module.
7. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.
8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.
9. Air/fuel mixture screw improperly adjusted.
10. Water or dirt in the fuel system, carburetor or filter.
11. Restricted, blocked or kinked fuel line.
12. Fuel tank empty.
13. Gas cap is not venting properly or fuel tank venting system blocked.
14. A failed fuel pump, pressure regulator and or fuel injectors.
15. Vacuum line from intake manifold to petcock broken, cracked, or not attached, carburetor vent line plugged.
16. Needle and seat stuck closed in the float bowl.
For more information about your issue and valuable free downloads that you need please visit the websites below. Good luck and have a nice day.
Stalling Recalls
Pan European ST1100 cutout
Honda Pan European ST1100

Feb 14, 2016 | Honda ST 1100 Pan European Motorcycles

1 Answer

2000 BMW R1100S buzzing motor/pump buzzing sound after everything is turned off.


Hi, Anonymous for this situation I would call my local dealer or reputable shop's service/parts department and inquire about any possible quick fix, answers, or parts inquiry. If necessary, transport your bike to the dealer or shop and have a professional technician take it for a test drive, if it is in running condition, and give you a written estimate of repairs and answer any specific questions you may have about your issue. For more information about your issue please visit the website below. Good luck and have a nice day.
ABS electric motor stuck on
94 R1100 RS Won start electrical issue BMW RS Owners Club
1999 2005 BMW R1100S Service Manual Moto Data Project
BMW Motorcycle Parts Fiche OEM BMW Motorcycle Parts online 1970 present BMW
http://www.bmw-motorrad.com/us/en/index.html?content=http://www.bmw-motorrad.com/us/en/services/manuals/manuals_main.html¬rack=1

Mar 18, 2013 | BMW R 1100 S Motorcycles

1 Answer

Stalls when giving gas


Hi Boscha4, and the usual suspects are:
1. Idle speed improperly adjusted.
2. Inlet system air leak.
3. Leaking accelerator pump.
4. Loose low-speed jet.
5. Plugged low-speed jet.
6. Contaminated or plugged low-speed circuit.
7. Enrichner valve not seated or leaking.
For more information about your issue please visit the websites below. Good luck and have nice a day.
2004 Yamaha Motorcycle Service Repair Manuals

May 20, 2012 | 2004 Yamaha V Star Classic

1 Answer

Hi, I have a derbi mulhacen 659 model 2011. When I drive the motor, after a while the motor turns off.. When waiting for trafficlights...it's shuts down .... expecially when the motor is warm, engine...


Hi, Quest25 the following applies to carbureted also fuel injected models and the usual suspects are:

1. Severely discharged or a damaged battery, 9 volts or lower.

2. Failed alternator/generator and or voltage regulator.

3. Loose or corroded battery terminals and or cables especially the "NEGATIVE" cable, look for loose, corroded, or broken connectors inside the cable harness at "BOTH" ends.

4. Failed main circuit breaker or ignition switch, check for loose connections and continuity.

5. Failed system and or ignition relay, check for continuity.

6. Failed ignition coil, ignition/electronic module.

7. Failed CKP, CPS, CMP, MAP, TPS, or BAS sensor, corroded, loose or broken wire connector pins/sockets.

8. Throttle cables and or idle speed improperly adjusted hot idle speed should be 950 RPM to 1000 RPM.

9. Air/fuel mixture screw improperly adjusted.

10. Water or dirt in the fuel system, carburetor or filter.

11. Restricted, blocked or kinked fuel line.

12. Fuel tank empty.

13. Gas cap is not venting properly or fuel tank venting system blocked.

14. A failed fuel pump, pressure regulator and or fuel injectors.

15. Vacuum line from intake manifold to petcock broken, cracked, or not attached, carburetor vent line plugged.

16. Needle and seat stuck closed in the float bowl.

For more information about your issue and valuable "FREE" downloads that you need please visit the websites below. Good luck and have a nice day.

http://www.her-motorcycle.com/stalling-at-a-traffic-light-or-stop.html

Stalling Shifting and other Noobness

https://answers.yahoo.com/question/index?qid=20110902151558AAV6IRD

Motor stalls when idles hot in traffic

Aug 20, 2011 | 2011 Derbi Mulhacen 659

1 Answer

I have a 1994 Honda CBR600 F2 Sport Motorcycle. It starts and runs but after it is driven a few miles it stalls out. Then restarting is very hard, will restart with choke and drives a few more miles then...


Your fuel filter is clogged or your fuze for the fuel pump pop'd check to see if you can hear it engage win you turn on the key shuld be a easy fix.. Worse case your fuel pump went/going out.... Good luck.

May 31, 2011 | 1992 Honda CBR 600 F(2)N

1 Answer

07gsxr600 10800mi My bike runs great except for the occasional spit or sputter due to a bad tank of gas. I ride it everyday to work. It was running perfect 3 days ago after two days of sitting without...


there is usually a screen in the fuel ****/valve that will catch any nasty goop that may have been in the tank. Also there might be a screen before or right after the fuel pump. you need to eyeball these to see if they are stopped up. good luck

May 07, 2011 | 2007 Suzuki GSX-R 600

1 Answer

Why does the motor stall around 3000 rpm it is sitting on the stand with new gas new plugs cleanedout carberator new petcock kit and still it stalls why?


dirty fuel filter or fuel pump not working,check that fuses are good.check for fuel pressure after the pump. Gravity feed may be enough to start but not enough to run proper. collapsed fuel line could be there as well.

Apr 02, 2010 | 1984 Honda VT 500 C Shadow

1 Answer

Stalling


does it have a fuel pump? It could be going bad.. if not, it could be a bad battery...but since it looks like a 2008 its doubtful and could be just loose or dirty connections in the battery circuit.

Sep 14, 2009 | 2007 Yamaha V Star 1100 Classic

Not finding what you are looking for?
2001 Ducati 996 S Logo

612 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ducati Experts

Arnie Burke
Arnie Burke

Level 3 Expert

4477 Answers

Gino Cussen
Gino Cussen

Level 2 Expert

216 Answers

yadayada
yadayada

Level 3 Expert

60867 Answers

Are you a Ducati Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...