Question about 2008 Cagiva Mito 125

1 Answer

Starter problem I had a look over the Planet again. Stuck in the battery from the TZR as I was out riding it so it should be charged well. Same symptoms. All relays and solenoids click. Power valve zips. I managed to bump start it and the Planet ran as normal. When I press the ignition button

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,712 Answers

I can feel the starter motor clicking. So I took it off and pressed the ignition button and the starter motor was spinning as it should. I took off the left crank case cover removed the cog cover removed the cog and rod pressed the ignition button and the starter motor spun as it should. I attached the cog and rod, the starter motor struggled to spin. Is the starter motor working? Why does it spin with the cog and rod removed? Why wont it spin with the cog and rod in place?,You have stumbled on it - if you are describing the stud that protrudes out towards the front wheel where you attached the thick red wire with eyelet on it, then no - it should not rotate freely. Chances are when nut tightened previously it has been turning whole stud (which you mustn't) and so it has(possibly) twisted internal connection to the point of almost breaking. Is there a lock nut on the stud before you attach the starter lead? cos If you are lucky (and no twisting damage has been done yet) you could either replace missing (first) locknut and plain washer and carefully tighten down - mustn't overdo this and watch to make sure stud doesn't turn, or just tighten (presumably) loose locknut thats already there. then you can put starter lead on and then second locknut with plain washer and again, tighten down making sure stud does not rotate. Sorry to say, but tend to think it's the earlier option though.,,,

Posted on Nov 10, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I release a jammed starter motor on a Honda 1211 Hyrdrostatic Ride On mower?


Pull the spark plug and try again many times the fuel get into the cylinder and will not let motor turn over . if it goes change the oil also and put a shutoff valve in the fuel line

Mar 30, 2015 | Garden

2 Answers

Riding mower won't start & makes clicking sound when I turn key over


MAKE SURE BATTERY IS CHARGED IF IS THEN JUMP LAWN MOWER AT STARTER IF STARTS BAD BATTERY ARE STARTER RELAY COST 60.00 I STILL THINK YOUR BATTERY IS BAD OR DEAD NOT ENOUGH CHARGE IN IT

Sep 01, 2014 | Garden

3 Answers

Battery is dead and wont start


Make sure the battery is fully charged before trying again. If the battery wont charge get a new one. Once installed use a multimeter to verify that the alternator is charging.

Sep 22, 2012 | 2004 Chevrolet Chevrolet TrailBlazer EXT

1 Answer

Toro sl 500 riding mower starter will not turn


Is the battery charged up? Check that the headlight is on and bright.
Does the solenoid click but the starter not spin?
It could be jammed in the flywheel. Try engaging the drive and rocking the machine back and forth. Then try the starter again.

Feb 23, 2011 | Garden

1 Answer

Engine starting problem


The battery still may be bad. The fact that it "warmed slightly when being charged" doesn't suggest it to be good - instead it could have high internal resistance in one or more cells. A battery with this failure still measures a good 12V until you put a load on it. I'd take the battery to a battery store, not a lawnmower dealer, and have it tested there with an actual battery tester. If it's bad, replace it. If it's good, then it's probably the solenoid and that means you'll have to replace the starter/solenoid assembly.

Jul 05, 2010 | Garden

1 Answer

Riding mower won't start


Test before you replace! Check the ground cable. Make sure it is clean and tight. Check all connections for the same. I have to assume that you made sure the new battery was charged...Check all of your safety switches. Check the connection to the starter. Good luuck...Lee

Sep 14, 2009 | Garden

1 Answer

I was riding my '94 Virago 535 when it made a loud whirring sound then the bike stalled and I was unable to start the bike again. When I press the starter button nothing happens except the headlight goes...


Yes, the starter clutches sometimes get stuck on those bikes.
Then the starter turns at very high speeds and get broken.
Remove the starter from the engine ( that's an easy job )
Hold the starter in a bankwrench and connect a 12V battery to it. If the starter turns, he is OK, if not, replace the starter and his clutch system.

Mar 30, 2009 | 1994 Yamaha XV 535 Virago DX

2 Answers

MURRAY AUTOMATIC DRIVE, 42" CUT, 17HP, TWINII,MODEL 42A707,TYPE 2653E1,CODE 9710235B. Battery fully charged,starter will not turn fast enough to start engine. acts as tho there is a presure build up....


Dropped / Stuck valve?

Major Overheat?

Battery weak (understand it is fully charged... but is it delivering proper amperage under load?)

bad connections betwixt battery and solenoid, then solenoid to starter?

Weak starter motor?

Mar 25, 2009 | Craftsman 17.5 hp 42 in. Deck Lawn Tractor...

1 Answer

Starter problem


I can feel the starter motor clicking. So I took it off and pressed the ignition button and the starter motor was spinning as it should. I took off the left crank case cover removed the cog cover removed the cog and rod pressed the ignition button and the starter motor spun as it should. I attached the cog and rod, the starter motor struggled to spin. Is the starter motor working? Why does it spin with the cog and rod removed? Why wont it spin with the cog and rod in place?,You have stumbled on it - if you are describing the stud that protrudes out towards the front wheel where you attached the thick red wire with eyelet on it, then no - it should not rotate freely. Chances are when nut tightened previously it has been turning whole stud (which you mustn't) and so it has(possibly) twisted internal connection to the point of almost breaking. Is there a lock nut on the stud before you attach the starter lead? cos If you are lucky (and no twisting damage has been done yet) you could either replace missing (first) locknut and plain washer and carefully tighten down - mustn't overdo this and watch to make sure stud doesn't turn, or just tighten (presumably) loose locknut thats already there. then you can put starter lead on and then second locknut with plain washer and again, tighten down making sure stud does not rotate. Sorry to say, but tend to think it's the earlier option though.,,,

Nov 10, 2008 | 1994 Cagiva Mito 125 - Lawson

Not finding what you are looking for?
2008 Cagiva Mito 125 Logo

492 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cagiva Experts

yadayada
yadayada

Level 3 Expert

67800 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

chris

Level 2 Expert

232 Answers

Are you a Cagiva Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...