Question about 2008 Buell Lightning XB12S

1 Answer

Speedometer occasionally stops working.

My speedometer occasionally likes to stop working on me. Its not the display cause it usually works fine but every once and a while it just sits at zero. Im guessing the speed sensor is going out or there is a bad wire. Has anyone heard of/seen this problem?

Posted by on

  • peter69colli May 04, 2009

    My 900 Firebolt has now 7500 miles on it and for the first time since new, the speedo has stopped working! I will try taking sensor out first and cleaning it.

    Anybody got any other ideas please let me know.

    Thanks. Peter.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,712 Answers

Clean the speed sensor connections and put electrical grease at the connections see if that helps.

Posted on Nov 10, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speedo stops working at times and when turning on ignition, the needles refrain from wiping across the clocks. then all of a sudden all works fine again. What to do?


Hi, William and the usual suspects are:
1. Contaminated speedometer sensor.
2. Corroded, broken or loose connector pins/sockets in the wire harness between the speedometer and the ECM and the sensor.
For more information about your issue and valuable "FREE" downloads please visit the websites below. Good luck and have a nice day.
Speedometer sometimes doesn work
Star Speedometer not working
Speedo and tach are not working
How to FIX For Scooter Speedometer and odometer Stopped Not Working

Mar 11, 2016 | Motorcycles

1 Answer

My 2003 ford focus speedometer stops working sometimes as does the elecyric odometer- sometimes both at same time. Other gauges work fine. The odometer goes to just dashes in place of the actual mileage...


Usually if both the odometer and speedometer stop working, the problem is the speed sensor on the transmission. You should also have a trouble code in the engine computer.
If one component works but the other does not, the problem is usually the speedometer head in the dash.

Sep 23, 2013 | Cars & Trucks

1 Answer

Bmw speedometer


Sounds like a bad or lose fuse. Take a look in the fuse panel and look for a loose fuse or blown fuse.

Jan 10, 2013 | 1993 BMW 325

1 Answer

Speedometer/odometer stopped working. Removed ca...


Because the inner cable has to turn and flex as it spins, they can occasionally break, this can be normal wear and tear. other reasons can be rust from washing, incorrect installation when changing tyres, or the outer has been kinked or damaged. Repace inner and outer as a set, apply some light lubrication.

May 19, 2010 | Motorcycles

1 Answer

2000 ford windstar speedometer and odometer problem


Could be a ciggerette lighter fuse, usually cause this when it blows.

Aug 21, 2009 | 1999 Ford Windstar

1 Answer

!992 Accord speedometer not working.


this is usually caused by a bad speed sensor heres the location http://senduit.com/09251d its on the transmission on the passenger side .
If there is anything else I can help you with let me know

Apr 03, 2009 | 1992 Honda Accord

1 Answer

Speedometer does not work


Sounds that the magnetic pickup on the vehicle speed sensor has stopped working. Dirt or grease usually. That will cause an erratic reading. Also check wiring to sensor. Poor connection is rare but possible. Good luck and have a good day.

Mar 08, 2009 | 1998 Subaru Forester

1 Answer

Speedometer stopped working


maybe speed sensor switch? usually located and attached to speedometer cable at transmission!??

Dec 28, 2008 | 1995 Nissan Sentra

Not finding what you are looking for?
2008 Buell Lightning XB12S Logo

544 people viewed this question

Ask a Question

Usually answered in minutes!

Top Buell Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Joseph Hoffmann

Level 3 Expert

1700 Answers

Are you a Buell Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...