Question about 2008 Benelli Velvet 125

1 Answer

Electrical problem I've been having big time electrical problems with my bike . First the turn signals turn on but don't blink. Then the neutral indicator doesn't work

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,712 Answers

Then the bike would not turn no at all (no clicks) then the bike would turn on but would shut down when I put it first gear (yes the side stand was up) now everything seems to work unless I flip on the high beams then the turn signals go out again or the bike doesn't turn on etc.. The problems seems to cycle through all these over and over again. Am I screwed?Sounds like it's time to invest in a new battery, or at least see if the old one will accept and hold a good charge. That should at least solve some of your problems.,,,

Posted on Nov 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

L have a Honda cbf 250 my indicators have stop working. next day l use the bike next day. when l turn the indicators on they work again switch off and turn them again they stop


Usually when electrical things bwork intermiittently, you have a loose wire somewhere - likely a ground wire for the lights. Check all wire connections for your lights and make sure they are tight and not corroded. If you have a loose or burned out bulb, the good signal light may come on but won't blink.Check your signal light switch too.

Don

Dec 03, 2014 | Honda CBF 250 Motorcycles

1 Answer

GS550 Electrical Problems.


try carefully shorting a screw driver accross solenoid the two big nuts with ignition on . try a meter on continuity starter casing to earth

Jul 18, 2013 | 1980 Suzuki Gs 550 L

1 Answer

2007 fatboy lost the 'flashing' of turn signals (but they still light up), lost horn, lost rear break light. All fuses in the fusebox are OK. I also lost all gauges (speedo, neutral indicator,...


Your turn signals (but not your running lights), horn and a few other things are on the "accessories" fuse in your electrical circuit, I think. If the fuse is not blown, I would guess that you have a bad connection in the power lead for that circuit. I'm not sure of what I'm going to say here because I don't work on the newer bikes but in the older bikes, the "orange" colored wires carried the battery voltage to the individual components much like "red" wires used to do in most DC circuits. I'd look for a bad connection in a plug somewhere. I hope this helps but like I said, I don't know a lot about the newer bikes. I mostly work on the older bikes that the dealers will not work on any longer.

Good Luck
Steve

Aug 13, 2011 | Harley Davidson FLSTF Fat boy Motorcycles

1 Answer

2000 Roadking my speedo works when it wants,and when my speedo doesn't work,my self canceling turn signals don't self cancel. Any help would be greatly appreciated.


The problem is with the speedo. The speedo has a "lean switch" that works in conjunction with the turn signal canceller. If the bike does not detect a "lean", the TSC will not cancel the turn signals Resolve the speedo problem and the turn signal problem will go away. As for what's causing the speedo problem, I have no idea other than maybe a loose connection. I've read a LOT of problems with the speedo not working on this forum but since I don't work the bikes built in 2000 and later, I'm afraid I have no experience with the problem and therefore cannot offer any advice.

Good Luck
Steve

Jul 17, 2011 | Harley Davidson FLHRC Road King Classic...

1 Answer

The bike has power, but the turn signals don't turn on, it doesn't even acknowlegde that im pushing the indicator switches.


Contact me directly at wd4ity@bellsouth.net and I'll send you a trouble shooting guide for the turn signals. Don't forget to remind me of what you need.

Steve

Jun 28, 2011 | Harley Davidson XL 1200 C Sportster Custom...

1 Answer

Have 1997 heritage softail classic neutral light will not come on even when changing blubs, other lights seem to still work,oil. bright lights, turn signals. Don,t know whar else to do?


Your neutral indicator switch may be bad. Look on the chrome cover on top of the transmission and you'll see a wire that plugs onto the neutral switch. Disconnect this wire and ground it to the engine. Turn on the ignition switch and the indicator light should light up. If it does, replace the neutral switch. If it doesn't, you've got a wiring problem between there and the indicator lamp.

Good Luck
Steve

May 31, 2011 | Harley Davidson FLSTC - FLSTCI Heritage...

2 Answers

92 FXR bike will not start or even turn over


the starter solinoid is not working if it has an electric start, try kick starting it, if it won't start check the points or the ingiter coil.

Aug 08, 2009 | 1993 Harley Davidson FXR Super Glide

1 Answer

Yamaha trx850 bike stopped then restarted no problem following week stopped again this time would not restart--no spark at all been in bike shop for 2 weeks they cant find anything wrong


If they find nothing wrong then the problem is obviously intermittent and can be very hard to find. Check the operation of the ignition switch and all kill switches with a volt ohmmeter. Check the wiring harness. Did a wire come unplugged? Are all wires clean and with solid connections? Any abraded or pinched wires? Is the bike in neutral and the neutral light is lit up? If no neutral light, check the neutral switch and neutral wire connection.
>
The usual source of intermittent loss of spark is the side stand kill switch. It kills the engine so that you don’t start out with the side stand down. Check for a broken wire at the switch or coupler. Get a service manual and check out the electrical section. Some bikes have a diode controller integrated into the turn signal relay. Try moving the kill switch by hand. If that doesn’t work then wire a jumper around the switch to bypass it. If that doesn’t work, check out the relay.The dealer would / should have load tested the various ignition components. I will assume the ignition system is okay. Check the battery and fuses. Install a new set of stock spark plugs.

Jun 12, 2009 | 1997 Yamaha TRX 850

Not finding what you are looking for?
2008 Benelli Velvet 125 Logo

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Benelli Experts

yadayada
yadayada

Level 3 Expert

60667 Answers

Connie Richardson

Level 1 Expert

15 Answers

Jazz Boyce
Jazz Boyce

Level 1 Expert

728 Answers

Are you a Benelli Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...