Question about 1999 Aprilia RS 125 Extrema

1 Answer

Aprilia rs 125 turn signals faulty

I have just replaced all the indicators on my rs125 (1999) as one was snapped, connected all the wires in the right places, and when i switch the turn switch, in either direction, all the indicators come on and stay on without flashing. I am stumped. Can anyone shed any light, as to why this is happening please?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Night Owl:

    An expert who has answered 10 or more questions between 12 midnight and 6am on the same day.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 74 Answers

This is a faulty indicator relay, replace the relay

Posted on Feb 23, 2012

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 2712 Answers

SOURCE: de-restrict an aprilia rs 125

You shouldn't have to restrictions only happen on faster bikes 600cc onwards but if you talking about the inabilty to push your revs to the very max, I wouldn't do this unless you know what you doing, and by you asking this question, you don't know what u doing, this rev restriction is set in place for safety of your engine, rather than restricting speed.,,,

Posted on Nov 10, 2008

  • 5 Answers

SOURCE: how much oil do i put in transmission on aprilia

500 - 600 ml

Posted on Jul 18, 2009

  • 9 Answers

SOURCE: how much fork oil goes in my aprilia rs 125 1998

front fork oil capacity is 430cc

Posted on Aug 02, 2009

  • 3567 Answers

SOURCE: My aprilia rs125 2007 jus cut out on me and wont fire up again

  • Start with a new spark plug. Now do you see spark? If not, check the side stand kill switch. It kills the engine so that you don’t start out with the side stand down. If broken or out of adjustment, it would kill the spark. Check for a broken wire at the side stand switch and coupler. Try moving the kill switch by hand. If that doesn’t work then wire a jumper around the switch to bypass it.
  • Check the fuses. How good is the battery? Try a jump start from your car battery. Is the handlebar kill switch on?
  • Check the operation of the ignition switch and all kill switches with a volt ohmmeter. Check the wiring harness. Did a wire come unplugged? Are all wires clean and with solid connections? Any abraded or pinched wires? Is the bike in neutral and the neutral light is lit up? If no neutral light, check the neutral switch and neutral switch wire on center casing. If still no spark, get CDI system and coils checked at the dealers shop.
  • Are the fuses good?
Can I get a “very helpful” rating on this answer? Thanks!

Posted on Aug 03, 2009

  • 4 Answers

SOURCE: Aprilia RS125 doesnt rev past 5000 rpm

not cooling properly

Posted on Aug 30, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Not starting off starter but goes with a push


Hi, Malcom Smith famous dirt bike rider extraordinaire and the usual suspects are:
1. Ignition Switch not in the "ON" position.
2. Engine Run Switch in the "OFF" position.
3. Discharged battery, needs to be 12.5 volts or better and be able to pass a "LOAD" test if necessary.
4. Check the battery terminals for damage or corrosion check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
5. Tip over sensor needs a reset.
6. Faulty ignition switch.
7. Faulty starter button.
8. Faulty kickstand or clutch pull in switch/sensor.
9. Starter control circuit, relay, or solenoid faulty.
10. Main fuse or circuit breaker may be blown or faulty.
11. Check for engine trouble codes.
For more information about your issue and valuable "FREE" downloads that you will need please click on the blue links below. Good luck and have a wonderful day.
APRILIA RS 125
Aprilia rs 125 trouble starting arghhh
RS50 wont start off motor but will easy when bumped
https://www.manualslib.com/manual/363586/Aprilia-Rs-125-Tuono-2003.html
Products at Aprilia Genuine Parts Aprilia Parts Aprilia Spare Parts...
APRILIA RS 125 2006 Manual

Mar 18, 2017 | 2003 Aprilia RS 125

1 Answer

No spark on aprilia rs 125


Hi, Anonymous if you have a CKP sensor it needs compression to send the correct signal to the ICM/ECM, make sure both spark plugs are in heads and use a grounded third plug to check for spark or hold spark plug cable close to spark plug in the head. If still not getting spark the usual suspects are:
1. Fouled spark plugs.
2. Battery voltage below 8.7 volts, loose or broken battery cables, check the "NEGATIVE" cable at both ends.
3. Loose connection at ignition coil or plug between ignition sensor and module.
4. Spark plug cables in bad condition, shorting / leaking, spark plug cable connections loose.
5. Faulty ignition coil or ignition / electronic module
6. Failed CKP, CMP, MAP or BAS sensor.
7. Faulty ignition switch.
8. Security alarm failing to disarm.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2008 Aprilia Rs 125

Jan 21, 2014 | 2008 Aprilia RS 125

1 Answer

Aprilia rs 125 sputters


Hi Anonymous, and the usual suspects are:
1. Spark plugs in bad condition or partially fouled.
2. Spark plug cables in bad condition or leaking.
3. Spark plug gap too close or too wide.
4. Faulty ignition coil, module and or sensor.
5. Battery nearly discharged.
6. Damaged wire or loose connections at battery terminals especially the ground cable at BOTH ends ignition coil or plug between ignition sensor and module.
7. Intermittent short circuit due to damaged wire insulation.
8. Water or dirt in the fuel system, carburetor or filter.
9. Fuel tank vent system plugged or carburetor vent line closed off.
10. Carburetor controls misadjusted.
11. Damaged carburetor or intake seals.
12. Loose or dirty ignition module connector at crankcase.
13. Faulty MAP, CKP, and or CMP sensors.
14. Incorrect valve timing.
15. Weak or broken valve springs.
16. Damage intake or exhaust valve.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2001 Aprilia Rs 125

Sep 27, 2013 | 2001 Aprilia RS 125

1 Answer

2008 aprilia 125 full power edition not revving over 7500rpm no power band any solutions?


Hi, Rankin345 and the usual suspects are:
1. Severely drained or faulty battery.
2. Faulty regulator/rectifier or high output coil.
3. Faulty power valve, solenoid or installation.
4. Clogged air filter or exhaust.
5. Cracked or incorrect float level.
6. Float needle is not seating.
7. Faulty reed valve.
For more information about your question please visit the website below. Good luck and have a nice day.
DOWNLOAD 2008 Aprilia Rs 125

Mar 05, 2012 | 2008 Aprilia RS 125

1 Answer

My aprilia rs 125 battery keeps going flat i charge the battery up and last round about 1 mile then gose flat my engine then cuts out i leave for 10mins then it gose again im thinking the magneto as ive...


Hi, Swiftb152 and the usual suspects are:
1. Voltage regulator/rectifier not grounded.
2. Engine ground wire loose or broken.
3. Faulty voltage regulator/rectifier module.
4. Loose or broken wires in charging circuit.
5. Faulty stator and/or rotor.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 1999 Aprilia Rs 125

Mar 16, 2011 | 1999 Aprilia RS 125 Extrema

1 Answer

2004 RS 125: aprilia rs125 2004 plate, cuts out when warm... wi...


Hi, Anonymous either the plate has failed or you have wiring issues check the positive/negative connections for continuity and I am sorry you can't find the first and best tool you ever bought for your Aprilia but despair not for a mere $10 you can download another one. For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2004 Aprilia Rs 125

May 18, 2010 | 2004 Aprilia RS 125

1 Answer

My indicators wont work what is the problem?


Hi, Gunsnith24d9 you may have a faulty turn signal module/relay/connection and I am sorry you can't find the first and best tool you ever bought for your Aprilia but despair not for a mere $10 you can download another one. For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2002 Aprilia Rs 125

Feb 27, 2010 | 2002 Aprilia RS 125

1 Answer

Aprilia rs 125 wont start got a spark and it says on clock cold cant get it to warm up could it be the heat sensor


Hi, Dr_croft and the usual suspects are:
1. Fuel tank empty.
2. Fuel supply valve/petcock turned off.
3. Fouled spark plugs.
4. Engine flooded as a result of overuse of the enricher.
5. Vacuum hose to the fuel supply valve/petcock disconnected, broken, cracked, or pinched.
6. Fuel valve/petcock or filter clogged.
7. Discharged battery, check battery terminals for damage or corrosion, check the battery cables at "BOTH" ends for loose, corroded, or broken connectors, "INSIDE" and outside the cable harness, perform connector wiggle test and check cables with an ohmmeter if necessary.
8. Loose or corroded wire connection at the coil, battery or plug between ignition sensor and module.
9. Spark plug cables in bad condition and shorting, cable connections loose, or connected to the wrong cylinders.
10. Ignition timing incorrect due to a faulty ignition coil, ignition module or sensors (MAP, CMP, CKP, O2 and/or BAS).
11. Security alarm needs a reset.
For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2000 Aprilia Rs 125

Jan 03, 2010 | 2000 Aprilia RS 125

1 Answer

Aprilia RS 125 (2004) - speedo not working


it may have snapped in the middle of the cable or check the drive in the front wheel

Aug 04, 2009 | 2004 Aprilia RS 125

1 Answer

Efi warning symbol and the red triangle warning light keeps coming on after a short ride. turn bike off and on and no warning lights appear.until i go for a blip some times it wont come on for a couple of...


Hi, Caroline850 my guess is you have a faulty wire connector and I am sorry you can't find the first and best tool you ever bought for your Aprilia but despair not for a mere $10 you can download another one. For more information about your issue, please visit the websites below. Good luck and have a nice day.
DOWNLOAD 2008 Aprilia Rs 125

Mar 10, 2009 | 2008 Aprilia RS 125

Not finding what you are looking for?
1999 Aprilia RS 125 Extrema Logo

234 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aprilia Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Arnie Burke
Arnie Burke

Level 3 Expert

4514 Answers

Fabrice Wolters

Level 2 Expert

163 Answers

Are you an Aprilia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...