Question about 1994 Toyota Pickup

4 Answers

No start Ive asked several people about this problem some of which are professional mechs and it just baffles me that the dealership cant even help me. SO! Heres the problem Ive got a 94 toyota pickup 4cyl 5spd 4x4. When I bought it it needed a new head gasket, new front gaskets and a new timing cover. I replaced all of these and go to start it and nothing, it just cranks. Turns out the fuel pump isnt running. So I follow all the wires and find that power going to it is cut some where behind the dash. So I jumped those two wires (the solid blue ones going to the pump) and now that works. I got to start it and it still...just cranks....So I checked an injector and it seemed fine and I left those alone cause I know its getting fuel cause Ive fouled the pluggs twice just from cranking it so much. It has spark cause Ive checked the plugs, the wires, and the coil. Still just cranks. found that when I put the head back on I neede to adjust the distributor timing so I did that ((was very carful as far as the timing goes on the cam and crankshaft in making sure I didnt so much as budge ither of those removing or instaling, when I removed the gear and chain from the head to replace the gasket)) and still...no...start. Im out of Ideas other than Im not getting enough compression some how or I havent managed to get the timing right on the distributor.

Posted by on

  • 2 more comments 
  • Haraku Aug 28, 2008

    well if thats all it takes to get it right than I have it right cause thats what I did.(except I used a coat hangar) I thought it just might be off cause when I went to adjust it to make sure it was right I misread the manual and thought it meant that their were two strokes involving the TDC but it was just saying on the exaughst stroke their would be no compression but the timeing marks would allign. So I must have the timing right SO how do I check compression and what else could my trouble be?

  • Haraku Aug 28, 2008

    hm k what do the relays do exactly cause I know it wasnt getting gas cause the pump wasnt working (I dropped the tank and pulled the pump and everything just to find it wasnt getting power.) and I fixed it and its getting gas for sure and Ive also tried putting a little fuel in the intake like you just said I tried some carb cleaner with no result and I tried putting a little gas in their to the same result and then I put in enough to blow the whole thing up with yet the same result. and where would I find these relays if what I jsut told you hadnt eliminated the need to check them?

  • Haraku Aug 29, 2008

    the crankshaft positioning sensor is built into the distributor I think so to test that would I jsut have some one crank it while I go at the wires with a test light? if yes what responce should I get from the light flash or solid? the egr valve doesnt apear to be a valve at all as in their doesnt seem to be any moving mechanical parts it looks like a tube with a space ship looking part with a couple vacum hoses attached if Im reading the same thing in the book and looking at the same thing on my engine, so how do I go about unsticking it?

  • Haraku Oct 21, 2008

    EGR valve is good. ive had it for...sveral months now and its starting to get cold out so im going to take another stab at fixing it myself. But ive discovered that if I let the truck sit for say a week or so and try to start it, it will fire on the first couple of cranks and then go back to just cranking. MY thoughts are that when I jumped the wiring across the dash because of the no power problem with the fuel pump I msut have jumped some sort of control that monitors the the gas input on the EFI cause the only thing I can think of is that its pouring so much gas in their that it floods before it gets a chance to fully fire up cause it smells and sounds like its just pouring gas in their non stop.

×

4 Answers

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 4 Answers

I had the same problem with my chevy s 10 I got a new rotor button and new distributor cap and it fired right up!! what happens is over time the gold covering on the rotor button wares off and no longers sends a spark to the plugs. A new rotor button is in the 5 to 10 dollar range and a new distributor cap is arounds 20 to 30 dollars!! good luck bro,

Posted on May 14, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Get a scanner you may have an ECM issue, it is possible that u some drivers arent working.

Posted on May 30, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 422 Answers

Check the crankshaft positioning sensor or the egr vavle might be stuck all the way open

Posted on Aug 28, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,263 Answers

If it's a matter of timing then i would suggest remove the #1 spark plug. then manually turn the crank until it reaches top dead center(i use a 1/4 drive 6 inch extension) place in plug hole and you should feel the top of the piston. then take your distributor and replace it with the rotor pointing in the # plug position your timing should be right. From what you describe it seems you could be 180 degrees off on the timing

Posted on Aug 28, 2008

  • Ronald Mueller
    Ronald Mueller Aug 28, 2008

    ok if it's cranking and you got spark check the fuel pump relays to make sure they are still good. mostimes people assume because they are not getting gas that the fuel pump is out but alot of times the relays are bad. onother easy way is add a lil gas or starter fluid to the intake side like in a air filter box or the rubber tub to the throttle body if it fires you know that it's on the inflow of the fuel side but i would check those relays first. I hope this helps.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Irpms very high, temp guage not working, no cel on, no codes, it drives, shifts,thermostat working fan comes on. it pings at 40 to 50 miles per hour, then stops. after driving and turning engine off,


you have a number of things wrong, but lets start with it running ive only got a small picture if what your saying it drives for a short time turn engine off then start again it runs again is this right???.please tell me more I cant help you until I get the full facts,adrian....

Mar 19, 2014 | 2005 Ford Escape

1 Answer

2000 Isuzu Trooper cannot find engine temp gage sensor


this is where it is at on a 1998-2000 3.5 V6
ec76c3f2-a279-4de1-8718-f7c0c10aac55.gif
1997 3.2 V6

1eb986fc-b23d-4597-a9f3-5c836b631269.gif

Nov 23, 2013 | Isuzu Trooper Cars & Trucks

2 Answers

Just bought a citroen c4, 1600 hdi it is making a humming noise. sounds like its coming from the engine.the more exceleration the louder it gets.please help


my heart goes out to anyone that buys a French car.
what a bad deal that is....

first off never drive a car with bad sounds, like that.
it can cascade or even cause and accident.
and point 2,ever ask a web bunny to help fix a engine.
i cant see it, touch it ,hear it or drive it nor do the tests.
finding noise is a human hands on deal.
find a mechanic. here in USA we use ASE certified mechs,

find a mech and just ask him/her to listen. or fail big time.

Oct 03, 2013 | 2002 Suzuki Vitara

2 Answers

Please help! My Sorento lost all power whilst driving. The steering lock comes on and everything cuts out! This has happened 9 times in one day. The engine management light stays on. Local garage thought...


ask the dealer(kia) for a diagnostic report,this will show what needs to be done then decide wether you can fix it, or your tame tech can do it, or even if you want the dealer to do the job,that way you control the bill,(play the dealer off against your mech to get the best labour rate/deal.(the dealer will try and baffle you with codes,do not accept this form of bulls..t.ask and get a FULL diagnostic report.after all your paying his salary.and even if you only get codes WE CAN HELP WITH THOSE..........

Nov 26, 2010 | 2005 Kia Sorento

2 Answers

1999 Toyota Solara Unfixable Problem !!!


interesting problem, sound like a similar situation with a van i worked on for a week, turned out the alternator bracket was not grounding to the engine block, try running a ground direct from the alternator to the battery, i know it sounds farfetched but at this point trying anything is worth the effort. if this doesn't help i'll try to think of something else, its all i can think of for now

May 24, 2010 | 1999 Toyota Camry Solara

1 Answer

Ive got a 98 concord no dash lights and wont shift from first ,Ive replaced transmission control module 6 times chrysler dealership said they cant fix can you help


Call the service department and ask them if they know if there is a speed sensor available for the car and where it is located (internally or externally) this may be the problem or the secondary shift solenoid is bad. If you have not gotten any progrees from these strategies I would bring the car to an electrical diagnostic shop if they can trace the problem with the dash lights they may fix the transmission shift issue as well.

Jul 14, 2009 | 2001 Chrysler Concorde

1 Answer

Want to change waterpump on mazada626


try asking a Mazda dealership mechanic, most mechanics Ive asked have been very generous in giving information. Also , a Chilton manuals , sold at auto parts stores, are very helpful with step by step instructions

Jun 12, 2009 | Mazda MAZDA6 Cars & Trucks

4 Answers

No start


Turn the engine by hand to Top dead center on the # 1 cylinder,Pull the distributor cap and see where the rotor is pointing.It should be lined up with the # 1 plug wire on the cap,If it's not,turn the distributor until it is.If you can't turn it far enough,you will need to pull the distributor out and turn one tooth on the distributor gear and reinsert it.

If this it is way off,let me know and I will tell you what to do.


please rate this a fixya

Feb 13, 2009 | 1999 Ford Escort

Not finding what you are looking for?
1994 Toyota Pickup Logo

461 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toyota Experts

yadayada
yadayada

Level 3 Expert

61249 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Toyota Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...