Question about 1997 Land Rover Range Rover

1 Answer

Overflow hoses hey my truck ran hot,so i discovered a hole in the overflow hose,then engine light  on,so i change hose,and engine light is still on aand my gauge  still go to hot temp. do you have any suggetion or input

Posted by on

  • shanma Aug 31, 2008

    your feedback was very helpful,but it still running hot,i think water isn't getting to the radiator.but thank you

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,035 Answers

Please check the hose any for any leaks ,please remove the wires from the battery for 30 min this will reset the computer of the truck make sure that unlock code for any security system...and then plug the wires and check if the light come on the truck...


Good luck...

Posted on Aug 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What cause lower radiator hose to collapse after cool down


Hi Larry:
Good observation. Not too many people would spot that.
When the engine is hot, the coolant is hot and expands. At the filler cap for the radiator, there will be a hose that goes to the overflow tank. As the coolant fluid expands, it flows through thie tube into the overflow tank.
When the engine is turned off, as it cools, the volume of coolant in the engine and radiator contracts, and is supposed to suck fluid back from the overflow tank.
I'm suspicious that something is preventing this from happening so the vacuum in the engine coolant system is collapsing the hose.
WHAT TO DO?
- Check the radiator cap. Make sure it is functioning correctly. Make sure that it is correctly installed and screwed all the way on.
- Check the coolant overflow hose. Make sure it is not plugged.
Odds are that you will find the problem quite quickly.
Cheerfuls.

Sep 27, 2015 | 1991 Toyota Corolla

1 Answer

Why is my 96 camry spraying coolant?


The overflow tank is not pressurised, so will not spray coolant around. The little hole is a breather. On the other side, possibilities are a cracked radiator top tank (it is plastic, and your Camry is about the right age to develop this), or a leaky hose or hose connection on the driver's side. Open the bonnet, wash the engine with a hose, allow it to completely dry, then start the engine and idle till hot, watching like a hawk with a torch to see where the leak appears. This is easier if you have a helper and the car is on wheel ramps.

May 18, 2014 | 1996 Toyota Camry

1 Answer

Overheating


CAR OVERHEATING FIRST CHECK FOR LOW COOLANT IN THE RADIATOR COOLANT OVERFLOW JUG.IF COOLANT LEVEL IN OVERFLOW JUG LOW REFILL ADD COOLANT BACK TO THE FULL COLD MARK.PUT RADAITOR CAP ON COOLANT OVERFLOW JUG START ENGINE LET IT IDLE UNTIL IT OPERATING TEMPERATURE.MAKE SURE TOP RADIATOR HOSE GETTING HOT WHILE ENGINE WARM UP.IF TOP RADIATOR HOSE DONT GET HOT WHILE ENGINE IDLING YOUR THERMOSTAT COULD BE STUCK CLOSE CAUSING CAR TO OVERHEAT.IF TOP HOSE IS GETTING HOT.CHECK FOR COOLANT LEAKS CHECK TOP RADIATOR HOSE AND BOTTOM RADIATOR HOSE FOR LEAKS.CHECK FOR LEAKS AT THE RADIATOR CORES AND PLASTIC SIDE CONTAINERS.IF ALL IS GOOD ENGINE OVERHEATING WHILE IN A LONG TRAFFIC LINE, COOLANT FANS NOT COMING ON.COULD HAVE FAULTY ENGINE COOLANT TEMPERATURE SENSOR OR BLOWN COOLING FAN FUSE OR RELAY.COULD HAVE PCM FAULT.MAKE COOLING FAN ELECTRICAL CONNECTORS AND WIRING NOT DAMAGE OR BROKEN.

Jul 17, 2011 | 1999 Oldsmobile Alero

1 Answer

I got a 2000 dodge durago and i smell raditor when i am at the light i just got a new one installed is there a problem with my truck


open the hood and inspect for leaks. if you smell it, theres a leak. check radiator hoses,caps on radiator and plastic overflow resevor . a flash light may help find a small leak as the hoses run into dark places. the place that installed the radiator may not have done a good job. the caps should be checked with cold engine and the hoses with hot engine. donot remove caps when HOT. good luck

Apr 18, 2011 | 2000 Dodge Durango

2 Answers

The heater just quit working. It worked fine yesterday but this morning it does not. The car is running a little hotter trhan normal but not overheating. Any ideas?


I would check to make sure the radiator is full and the overflow tank is filled to the proper level. It doesn't have to be very low for these cars to stop blowing heat.

Feb 01, 2011 | 1992 Subaru Legacy

1 Answer

Where is the drainedge for the radioter


For a 2001 Buick Regal GS 3.8 Liter, Supercharged engine:

First, let engine cool some. Second, locate small drainage hole at the bottom left/drivers side, of the radiator. From the bottom of this small drain hole, go straight back toward rear of radiator, then up about 1 1/2 to 2 inches up. (Have a drain pan or pail handy, to catch the old antifreeze.) You'll find a dark colored drain nut. Use a larger, correct sized socket ratchet wrench & loosen this fitting a turn or so, counter clockwise. Old antifreeze will begin to come out the bottom drain hole. The more you loosen the fitting, the faster the fluid flow out. I wouldn't remove the drain plug completely, or you'll loose control of the draining flow rate.

I just changed my anti-freeze just last week. I also changed the 2 large radiator hoses & smaller 2' overflow hose at the same time, as long as I was doing the job. They had never been changed before. I also used new hose clamps & a small packet of "radiator hose grease", from Autozone.. I drove the car up onto front car ramps to make it easier. I used safety jack stands for extra care. " You-Tube" shows some, "how to videos", that are helpful.

The old hose clamps are difficult to get to. (You'll need a few tools, some time & patience.) To get to the upper clamp, near the right/passenger side of the of the car, near the battery, I removed the outer serpentine belt & tension pully. I then removed the factory installed spring tension clamp, with the help of an adjustable battery pliers. The bottom of this hose wasn't too bad to get to. On the left/drivers side of car, remove black air intake box to access upper clamp. Remove the black metal brace bar, the will allow access to the air intake black box.

I also changed the small overflow 2 foot long hose & 2 clamps, that goes from radiator cap area, back to the overflow white plastic tank, close to passenger firewall. I removed the overflow tank to clean it out as well. I drained the fluid & changed the 3 hoses & clamps. I then placed all removed parts back where they belong, including white plastic overflow tank, tension pully & outer serpentine belt, air intake black box & metal diagonal brace, contacting air intake box. I flushed the system with some Prestone Radiator Cleaner & clean water. Start car & get up to temp., then run for about 10 minutes. Let cool, then drain again. I flushed my car at least 2-3 times after this, until the drain water ran clear.

The best price on a 5 year/150,000 mile anti freeze, came from Wal-Mart. I then mixed about 50/50 with Distilled water, as suggested on the bottle. All went well & no leaks! I took my time and did a thorough job. Good luck!

Jan 16, 2011 | 2001 Buick Regal

2 Answers

Where Does The Overflow Tank Hose Connect


to weaker mixture will cause vehicle to overheat ,but i think that the radiator cap rubber has perished causing the coolant to throw out or the head gasket ,get the cooling system pressure tested ,and then run engine with gauge attached to check for excessive pressure build up ,(head gasket test) ,another trick is to fit a bottle to end of the overflow pipe so what goes out gets sucked back in when engine cools .Check the rubber seal in teh rad cap and check the seating that it pushes and closes onto.As for the sliding doors use your judgement and you will not go far wrong

Dec 24, 2009 | 1999 Ford Windstar

1 Answer

Changed radiator hoses and cap. changed coolant. still not getting flow with overflow into bottle. Thinking it may be bad thermostat. had coolant come out under cap. checked bottle and cap and no leak...


I had a leak on my top on hose on my jeep it was such a small hole I couldnt even recognize it. Almost mistaked it for the metal pipe corroding through. Now anytime your messing with the hoses it is best to just change the thermostat. They are cheap and easy. I would try that and go from there. Also how hot is it getting? 220 degrees is normal for jeeps. Should go a little past the middle line. Then the fans kick in and bring it back down. Also squeeze the hoses once it gets all the way hot and see that they have full pressure in them.
Thanks,
Lee

Sep 08, 2009 | 1992 Jeep Cherokee Sport

2 Answers

Over heating


Have you changed the thermostat? The way you describe it seem like a thermostat.

Jun 30, 2009 | 1998 Volkswagen Jetta

Not finding what you are looking for?
1997 Land Rover Range Rover Logo

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Land Rover Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

60960 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Land Rover Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...