Question about Alfa Romeo 156

1 Answer

My indicators and hazard warning lights have both suddenly stopped working have checked all fuses all seem ok

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Alfa Romeo Master
  • 70,365 Answers

I think there is an issue with turn signal switch, test the leads at the switch that are supposed to have power, if they are ok replace the switch. An inexpensive test light will do nicely for these checks.

Posted on Aug 21, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Indicators/lights not working on my 94 polo,checked fuses,they seem ok.no idea what it could be?


check relay and hazard light switch as the switch is not often used they some times gum up operate the hazard switch several times

Dec 30, 2013 | 1995 Volkswagen Polo 1.4

1 Answer

Indicators & hazard lights


it is worht checking the fuses and also keep working the hazard light switch as they are not used that often they tend to get sticky on the con tacts and that will knock out your indicators as well if they start to work after working afer working the haz switck then change the switch

Dec 30, 2013 | Mitsubishi Outlander Cars & Trucks

1 Answer

I have an 02 kia sportage. my signal lights come on but dont blink outside. no lights for the signal lights come on on the dash at all. also, no hazard lights.


If the 15A HAZARD fuse in the passenger compartment fuse box is OK, power is getting to the hazard function of the flasher unit. Pressing the hzard switch should cause the hazard lights to flash. HOWEVER, there is an electronic time and warning indication system module connected to to the hazard switch lead and that may be affecting things. If the 10A TURN fuse is OK, power is applied to the turn switch (with the engine in START or RUN) and you state you can select a right or left turn. HOWEVER, the RED/WHT and RED/BLU outputs from the flasher unit connect directly to the front and rear turn lamps and the instrument cluster turn indicators so you are not getting any flasher output. Again, that electronic time & warning indication system module could be affecting things

Oct 26, 2012 | Cars & Trucks

2 Answers

1992 jeep cherokee laredo fuse box diagram , signal lights and hazards don't work all of a sudden


check the light first when one goes out they seem to stop working alltogether

Jan 11, 2010 | 1992 Jeep Cherokee Sport

1 Answer

Renault kangoo indicators and hazard lights have stopped working, checked the fuses there ok. Could you help?


Most common cause is a failed indicator relay. Just swap it with a known good one to confirm whether it's faulty but ensure it's correctly rated for your Kangoo.

After that, the next most common causes are more expensive: the indicator switch and the hazard light switch.

Nov 01, 2009 | 2000 Renault 181

2 Answers

No hazard lights


Check the hazard switch and the connector to hazard switch see if u have the power and earth to hazard switch if there is power and earth to switch then replace ur hazard switch its faulty but if there is no power and earth to switch then it has whirring problem

Jun 16, 2009 | 1997 Mitsubishi Mirage

1 Answer

I have a hyhudai getz and the indicators just stopped working are they just on a fuse or is it an electrical problem?


hi from the uk 1st thing to check is fuse located on inner panel inside just above bonnet release lever it is 10amp red fuse position is 2nd fuse down on l/hand column ? then if ok? check the flasher unit is working /clicking when selected also your hazard warning switch is also arelay? hope this helps hope its just fuse good luck

Nov 27, 2008 | Hyundai Accent Cars & Trucks

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

252 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alfa Romeo Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

yadayada
yadayada

Level 3 Expert

70347 Answers

ROBERT GARCIA
ROBERT GARCIA

Level 3 Expert

570 Answers

Are you an Alfa Romeo Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...