Question about 1995 Cadillac DeVille

1 Answer

94 4.6 deville coolant hot,eng hot ,limp mode

Just purchased 94 cad previous owner replaced water pump,thermostat & temp sensor..runs for 2 mins then limp mode..i replace with new radiator..flushed engine ..still did the same thing then i ran car with out it runs ..but still goes to limp then i connected garden hose to heater hose and let the water run out of water pump ran like a charm no coolant hot engine hot no **** mode ..could it be still the temp sensor???..i am lost ..not sure ..think of taking it in to the dealer...any thoughts out there on what it could be to guys at thermagasket they think it might something with the computer pcm ??? etc..

Posted by on


1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 74 Answers

Pull codes from on board diagnostics turn key on not running press and hold hot button on temp and off at same time till dash lights up write down codes respond with all computer codes i will help you determine prodlem and try to fix

Posted on Aug 26, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

2 Answers

My 05 DeVille Keeps running Hot! Temp Gauge Goes Up And Down..Then Level out today.. So it's possible the thermostat Is Bad..

start there replace the thermostat

replace the temp sender
make sure the engine cooling fan comes on and spins fast enough
check for old or soft hoses and how tight the clamps are

if temp is still up and down might be
air or a leak in the system


Oct 26, 2016 | Cars & Trucks

1 Answer

Shuts off when warm wont stat until cool

audi tt sensors - forum about car parts and car advices
audi tt sensors 2004 audi tt coupe windows roll down hi all only new to forum 2001 ...2002 audi tt purchase advice newbie looking to get a tt. ... Used on cold starts towarm engine and cat faster. .... replaced and sending my car into limp mode. my ac just shut off one day and will not turn back on. the esp in the car is stuck off.

Sep 22, 2015 | 2002 Audi TT

1 Answer

Replaced head gaskets on pontiac trans am 1997 lt1 eng now its over heating

trapped air. When temp needle climbs to 1/4 way, loosen coolant temp sensor to bleed off trapped air in cylinder heads. Air is gone once coolant starts to stream out, but only open slightly at a time. May have to do in increments as trapped air will cause rapid overheat

Jul 03, 2015 | Pontiac Cars & Trucks

1 Answer

94 accord ex still running hot after new water pump,hoses,termostat

Is it actually overheating or is your gauge just saying it is, did you measure the water temp to see if you have a bad temp sensor?
Have you started it from cold with the radiator cap off and let it warm up till water starts circulating so you can see that it actually is? New thermostat in backwards could cause it also.

Apr 15, 2015 | 1994 Honda Accord

2 Answers

My car keeps randomly going into limp mode

O2 sensors will do this and many times will not leave a trouble code.

Dec 04, 2014 | 2003 Dodge Stratus

3 Answers

1999 astro/4.3L/starts cold /runs 10-15 min. then dies will not start hot new coil/clean filter/pump 2 yrs old installed new/battery shows 14 amps when running/ won t crank when hot either/...

car shuts off when it gets to normal operating range. it takes 10-15 minutes to reach normal range. causes: low coolant, failing coolant tempurature sensor, air in water pump, check the coolant temp. sensor. if it is bad it will send wrong info to engine when hot, and shut it down. ITS WORTH A TRY!! good-day!

Sep 15, 2011 | 1999 Chevrolet Astro

3 Answers

I have a 94 crown Vic I just put a thermostat in it how do u know if it thermostat bad cause it running hot now

If it was running hot before you replaced the thermostat and the new stat didn't help it, most likely you have another problem. First make sure you installed the new thermostat correctly and not upside down and make sure you have purged all the air out of the cooling system. Your radiator could be clogged and restricted, not allowing coolant to circulate. Your fan clutch could be faulty or the radiator fan is not working properly. You could have a bad head or head gasket causing combustion gases to enter the cooling system. The water pump impeller shaft could have broke---These are the most common causes for an overheating problem. Good luck, i hope this helps.

Jul 11, 2011 | 1994 Ford Crown Victoria

2 Answers

My 2000 cadillac deville keep running hot when i drive it.the coolant shoots out the coolant tank when i open it.i changed the radiator and the thermostat.i don't think a head is blown cause it dosen't...

OK, check that the 2 fans are turning on when it gets to operating temperature. If not, replace the 3 or so relays that control the two speed fans on your car.If that doesn't solve the problem, then you may have to buy new fan motors and also have the harness replaced if necessary to make it cool reliably.

I had this problem on a 1997 Cadillac Deville Limousine that overheated over 157 deg. F and went into its limp mode for cooling the engine off by allowing 1/2 of the cylinders to circulate fresh air into the engine in case all antifreeze would leak out or the car would overheat.

Don't run the Northstar engine too long, more than 45 min. at a time in this limp mode.

Good luck on this repair of your Northstar Engine.

Jan 02, 2011 | 2000 Cadillac DeVille

Not finding what you are looking for?
1995 Cadillac DeVille Logo

502 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts


Level 3 Expert

77932 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22306 Answers

Ronny Bennett Sr.
Ronny Bennett Sr.

Level 3 Expert

6927 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides