Question about 1995 Cadillac DeVille

1 Answer

94 4.6 deville coolant hot,eng hot ,limp mode

Just purchased 94 cad previous owner replaced water pump,thermostat & temp sensor..runs for 2 mins then limp mode..i replace with new radiator..flushed engine ..still did the same thing ..so then i ran car with out thermostat..now it runs ..but still goes to limp mode..so then i connected garden hose to heater hose and let the water run out of water pump housing...car ran like a charm no coolant hot engine hot no **** mode ..could it be still the temp sensor???..i am lost ..not sure ..think of taking it in to the dealer...any thoughts out there on what it could be ..talk to guys at thermagasket they think it might something with the computer pcm ??? etc..

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 74 Answers

Pull codes from on board diagnostics turn key on not running press and hold hot button on temp and off at same time till dash lights up write down codes respond with all computer codes i will help you determine prodlem and try to fix

Posted on Aug 26, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

My 05 DeVille Keeps running Hot! Temp Gauge Goes Up And Down..Then Level out today.. So it's possible the thermostat Is Bad..


start there replace the thermostat

replace the temp sender
make sure the engine cooling fan comes on and spins fast enough
check for old or soft hoses and how tight the clamps are

if temp is still up and down might be
air or a leak in the system

26328754-q3uh2srnghbiaye4x0nczjdp-1-0.jpg

Oct 26, 2016 | Cars & Trucks

1 Answer

Replaced head gaskets on pontiac trans am 1997 lt1 eng now its over heating


trapped air. When temp needle climbs to 1/4 way, loosen coolant temp sensor to bleed off trapped air in cylinder heads. Air is gone once coolant starts to stream out, but only open slightly at a time. May have to do in increments as trapped air will cause rapid overheat

Jul 03, 2015 | Pontiac Cars & Trucks

3 Answers

1999 astro/4.3L/starts cold /runs 10-15 min. then dies will not start hot new battery.new coil/clean filter/pump 2 yrs old installed new/battery shows 14 amps when running/ won t crank when hot either/...


car shuts off when it gets to normal operating range. it takes 10-15 minutes to reach normal range. causes: low coolant, failing coolant tempurature sensor, air in water pump, check the coolant temp. sensor. if it is bad it will send wrong info to engine when hot, and shut it down. ITS WORTH A TRY!! good-day!

Sep 15, 2011 | 1999 Chevrolet Astro

2 Answers

My 2000 cadillac deville keep running hot when i drive it.the coolant shoots out the coolant tank when i open it.i changed the radiator and the thermostat.i don't think a head is blown cause it dosen't...


OK, check that the 2 fans are turning on when it gets to operating temperature. If not, replace the 3 or so relays that control the two speed fans on your car.If that doesn't solve the problem, then you may have to buy new fan motors and also have the harness replaced if necessary to make it cool reliably.

I had this problem on a 1997 Cadillac Deville Limousine that overheated over 157 deg. F and went into its limp mode for cooling the engine off by allowing 1/2 of the cylinders to circulate fresh air into the engine in case all antifreeze would leak out or the car would overheat.

Don't run the Northstar engine too long, more than 45 min. at a time in this limp mode.

Good luck on this repair of your Northstar Engine.

Jan 02, 2011 | 2000 Cadillac DeVille

3 Answers

99 deville head gasket leak?


A head gasket leak is usually indicated (among other things) by continous overheating of the motor, and subsequent loss of coolant.
It can also be indicated by the presence of engine combustion gas bubbles in the coolant resevoir.
Ensure the coolant system has no external leaks, such as faulty hose/s, radiator etc.

Ensure motor tune or other motor mechanical condition is not the cause of overheating.
I assume the motor is actually running hot.

Check cooling fans are operating ok (as necessary when car warms up):- if not check
1) fuse,
2) relay operation,
3) heat sensor switch.

Check/replace the thermostat,
Check the coolant pressure cap is serviceable & of correct rating,
Ensure cooling system is correctly filled, bleed off any airlocks as necessary when re-filling,
Ensure radiator hose on suction side of waterpump is not collapsing at engine revs above idle (due softening),
If the motor has been severely overheated, the head gasket could be blown - look for combustion gas bubbles in the coolant resevoir.

Sep 21, 2009 | 1999 Cadillac DeVille

1 Answer

Temp sensor needs to be replaced


this does not mean the sensor is defective, it most likely means the engine thermostat is stuck open and the engine is not running hot enough to satisfy the computers preset temp requirements for minimum eng operating temp.

Apr 08, 2009 | 2002 Daewoo Lanos

1 Answer

1990cad deville overheating


the first thing to check is to have the engine running. as soon as it reaches operating temp the upper radiator hose should get hot. if it doesn't then it's the thermostat. if it does then i believe your water pump is probably not circulating like it should and it should be replaced. however before replacing the wter pump make sure that the wire to sending unit is tight and not giving you a false reading. if your model has electric fans make sure the fans are running when the engine is hot. if they are not running check the relay in the fuse box for the fans with the engine running switch out the fan relay with the a/c clutch relay. ifthe fans kick on replay the relay with a new one. if they don't click on the it's either a bad wire or the temp sensor probe is bad. hope this answers your question. please rate this solution...thanks.

Aug 30, 2008 | 1990 Cadillac SeVille

Not finding what you are looking for?
1995 Cadillac DeVille Logo

477 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

63291 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21981 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...