Question about 1992 Cadillac DeVille

1 Answer

Accelerator problem Today I started my Cadillac and it started to make a weird noise inside the engine so when I put it on reverse it was fine since my drive way it?s kind of a little hill. But when I put on drive it wouldn?t go forward at all, like if had no power I?ve check my car and it was running good till today. It almost sound like it?s a spark plug. But a year ago I gave it a major tune up. So I?m not sure what the problem is I?m confuse I would thankful if anybody has any idea what the problem could be. Thanks

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 255 Answers

Hi even if you had a mayor tune up you still have to do mantenance to your car , be sure you check your fuel filter, you can also add a good fuel injection cleaner to the sistem ,it wont hurt, leave the car runing for some twenty minutes afther you add the cleaner ,also check your oil levels ,(motor & transmition ,checkthe spark plug wires and also if you know how check the spark plugs .GOOD LUCK......

Posted on Aug 24, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

It drove fine but when I got off the motor way and into town it started smoking loads of smoke and the accelerator made a weird noise


Do you notice any check engine lights coming on the dash when this happens, also has the vehicle had any recent repairs or any reason why this may be happening? Any input from you is helpful. I will check my resources and see what we can find out. Please advise

Jul 07, 2015 | 2004 Toyota Previa 2.0

1 Answer

I have a 2001 Cadillac SLS seville and when it in park or neutral the rpms rove up fine but when I put it invdrive or reverse I step onbthw gas it won't go pass rpm 1 what will cause this


Something inside the transmission. TCC solenoid/valve could be a cause. Have the codes checked, even if the check engine light isn't on.

Jan 18, 2015 | 2001 Cadillac Seville SLS

1 Answer

2008 vw jetta makes noise from blower


OK. The noise you are hearing is the recirculation flap motor. It could be what is causing the condensation. Easy way to check in after the noise has stopped push the recirculation button on the AC controls to see if the noise happens. If the motor is bad and the flap isn't closing you could be getting moisture from the outside air. As far as the check engine light goes there is no relation. 2 completely different systems. The flap motor would probably run you a couple hundred of dollars. The check engine light could be anything.

Dec 14, 2013 | 2000 Volkswagen Beetle

1 Answer

1997 Cadillac Seville Engine races 4000 RPM on startup


run fault codes and check for accelerator position sensor problem Check for MAP/MAF sensor faults.

Nov 17, 2013 | Cars & Trucks

1 Answer

I have a 2000 GMC Jimmy that has around 93,000 miles on it. The last oil change was 2 weeks ago. Today, on a trip on the interstate, I pulled off to have dinner. When I left the restaurant and started...


If the trucks engine rev'd up when you first put the gas pedal down, but didn't go anywhere then it was probably in neutral (not drive as you thought). If it was in drive and still didn't go anywhere but engine still rev'd up then its a transmission issue or PRNDL switch at the side of the tranny. I can't see anything relating to the gas pedal by NOT reving up the engine when it was pressed down. I wouldn't suspect a throttle cable issue. Check the tranny fluid while truck is running in park, see if the fluid is badly burnt or low on the dipstick. If it looks good I would have the PRNDL switch checked. (Park Reverse Neutral Drive and Low) switch.

Jan 31, 2011 | 2000 GMC Jimmy

1 Answer

The engine runs fine, but there is no power to the wheels. This just started today when there was a weird noise and then no power.


make sure the fluid level is good,the cable is still attached and if the fluid level is good smell it to see if it smells burnt

Sep 24, 2009 | 2001 Honda Civic

1 Answer

Cranking & Idle issue 92 Isuzu Rodeo


could be many things. Could be choke causing problems, could be engine temperature sendor bad, could be EGR. When you mean engine light comes on do you mean service engine light coming on? Probably has codes set which means something is gone wrong and setting a code that tells the tech what is wrong or what to look for. Have you changed your fuel filter lately?

Jul 28, 2009 | 1992 Isuzu Rodeo

1 Answer

2002 PT cruiser trying to start with no keys!


I would check your wire harness. The starter is close to where you would be working on the radiator. I have not had the pleasure to put one in but i know its a tight squeez in there.

Jul 22, 2009 | 2002 Chrysler PT Cruiser

1 Answer

I have a 2001 GMC Yukon. It was running fine until two days ago. I went to start it on Saturday and it would only make a clicking noise. I was able to start it with jumper cables. I drove for an hour...


i had the same exact problem with my chevy s-10, but once i replaced the battery it ran fine no problem, u may have fried some circuits and relays while jumping the car, and alot of times that clicking noise is your relay burning out, did your car start doing weird things too? like ejecting cd's, flashing lights really fast and weird noises?

Jul 21, 2008 | 2002 GMC Denali

Not finding what you are looking for?
1992 Cadillac DeVille Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Cadillac Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6811 Answers

Are you a Cadillac Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...