Question about 1993 Chevrolet S-10 Blazer

2 Answers

Brakes go out at speeds above 60 mph

I have a 93 chevy blazer s-10. I bought it as a restore project to tinker with. The ABS light has been on since I bought it. After I replaced all the brakes driving around town was fine but I discovered once I got on interstate and get up around 60 mph it feels like only one wheel is grabing and it sounds like grinding metal. The first time it did this I almost wrecked because it caused the vehicle to shift around. Once I get back under 60, the brakes seem to go back to normal and brake fine and normal. So, I have just been using this vehicle for little trips around town.

I took it to a brake place and they recommended a brake pump and brake module. Does this sound like what could possibly be the problem? Also, when they say brake pump and module are they referring to the brake booster and ABS module?

Thanks,
Glenn

Posted by on

  • glenntate Aug 19, 2008

    O.k. I will try this. Thank you.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Top Expert:

    An expert who has finished #1 on the weekly Top 10 Fixya Experts Leaderboard.

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

  • Chevrolet Master
  • 61,168 Answers

You may need the hydraulic control for the anti-lock, but it is more likely you need a wheel speed sensor, if the anti-lock module looses the wheel sensor signal all types of strange brake concerns occur, check all the wheel sensors and the trigger wheels, make sure they are not clogged with dirt or have broken trigger wheel teeth or damaged wheel sensor wiring

Posted on Aug 19, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 2,028 Answers

I would say that the module they are refering to is the module that allows even distribution of fluid pressure to all the brakes evenly. The exact name of the module escapes me at this moment, but that is what I would recommend in order to fix this problem. As for the pump, this the master cylinder. It also has a check valve that could be a factor in the uneven pressure at higher speeds, but I would start with the distribution module.

Posted on Aug 19, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Chevy S-10 ABS light on at 70 mph every time


the speed sensors in the wheel hub control the abs each wheel bearing/hub has a speed sensor you need a good scan tool to pin piont the bad one or ones with gm you have to replace the whole hub/bearing to replace the sensor.

Dec 02, 2012 | 2000 Chevrolet S-10

1 Answer

Abs light on everytime i stop it dies what would cause that on a 95 blazer


The abs light problem is more than likely a faulty speed sensor as for engine cutting off sounds like a low fuel pressure problem.Check the fuel pressure it should be 60-66 psi with the key on engine off.Also check the fuel pressure regulator for proper operation these regulators are known for causing this problem.

Apr 23, 2012 | 1995 Chevrolet Blazer

1 Answer

Abs light comes on when driving above 60 mph but brakes work fine in my volvo v40


Brakes always work but ABS may be not functioning.
This is probably to be repaired by experienced repair shop.
Brakes are too serious to make experiments by yourself.

Apr 19, 2012 | Volvo V40 Cars & Trucks

2 Answers

My 1997 Chevy Blazer ABS light comes on and then shuts off but does it regularly. Also it makes a noise on the front brakes when using them. What could be the problem?


One of the wheel speed sensors is going bad probably. If the brake is shuddering when pressed like when the ABS kicks in then the sensor is bad.

Jun 13, 2010 | 1997 Chevrolet Blazer

2 Answers

60% of the time when applying the brakes the abs system kicks in and makes the weird noise and hinders braking


A shop will need to check the wheel speed sensors, maybe one is reading "0" and the ABS thinks the wheel is locking up, when its not.

Oct 21, 2009 | 2002 Oldsmobile Silhouette

2 Answers

ABS under 10 mph goes off...feels like we won't stop!


Like the other person mentioned, if you have a faulty sensor or bad connection, that would trigger the light. That may also be triggering your ABS to kick in when it doesn't need to. On each wheel, there will be a sensor with some wires coming out of it located on the inside of the axle just behind the rotor. You'd have to test each sensor to determine if one or all of them are faulty.

Sep 25, 2009 | 2002 Chevrolet TrailBlazer

1 Answer

Anti lock brakes activation


if abs activates when it should not,,, it means abs module senses one or more wheel sensores under 3 mph and the other sensores are above 3 mph. .the cause of this is usualy a bad wheel speed sensor or excessive air gap between the sensor and ringwheel. you need an abs data scanner to hook up and go for a test drive to find out which sensor is the culprit.

Jan 29, 2009 | 1991 Chevrolet Corvette

1 Answer

ABS brake system comes on everytime I stop - no codes set


Test your wheel speed sensors. You can do it with a DVOM or a hand held lab scope. With a DVOM you want 2.8VAC while spinning the wheel and with a lab scope you want a good sine wave pattern.

Dec 27, 2008 | 1998 Chevrolet Blazer

1 Answer

Brakes go out at speeds over 60 mph


Glen; you have a bad wheel bearing is what it sounds like to me so here's what you do.Jack the front of the rig up grab a wheel fromthe top and bottom and try to wiggle it.if it does not move try the other one buy the sounds of it you should find some movement in one of them.If not got too a garage and just have them scan the ABS system and that should tell you which sensor is not working and that wheel should be the bad bearing since the ABS sensor is built right into the bearing.s10's are known for bearings going bad.

Aug 19, 2008 | 1993 Chevrolet S-10 Blazer

5 Answers

My abs light and trac off light are both on


Def the wheel bearings/hub/speed sensor. I just bought a new wheel bearing comes with the hub and speed sensor as one. Runs about 80-100 dollars though but abs/traction light went off and stays off now.

Jul 24, 2008 | 1999 Pontiac Grand Am GT

Not finding what you are looking for?
1993 Chevrolet S-10 Blazer Logo

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

61168 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...