Question about 2005 Mercedes-Benz E-Class

1 Answer

I have a2005 e270cdi and it will not start when cold the glow plug light doesn't come on and the fan kicks in.After approx 10 minutes of trying it starts.The Merc garage say the computer needs replacing,has anybody had this problem or can help thanks.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 206 Answers

Symtoms suggest a faulty glow plug control module. Not too expensive and easily changed.

Posted on May 29, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i start the car the autochoke doesn't come on but the fan does


Check the fuse box and relay box for signs of water ingress. Clean and retry.

Nov 14, 2012 | Cars & Trucks

1 Answer

Model 106.74052400 is not cold don't sound like


Are you talking about the interior fan unit?
If so, with it turned on try giving it a light tap with something hard.
If it turns on, then the fan motor is worn and requires replacement.
If it doesn't kick in, then check the power to the fan.
If you don't have power, then check the blower control switch.

Nov 02, 2012 | Cars & Trucks

1 Answer

Lincoln ls car is still running hot after changing thermostat


First when car is running hot stop and pop the hood check and see if the electric cooling fans are running. Second have your radiator cap checked, replace if bad. If neither or these are the issue, with the engine cold start it up and remove the radiator cap. It will take a couple minutes for the engine to warm up enough to open the thermostat. After it gets warm enough that your thermostat opens, (5 to 10 minutes) you should see the fluid in the radiator start to circulate. If this doesn't happen your water pump is out and needs to be replaced. Back to the first thing if your fans aren't kicking on check all your fuses in your engine compartment first. If you narrow down the problem to one of these and need more assistance, just reply to this comment and I will help you further.

May 25, 2011 | 2001 Lincoln LS

1 Answer

Car wont start when engine is cool


sounds like a glow plug problem,if it starts o.k. when warm,but not when cold,does it smoke a lot when trying to start it cold,if so i would say your glow plugs are either burned out or theres no power to them when you turn on the key,do you see the glow plug light on the dash,it may light,but that doesn,t mean the glow plugs are getting power

Apr 16, 2010 | 2000 Toyota Land Cruiser

1 Answer

Ford escort 55 van van starts after 3 or 4 atemps once warmed up starts 1st time?


You havent said which engine you have got so I presume it is the 1.8 diesel. Therefore, when you go to start it when it is cold, wait for the glow plug light to go off then wait approx another 15 seconds as the glow plugs continue to heat up after the light goes off before you try to start it.

Apr 22, 2009 | 1997 Ford Escort

2 Answers

Diesel engine keeps stalling


Hi!
Looking at the brief description of your problem it may be your heater plug timer? when you start the vehicle from cold the glow plugs have to heat up. These are little pencil type plugs that are mounted in the cylinder head they are timed and glow rather like the bar of an electric fire so the hot spots in each cylinder warm and give precise combustion. If the timer/relay gives only a short burst of power your car will start as normal but if the cylinders are still cold/cool when it shuts off the Vapourised Diesel doesn't ignite correctly so rev's drop and if you can't raise them will stall. When you turn off the ignition and back on again the timer/relay kicks in glow plugs glow and bingo your'e off again. I presume after the first stall everything is back to normal? if not how far up the road is it before engine dies? also how long after starting does it stall?
I hope you don't mind the Epic, Oh! if your 306 continues try starting the car and waiting a while listen for a click like a switch or if the interior light is on when it brightens after a few seconds turn off the ignition then back on and start then see how far you go!
Good Luck!
Paul 'W'
Onyer~EDson(:0)~[><

Jan 06, 2009 | 1995 Geo Metro

1 Answer

Vauxhall vivaro wont start cold


Sounds like a faulty cold start assistor. On top of the engine you will find an aluminium housing with four things that look like glow plugs screwed into it. These 'glow plugs' are only available complete with the housing fron Vauxhall. Approx £70 +
Airbag light is probably a fault with the seatbelt pretensioner.
Check the wiring under the seats for damage or perhaps the plugs have pulled apart.

Oct 30, 2008 | 2002 Volkswagen Eurovan

Not finding what you are looking for?
2005 Mercedes-Benz E-Class Logo

194 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

yadayada
yadayada

Level 3 Expert

75744 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...