Question about 2000 Dodge Avenger

1 Answer

The car starts fine. but when idling the RPM's fluxuate and it struggles. The RPM's also fluxuate at running speeds. When I hit the accelerator the engine chokes, problem varies on severity day to day but continues to get worse. The cerpentine belt does need to be tightened but doubtful thats the issue (im no expert though). Sometimes the problem is so bad the check engine light flashes. Car has never died on me or failed to start.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 19 Answers

Tighten your alternator. Then almost a hinder percent sure you r having fuel filter problems.

Posted on May 29, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

2003 Kia Sedona what is the RPM supposed to idle aton cold start an in warm weather


Idle speed depends on a number of factors; for instance it may idle faster when the air conditioner is on. Instead of a fixed idle speed, as in the old cars, the engine computer sets the speed to whatever is needed to run any accessories and maintain smooth operation, but generally not more than that. That's under normal circumstances. There are several failure modes that cause erratic idle speed; usually the engine will also run roughly.

Jul 09, 2017 | Kia Cars & Trucks

1 Answer

Poor idling


Coils,fuel filter,dirty throttle body.

May 11, 2013 | Cars & Trucks

1 Answer

Car idling to high


there is a idle speed control motor the motor sticks tap on it with a small hammer while running and see if the rpm's drop tap not hit

Sep 13, 2012 | Ford Mustang Cars & Trucks

1 Answer

My 05 chevy malibu is not excelerating or shifting properly...


I would test both the tps and map sensors.
map sensor is here:

0996b43f802030b8-etlvqcyxjdbbokifzikh1c5u-5-0.gif

Testing

Check the Manifold Absolute Pressure (MAP) sensor circuit as follows:
Ignition OFF, disconnect the MAP harness connector at the MAP sensor.Ignition OFF, test for less than 5 ohms of resistance between the low reference circuit terminal 2 and ground.If greater than the specified range, test the low reference circuit for an open/high resistance. If the circuit tests normal, replace the ECM.Ignition ON, test for 4.8-5.2 volts between the 5-volt reference circuit terminal 1 and ground.If less than the specified range, test the 5-volt reference circuit for a short to ground or an open/high resistance. If the circuit tests normal, replace the ECM.If greater than the specified range, test the 5-volt reference circuit for a short to voltage. If the circuit tests normal, replace the ECM.Verify the scan tool MAP Sensor parameter is less than 1 kPa.If greater than the specified range, test the signal circuit terminal 3 for a short to voltage. If the circuit tests normal, replace the ECM.Install a 3A fused jumper wire between the signal circuit terminal 3 and the 5-volt reference circuit terminal 1. Verify the scan tool MAP Sensor parameter is greater than 126 kPa.If less than the specified range, test the signal circuit terminal 3 for a short to ground or an open/high resistance. If the circuit tests normal, replace the ECM.If all circuits test normal, test or replace the MAP sensor.

0996b43f802030bb-etlvqcyxjdbbokifzikh1c5u-5-2.gif


Check the Throttle Position (TP) sensor circuits as follows:
Ignition OFF, disconnect the harness connector at the throttle body.Ignition OFF for 90 seconds, test for less than 5 ohms of resistance between the low reference circuit terminal C and ground.If greater than 5 ohms, test the low reference circuit for an open/high resistance. If the circuit tests normal, replace the ECM. Ignition ON, test for 4.8-5.2 volts between 5-volt reference circuit terminal E and ground.If less than 4.8 volts, test 5-volt reference circuit for a short to ground or an open / high resistance. If the circuit tests normal, replace the ECM.If greater than 5.2 volts, test the 5-volt reference circuit for a short to voltage. If the circuit tests normal, replace the ECM. Verify the scan tool TP sensor 1 voltage is less than 0.1 volt.If greater than 0.1 volt, test the signal circuit terminal D for a short to voltage. If the circuit tests normal, replace the ECM. Verify the scan tool TP sensor 2 voltage is greater than 4.8 volts.If less than 4.8 volts, test the signal circuit for a short to ground. If the circuit tests normal, replace the ECM. Install a 3A fused jumper wire between the signal circuit terminal D and the 5-volt reference circuit terminal E of the TP sensor 1. Verify the TP sensor 1 voltage is greater than 4.8 volts.If less than 4.8 volts, test the TP sensor 1 signal circuit for a short to ground or an open/high resistance. If the circuit tests normal, replace the ECM. Install a 3A fused jumper wire between the signal circuit terminal F and the low reference circuit terminal C of the TP sensor 2. Verify that the TP sensor 2 voltage is less than 0.1 voltIf greater than 1.0 volt, test the TP sensor 2 signal circuit for a short to voltage or an open/high resistance. If the circuit tests normal, replace the ECM. Ignition OFF for 90 seconds, disconnect the harness connector at the ECM.Test for less than 5 ohms of resistance on all TP sensor circuits between the following terminals:ECM C2 signal circuit terminal 65 to TP terminal DECM C2 signal circuit terminal 63 to TP terminal FECM C2 5-volt reference circuit terminal 3 to terminal E If greater than 5 ohms, repair the affected circuit for open/high resistance.Test for infinite resistance between TP sensor 1 signal circuit terminal D and TP sensor signal circuit terminal F.If less than infinite resistance, repair the short between TP sensor 1 signal circuit and TP sensor 2 signal circuit. If all circuits test normal, replace the throttle body.

0996b43f802030be-etlvqcyxjdbbokifzikh1c5u-5-5.gif
Fig. Throttle Actuator Control electrical connector


Throttle Body Relearn Procedure
NOTE
Do NOT perform this procedure if DTCs are set.

Start and idle the engine in PARK for 3 minutes.With a scan tool, monitor desired and actual RPM.The ECM will start to learn the new idle cells and Desired RPM should start to decrease.Ignition OFF for 60 seconds.Start and idle the engine in PARK for 3 minutes.After the 3 minute run time the engine should be idling normal.
NOTE
During the drive cycle the check engine light may come on with idle speed DTCs. If idle speed codes are set, clear codes so the ECM can continue to learn.

If the engine idle speed has not been learned the vehicle will need to be driven at speeds above 70 km/h (44 mph) with several decelerations and extended idles.
After the drive cycle, the engine should be idling normally.

If the engine idle speed has not been learned, turn OFF the ignition for 60 seconds and repeat step 6.Once the engine speed has returned to normal, clear DTCs.

Jul 29, 2017 | 2005 Chevrolet Malibu

1 Answer

I have a 1992 Honda prelude that when it starts up it idles at 1100rpms fine but after it runs for like five minutes it drops idle to 900rpms and as soon as I hit the gas it stalls out..... It starts right...


on a cold start car will idle fast till it warms up then will drop to about 1000 rpm, try increacing idle speed so when it warms and drops it should stay idleing

Feb 12, 2012 | 1992 Honda Prelude

1 Answer

My 95 nissan is bucking and having acceleration loss. And shes so stubborn that she can't maintain the same speed. Also when she idles she fluxuates from half an rpm to 1 rpm. Does anyone know where to...


it is most likely the throttle position sensor. it could be mass airflow sensor. are there any codes? best bet get it scoped and see which sensors out of range.

Feb 12, 2011 | 1995 Nissan Pathfinder

1 Answer

1996 ford bronco 5.8 litre, auto, engine idle has


Do you have a check engine light on? First thing I would do is unplug the IAC motor when the engine is warm. If the idle speed doesn't change you have a vacuum leak or a bad IAC motor. If the idle speed goes down you might have a bad TPS or IAC

May 31, 2010 | 1996 Ford Bronco

2 Answers

Engine vibration at idle, goes away after a little acceleration, mostly when the engine is still cold..


Check the rpm gauge while running. If the RPM needle fluxuates while idling that is caused by a defective spark plug and or a spark plug wire

Apr 08, 2010 | 2004 Ford Freestar

1 Answer

Extremely high idle speeds develped overnight


check idle speed control make your throttle valves not stuck.check for vacuum leak around the throttle body area look for broke gasket.

Apr 13, 2009 | 1987 Ford Ranger

Not finding what you are looking for?
2000 Dodge Avenger Logo

197 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75797 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22114 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8152 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...