Question about 1994 Oldsmobile Cutlass Ciera

1 Answer

Replaced fuel pump - filter- and mass air flow sensor still leaves me stranded turns over wouldnt start but does not seem to be getting gas because it does not smell

Posted by on

  • steve fenwick May 28, 2011

    do you have any spark at the plugs? If you have no spark your ignition control module or spark control is probably bad and needs to be replaced..this is the same part sometimes they use different names for it, this part is what controls you sprak to your plugs,they tend to go out after 8-10 years..they are affected by the heat under the hood of the car..they are pretty easy to replace if you can use a screwdriver you can replace this part. This part is located under your spark coil packs,if you follow your spark plug wire from the spark plug backwards to the coil pack. the coil packs sit on top of the control module, the only hard part of changing this part is to make sure you use the proper size wrench or tool, alot of times these are held in place by torx screws or very small nut head bolts. just make sure you get the right size tool..make sure you mark the coil packs with a piece of masking tape and number them so that you put them back in the same order that you took them off.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 328 Answers

Have you tried to open the air drum revealing the carburetter then bring a sprayer filled with gasoline and get someone to turn key on while you spry over the carburetter and air manifold it will starts the go to the carburetter have it fixed or adjusted

Posted on May 28, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My 2003 Astro van has been running fine the I got gasmonday night and as I pulled out the gas station it spit and sputtered like I got bad gas or trash in filter, then it started working fine.


Mass air flow sensor maybe drity or going bad . Ever had it replaced ? Have you replaced the air filter lately ? Video's on youtube showing how to clean mass air flow sensor , you would have to buy a can of mass air flow sensor cleaner . Also while your at it clean the throttle plate , again there are videos on youtube . How did you check fuel pump ? To do it right you would need to hook up a pressure gauge . Also check flow .Videos on youtube .Has the check engine light come on ? Also you mite try some fuel injector cleaner and or dry gas for moisture in the fuel !

Mar 15, 2017 | Cars & Trucks

3 Answers

2003 Nissan Altima 2.5L Service Engine Soon Light is on, Auto Zone says codes are for MAF and O2 Sensors. Car hard to start after driving a while but when starts appears to run smooth. Auto Zone thi


ok lets start with the codes they say your getting. P??? which 1's and how many. there are few o2 sensors, are they next to the Exhaust next to the converter? MASS AIR FLOW -MAF use this, for now i am guessing, until i see the correct codes your are getting. this could be the 1 you may have below, please read it........
  • P0103
    Mass Air Flow Sensor Circuit High Input
  • Possible causes
  • Faulty mass air flow sensor
    - Intake air leaks
    - Dirty mass air flow sensor
    - Dirty mass air filter
    - Mass air flow sensor harness is open or shorted
    - Mass air flow sensor circuit poor electrical connection
  • Before replacing the mass air flow sensor, try replacing the air filter and cleaning the air flow sensor with low compress air or mass air flow sensor cleaner. Reset code and drive vehicle. If the code comes back, it may be necessary to replaced the mass air flow sensor.
  • possible symptoms Engine Light ON (or Service Engine Soon Warning Light)
    - Engine stall
    - Engine running rough
    - Excessive fuel consumption
    - Excessive smoke
  • the code is generated when An excessively high voltage from the sensor is sent to Engine Control Module (ECM).
2003 NISSAN Altima Sedan OBDII Codes List

Oct 22, 2014 | 2003 Nissan Altima

2 Answers

87 Buick century 3.8l I replaced almost everything under the Hood plus fuel pump.filter runs great. Then starts missing like its running out of gas. But keep pumping the gas and it starts backfiring...


Is the check engine light on ?
If you really have replaced everything in the ignition and fuel system, that would leave the computer and the wiring harness.

Aug 30, 2012 | Cars & Trucks

1 Answer

Wont start unless I spray starting fluid into air cleaner. run great after that but if you turn it off you have to use starting fluid again . have put new wires plugs rotor cap distb. capand K&N...


A poor spray pattern in the injectors can cause starting issues. Have you tried a good (read not really cheap) fuel injector cleaner like Chevron Techron or Valvoline Synpower fuel system cleaner? A weak ignition system (worn spark plugs, leaking wires) can cause starting issues. You mentioned that it has a K&N filter on it. These filters use an oil in a cotton media to filter out dirt. Sometimes that oil can get out of the filter and contaminate the mass air-flow sensor. Follow the air tube after the filter box and you'll find a sensor in the tube with several wires running from it. It is made from aluminum and the wire housing is plastic. Remove it from the tube and clean it with a mass air-flow sensor cleaner. You HAVE to use a mass air-flow sensor cleaner specifically made for mass air sensors. Don't use anything else like carb, brake, or throttle body cleaner. Those cleaners will leave a residue on the sensor and just cause you more issues.

As for your fuel pressure, the system pressure with the key on, engine off is 60-66 psi. Do you really think you could visually tell the difference between 60 psi and 40 psi? I know I couldn't. You'll have to use a fuel pressure gauge to verify the pressure. For my money, I think your pressure is low. But, cleaning the MAF is much easier then putting a tester in, and it wouldn't hurt, so I would do that first.

Dec 07, 2011 | 1999 Chevrolet Tahoe

1 Answer

After my car stalling and then starting and not staying running longer than a minute we replaced the fule filter, fuel pump, and fuel pump strainer. Now it runs and drives, but it idles high around 1.5 to...


Remove the mass air flow,and clean it with intake cleaner spray,or mass air flow cleaner spray,if this does not help,reset the system again,by removing the negative battery cable for at least 20 seconds,then put it back on,if this does not help,replace the mass air flow sensor

Oct 25, 2011 | 1995 Ford Windstar

1 Answer

2002 SILVEROADO 5.3. I was drivig down the road, started acting like it was running out of gas than stalled. No whrilling fuel pump sound, I checked all relays and they were ok, New fuel pump did not fix,...


The fuel filter wont keep the pump from working but it can restrict the flow of fuel. Just to see where your pump is at smack the tank hard one time. If the pump is malfunctioning it will most likely turn back on.

Apr 06, 2011 | 2002 Chevrolet Silverado

2 Answers

I have a 1995 Chevrolet S10 that seems to be missing on take off but once you get going it quits and runs fine until you come to a stop again and then on take off it starts missing again and then levels...


Change the fuel pump. Check first fuel presure.
fuel regulator. PVC valve stuck????
Check the vacum hoses and EGR.
Clean MAF mass air flow sensor.
check the IAC idle air control resistor.
Vitally

Jun 02, 2009 | 1995 Chevrolet S-10 CA Edition

Not finding what you are looking for?
1994 Oldsmobile Cutlass Ciera Logo

59 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76164 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8273 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...