Question about 2003 Chevrolet TrailBlazer

1 Answer

I have replaced my electronic clutch fan three times in four months. my engine runs fine for about a month then acts up. it sounds as if my tranny is going out and very excessive fuel consumption occurs. this is getting to be quite a problem so please help. tyvm

Posted by on

  • bob c May 27, 2011

    Is the fan frozen in place when you replace it or does it just not come on when power is applied?

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Chevrolet Master
  • 1,131 Answers

Tranny? So the electric fan is running constantly, is this what you mean? Sounds like a jet taking off as you press the gas more and more?

Posted on May 27, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Intermitente starting problems & transmission seemed to go out the other day while driving it


sounds more like an engine issue off the top of my head. The transmission runs off the vacuum from the engine. If the engine timing chain is stretched it will run then not run, have problems idling and shifting and won't charge the battery properly. anyone who has done one before could probably tell you just by the sound of the engine running.

Feb 26, 2014 | 1998 GMC Jimmy

1 Answer

Radiator fans always on.


do mobile power onpassword {4-8}

Dec 24, 2013 | 2006 Mazda MPV

1 Answer

2006 F150 5.4, 4x4, Lariat. Intermittent excessive humming/fan noise from engine compartment


Sounds like the fan clutch bearing is locked up. Running in direct drive will affect MPG drastically. Its a 2006 so its time to replace it. See if the fan blade will spin by hand with the engine off or if excessive wobble is present at the bearing.

Jun 02, 2017 | 2006 Ford F-150 SuperCrew

1 Answer

1997 Mercury Sable will not shift into overdrive


Might need a good tranny flush my wife hauls us mail we tried a sable and tranny went in three months but with no center console there nice

Nov 28, 2012 | Cars & Trucks

1 Answer

Error code p1271 on trailblazer


That trouble code is faulting the accelerator pedal sensor. The APP sensors are located in a TAC module mounted to the accelerator pedal bracket. There are three individual APP sensors within the TAC module. Three separate signal circuits, low reference circuits, and 5v reference circuits are used to determine the accelerator pedal position. The APP sensor signal voltages increase when the accelerator pedal is depressed.

Nov 26, 2011 | 2003 Chevrolet TrailBlazer

1 Answer

1995 Mercury Grand Marquis electronic Dash goes blank


Possibly bad wiring with the tow package added on. Almost like it was not installed properly or that the lines where crossed or it was setup to a wrong fuse and it is popping eveything and making this happen

Feb 19, 2009 | 1995 Mercury Grand Marquis

1 Answer

Transmission


I have same problem with a 95 4runner 4wd 3VZE engine and A340 H tranny. I had previously had a real bad problem with all gears "neutralizing" where car would rev up but not move forward or rear in any gear. I spent $ 1,500.00 for transmission and transfer case rebuild, and problem not solved. After months of research, I found out there is a "valve body" which is a an electronic plate inside the transmission drain pan right above the transmission filter. These valve bodies have solenoids which act as mini pumps inside transmission. I ordered a kit through a San Antonio, TX independent distributor (# 1 solenoid, # 2 solenoid, and a so called "lock up solenoid". Kit comes with full details how to replace those three sensors. I did job myself one afternoon..no problem. 4runner works like new now except for the reverse which acts as you mention. There is a fourth solenoid in the transfer case (not transmission) whcih was not part of the "kit" I bought. Although I'm not sure it is the cause, after replacing the other solenoids, the fix was dramatic on the forward gears. I'm currently researching if solenoid # 4 may be the cause of the reverse gear still not working fine.

Aug 08, 2008 | 1995 Toyota 4Runner

Not finding what you are looking for?
2003 Chevrolet TrailBlazer Logo

112 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...