Question about 2000 Dodge Durango

1 Answer

When i start my truck the engine revs up and when im driving it sounds really loud and seems not to get up enough pressure to go, but the rpm register at 3or higher when driving.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,140 Answers

Fan clutch
transmission not shifting right

Posted on May 28, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does it feel as though I'm riding the brake?


Sounds like transmission prob. Loud sound cause its downshiftd makn motor rev. Some components getn hot in the electrics then cooling down. A scan wil show the worn part. Try not to driveit. And dont go to a dealer

Jun 14, 2015 | 1997 Dodge Caravan

1 Answer

Battery barely starting car, engine only rev to 2500 rpm


Loose or corroded battery cables, Loose fan belt not turning alternator fast enough, Bad alternator, check the battery with a Voltmeter, voltage with engine stopped. should be slightly over 12V Start engine and check again.. shoiuld be over 14V. this is if the alternator is putting out a charge. Chech the output at the alternator. the BATT connection. usually a larger red wire. should be 14V+ with engine running. Since the A/C works fine with the engine running.. I would have the battery checked.. sounds like bad battery.

Jun 02, 2014 | 2008 Kia Optima

1 Answer

2006 Suzuki forenza. sometimes it takes a long time turning engine over to start. when it does start, the tach revs up to 4 and won't slow down. when you shift the car into gear, it shuts off. when it is...


bad idle, and surges.
gets better, does that mean it idles at the correct regulated RPM
HOT? 800.?
and does the engine coolant hit 180 to 200 F and hold there.?
Sounds like the ISC valve is stuck open, clean it.
ISC means, idle speed controls.
also air leaks, vacuum leaks can do this on speed density, EFI.
Im not sure which EFI you have, too lazy to look that up.

which engine do you have, and what country, ?
as a mech, i open hood and look, on the net , i cant do that.
so.... no real help

Sep 11, 2013 | 2006 Suzuki Forenza

1 Answer

What can cause the engine on my 1999 Oldsmobile 88 LS 3.8L (3800 series 2) to make a loud air sucking sound in my intake manifold


With the engine running open the hood and look/listen for a vacuum leak. One of the larger vacuum hoses has likely come off.

Jul 25, 2013 | Cars & Trucks

1 Answer

My 2003 suburban seems to run at a higher rpm.


Hummm, 2000 rpm does not seem high, really. But another item to look at is your FAN. The clutch fan fails and drives the fan full engauge. Sounds like a jeep...massive sounding, relating to engine RPM, but not necessarily different.

I mentiont his because a trans does not typically fail and give a few hundred RPM. Usually a slipping sensation is described....

Jul 12, 2010 | 2003 Chevrolet Suburban 1500

1 Answer

I have an 198 k5 blazer wth a 350 small block . it shows no oil pressure at idle but when i drive it or rev it up the oil pressure goes to 35-40 lbs of pressure . the engine sounds great no knocking or...


Sounds to me like your oil pump is bad, not pumping sufficient oil at low RPM's. If the gauge shows pressure when driving or revved, the sending unit is working

Apr 02, 2010 | 1991 Chevrolet S-10 Blazer

1 Answer

Power steering pump issues


The oil is aerated, and hiig rpms while moving air jus mixes or aerates it further. Let sit fo 24 hors with **** cap loos. When ready to drive, don;t rev the engin. normal driving will cause oil to flow with aerating and as the oil heats up the air will be forced to seperate.The is nothing wrong unless your tank assembly was more than needed. it will clear . not to worry.

Mar 21, 2009 | 1997 GMC Sierra K2500

1 Answer

1998 Jaguar XJ8 won't rev over 3000 rpm


have u ever replaced the fuel filter? sounds like low fuel pressure.

Feb 20, 2009 | 1998 Jaguar XJ8L

1 Answer

1990 gmc k2500 new 5.7engine & turbo 400 ,power lose & noise.


sounds as if you may be looking in the wrong spot. If different gearing is drastically changing the symptoms you may want to check the trans. or torque converter. sudden pop with engine rpm increase and lack of power sounds like possible band breakage in transmission or impellor breakage in torque converter.

Oct 20, 2008 | 1990 GMC K2500

Not finding what you are looking for?
2000 Dodge Durango Logo

114 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dodge Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8180 Answers

Are you a Dodge Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...