Question about Mercedes-Benz SL-Class

2 Answers

Hi and good day my mercedes sl 500 1993 \m119960 wont start i have good battery strong starter .i have spark and the fule supply O.K i tastd the fule pumps the give 4.5 litr \min ---and rise to 8 bar out of the car . when they inside they give 4 bar trow the regulator'--i change follwing :camshft sensor' and crank sensor .fule distributor, 2 ignition coil .plags .mas air module ,'lamda sen' i have cleen the injectior wite spray carb its the injectior without coil-----i did'nt replace the ezl \the car seem to flood .can the coolent sensor influence?the injectior looks o.k i didn't notice leak and the spray fine '

Posted by on

  • 6 more comments 
  • drorb May 26, 2011

    ?? i have sl -500 -m119960 V-8 after the rotor ther is oil seal----the ignition coil are out side \i have clean the rotor and the cap ----maybe ididn'T understand?

  • drorb May 26, 2011

    i look for the distrbutor coil --and i didn't find any on oll the issue that i look for /the car wont start it's seems like flood when i take the mas air module out it's start for sec and die (mercedes sl -500 -1993 m119960 (1990-1992)the same motor

  • drorb May 26, 2011

    i do replace it !

  • drorb May 26, 2011

    i can start the car with spray carburtor \and its ran fine but when i stop spray it's die----it's seem like ther isn"t enough fuel --------but there is it's flood and i notice fuel marks on the oil engine(i know that risky to run it like this) ----------maby the spark weak and with spray \increase the spark?-----------



    i even start it once but only wite throttle drop to the floor on high rpm when i release it die . but it work fine and respond good on high rpm /

  • drorb May 29, 2011

    nothing halp \can the ezl have symptoms like this ? spark week ?only start wite spray carburtor 'i am desperate!

  • drorb May 30, 2011

    m119 960 --this engine dont have electronik injector !

  • drorb May 30, 2011

    ? egr?

  • drorb May 31, 2011

    well your intention -cold start injector valve\i know and test it it's spray in start for 2/3 sec

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,702 Answers

Have you checked compression? you need to check the valve timing sounds like you might have jumped time. the coolant temp. sensor might give some starting problems although it would be rare but if worried about the sensor un plug it and jump the plug in this will force a high temp. reading and turn off the cold start circuit. but i think i would forget about the electronics and start checking the mechanical components. i think your problem is a little deeper then just the fuel system.

check these things out and get back with me and i will try to help you get to the bottom of this problem.

Posted on May 26, 2011

  • 4 more comments 
  • john nail
    john nail May 26, 2011

    could still be slow valve timing, did you try to jump the coolent temp. sensor?also try this turn the key on but do not crank the engine then push the throttle all the way to the floor then crank the engine and see if it starts if it does keep it running untill the engine clears up then bring the engine up to around 2000 rpm intill the engine is up to temp. then shut it off let it cool and try to restart it, by doing this it will put the on-board computer system into clear flood mode. if this clears the flood and the engine starts then you need to check the fuel pressure regulator for a leak into the vacuum line and also test the fuel to make sure it is not contamated.

  • john nail
    john nail May 29, 2011

    if it starts on carb cleaner then the spark is ok, have you checked for injection pulse? unplug a fuel injector and install a 12 volt light between the harnss conectors and crank the engine the test light should flash.....check this and let me know what you find

  • john nail
    john nail May 30, 2011

    sorry i looked up a 500E insted of a 500SL have you checked the starting valve to see if it is stuck open?

  • john nail
    john nail May 30, 2011

    you do not know what a cold start valve is? this could be a problem how will verced are you on how this system workes? one wrong thing turned or bent in the air flow box and your done. i will send a picture of were and what the cold start valve looks like and were it is, when you crank the engine there is an electric injector on the intake that sprays fuel into the engine so it can start the air flow meter has to have air flow before it will allow fuel to the injectors so if the cold start valve is not working then you will never get the crank up fuel to get the sysyem working

  • john nail
    john nail May 30, 2011

    here are the location of the start up injector









  • john nail
    john nail May 31, 2011

    if you have fuel pressure and spark and you are sure the injectors are working, then there must be something wrong with the engine its self i think it is time to give up and take it to a shop, there are so many things that might be wrong that you could spend a fortune trying to guess at it,......there is no shame in admitting when you need help....good luck

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,386 Answers

Hello and welcome to FixYa!

Even though you have spark, I suspect that it's too weak to burn fuel that's why it floods. I strongly suggest that you replace the distributor coil. To access the distributor coil, you will need to remove the distributor cap and rotor.

Once you remove them, you can gain access to the distributor coil. Take note, it's gonna be messy for oil on the coil can be expected. Once you replaced the distributor coil you'll surely have good current supply to the plugs. This will surely eliminate the fuel flooding issue.

Hope this helps and thank you for using FixYa! Have a good one!

Posted on May 25, 2011

  • afarri
    afarri May 26, 2011

    Yes indeed, after the distributor rotor there you will find the distributor coil.

  • afarri
    afarri May 26, 2011

    Have you considered replacing the filter? The fuel filter may be worn out which can cause a free fuel flow, which can result to fuel flooding. It's kinda odd but still it's possible.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

2002 yukon denali xl wont start


Does the starter crank the engine over? If so, check for spark on a spark plug wire when cranking. If you have a strong blue spark, ignition is probably good. Check fuel pressure. Do you hear the fuel pump turn on for 2 seconds when turning key to on?

Dec 15, 2013 | Cars & Trucks

2 Answers

Van will not start. Battery is strong. Starter is turning over, but suddenly - and without warning - the van will not start.


  • check fuel supply(pump)..if no fuel....
check fuel pump relays and fuel pump
  • check ignition (or spark)at the plugs..no spark check plugs/damaged plug leads/faulty coil pack

Jun 29, 2011 | Chevrolet Venture Cars & Trucks

2 Answers

I replaced the starter and it still wont start


Make sure the battery is in new condition, charged up, and the terminals are clean and shiny when removed from the battery.

Sep 02, 2010 | 1991 Dodge Dakota

1 Answer

Engine turns over strong but wont start.....sprayed starter fluid inside air intake and it started,,,so i know spark is good...runs great when it is running just wont start...no fuel supply obviously but...


one answer is lack of compression in the cylinders,normally associated with high miles.
could also be valve seats/spark plug gap/dirty air filter,there are a few more but start with the cheapest to diagnose and work up.....

Apr 26, 2010 | 1999 Isuzu Rodeo

1 Answer

My 1994 chevy s 10 blazer starts only in morning or after sitting for a long time(1 or 2 days) has new fule pump fule fliter fule presser is great have strong spark new plugs and wire relay is good motor...


I would definately check around the intake gaskets with any spray lubricant or cleaner.Do this while the engine is running. If it starts to stumble then concentrate the spray until you pinpoint the area of fault. This is all I have to offer without being there. Good luck,Dana

Aug 23, 2009 | 1994 Chevrolet S-10 Blazer

1 Answer

500 sl wont start


Near the battery. However if you are saying no sparks then check the induction coil which generate these sparks..........sodeep

Jun 23, 2009 | 1987 Mercedes-Benz Mercedes Benz 500 Class

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

227 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercedes-Benz Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22095 Answers

yadayada
yadayada

Level 3 Expert

75066 Answers

Michael Contreras
Michael Contreras

Level 2 Expert

166 Answers

Are you a Mercedes-Benz Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...