Question about Kia Spectra

1 Answer

Blower motor will shut off at any time. Some times it works ,some time it doesnt.Had 2 shops look at it with one fixing it twice already,still not fixed,and trying to tell us it would need a new motor. Car is a 2006-Kia-Spectra.The other shop said it needs freon.Obvisouly they could not figure out the problem. The air is cold and when brought to shop the blower was working so I dont know what it is.

Posted by on

  • 9 more comments 
  • cpenick Aug 23, 2008

    I have the same problem with a 2007 Kia Spectra.



    Carol

  • Anonymous Sep 20, 2008

    This happened to me in a rio. no heat, no a/c, no defrost. It happened intermittently. We paid the dealer over $400 to get a new blower motor. It did it AGAIN! I finally gave up and we don't drive the car when we need defrost, etc.

  • jenty147 Oct 27, 2008

    sometimes air will blow and sometimes it doesn't. The back air blows just fine, but the dash blower will work on and off.

  • bryce_68 Nov 21, 2008

    Same issue hear with 2007 Spectra5. Dealer replaced the blower motor on Monday afternoon, now tonight Thursday the new one just shut off too. Have heat and the selector for defrost/feet/face works, just no fan to blow the heat out. Oh yeah the rear defrost also works fine.

  • joseph_foltz Nov 26, 2008

    I have the same problem, and in addition the last month, the motor began to slow down and eventually stopped (not like it was turned off as before), never to run again... no manual is availible from the parts houses. I dont even know how to get to it.

  • Anonymous Nov 29, 2008

    I have the same thing happening on my 2000 spectra

  • Anonymous Jan 18, 2009

    I have the same problem with my 2002 kia spectra. Upon troubleshooting the wiring I discovered the harness which plugs to the motor was the issue. I am in the process of rewiring the plug just to try to make it a little more robust. I will post the results once I complete the job along with instructions on how to do it.

  • 1Bad54 Feb 08, 2009

    So how do I go about by passing this wiring problem?

    Maybe taking a hot from the battery, fuse it, then run straight to the blower motor?

    That should work, no?

  • Anonymous Mar 09, 2009

    i have a 2004 spectra i just bought 1 week ago. yesterday the a/c blower stopped working. It doesnt blow in heat or defrost either. I do have cold air at the vent while driving just doesnt blow

  • Anonymous May 20, 2009

    There are three possabilities to sole the issue, (1) the blower motor is at fault, (2) the dash controls are at fault, (3) there is a seperate circuit board that operates the high speed for the fan it could be at fault.

  • Clyde Sep 26, 2012

    The problems begins in the passenger side foot compartment. The wires to the blower motor resistor are mounted in such a mannor that the plug in is vulnerable to get kicked by a long legged persons toes.If you look up under the glove box you will find a plugin facing down that will be your resistor. If you wiggle that plugin, you will find that is where you're losing conection if the plugin isn't already damaged beyond repair as mine was melted and alredy too far gone.

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 60 Answers

Its a wiring prob.

Posted on Aug 16, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Heater blower troubleshooting


Blower motor resistor is faulty.

Dec 27, 2011 | 1997 Buick LeSabre

2 Answers

I have a 1979 oldsmobile delta88 for several years.My blower motor stays on and blows at a constant low speed and doesnt blow much on high.I already replaced sll components except for thewhole a/c switch...


REPLACE BLOWER MOTOR RESISTOR. IF YOU GET ONLY ONE CONTROL SPEED.IF YOU HAVE ALREADY REPLACE BLOWER MOTOR RESISTOR.BLOWER MOTOR CONTROL SWITCH BAD. REASON BLOWER STAY ON ALL THE TIME.FAN BLOWER MOTOR RELAY BAD.
.

Aug 25, 2011 | Oldsmobile Delta 88 Cars & Trucks

1 Answer

I have only high speed on my ac/heat switch. have replace acdelco blower motor resistor 2 times already. works for a while and quits. whatelse do I need to check etc?.


If you have replaced the blower motor resistor block twice all ready, i would be replacing the blower motor itself. When the blower motor is drawing too much current it burns out resistors for lower fan speeds in resistor block, but doesnt blow fuse for fan. Also check for leaves and stuff in fan when removing fan.

Jul 18, 2011 | 2006 Isuzu i-280

1 Answer

2004 focus 80,000 miles/6 weeks ago, using ac with blower on high, blower gradually shut off and car produced bad smell. Drove home with ac off, blower off, had car checked and nothing found. Now it's...


The 'whirring' sound from the blower motor could be a dry bearing or damaged armature (part of blower motor that the brushes ride on), or just wore brushes. The smell could be the motor winding wires burning due to blower motor bogging down and overheating. You can replace blower motor with new or salvaged one.

Dec 09, 2010 | Ford Focus Cars & Trucks

1 Answer

Cabin fan is intermitten. It works (blows air) and the it stopps and then it comes back... ?


If you havent fixed it already, the problem 99% of the time is a blower motor resistor, usually found in the passenger foot well by the blower motor, look for large red and black wires going into a connector, usually held in by 2, 8mm screws

Sep 03, 2010 | 1999 Dodge Caravan

1 Answer

2001 Kia sportage blower motor resistor has been replaced twice and now failed for the third time. Blower motor will only work on high speed. How do I trouble shoot root cause. - Blower motor has also been...


hi there i was wonder can anyone help me i have replaced my heater blower resister has been replaced and now has stoped working again what is the problem can someone plz help me. the fan is working fine i ran a ground wire and it works but only on high and will not turn off

Dec 29, 2009 | Kia Sportage LX Cars & Trucks

3 Answers

A/c blower stays on while the car is off and is draining the battery.


Seems like you have an important short circuit. Blower is supposed to be cut off when car is shut down. I have seen blower switches melt, from excessive use of high speed blower, shorting the contacts, and staying on permanently.

Dec 08, 2009 | 2006 Chevrolet Impala

1 Answer

I have a 1990 ford van e-150 and the blower motor for the heater doesnt work. I would like to know if it can be bench tested to make sure that it doesnt work before i buy a new one. Ive already replaced...


YES BLOWER HAS A 2 WIRE CONN GIVE IT 12 VOLT POWER FROM A BATT & A GROUND & IF BLOWER MOTOR IS GOOD IT WILL RUN IF IT DONT RUN BLOWER IS BAD NOT SHORE WITH WAY POWER OR GROUND GO REV. WIRES FROM BATT IF IT DONT WORK FIRST TIME

Sep 27, 2009 | 1990 Ford F150

1 Answer

2003 Navigtor rear AC tnhuping noise ..could be a fan belt?


It sounds like your blower motor wheel is off, or broken. You will need a new wheel at minimum, probably should do motor at the same time since you are already there.

Jun 11, 2009 | 2003 Lincoln Navigator

2 Answers

AC Blower motor died


This is more than likely just the resistor as a bad motor wouldn't start at all,And low refrigerant(Freon) has nothing to do with the blower.

May 28, 2009 | 2001 Kia Spectra

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

1,122 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

yadayada
yadayada

Level 3 Expert

61168 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6812 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...