Question about Kia Sedona

1 Answer

Starts but after of running a while will not restart the more i prime the pump it starts and runs nothing else wrong with it

Posted by on

Ad

1 Answer

There is no priming of anything

If your talking cycling the key to start the
fuel pump,then maybe the fuel pump
is worn & not building pressure, to always
start the car quickly

The TPS Sensor moves a you push the gas
pedal. It may be worn

There is no corrolation to your foot & fuel issues

Those where the carburator days over 25 years ago

Posted on May 23, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Car has been sitting up and will not start now. It seems to not be getting gas and I do not know how to prime a fuel injection system. Any help appreciated.


There is only a few cars fitted with an ancient petrol injection system that needed any priming.

Diesel engines mostly need the injection system priming but petrol injection systems do not.

Lots of cars use a system where the fuel pump runs for a couple of seconds when the ignition is switched on and that is all the time it takes to prime the fuel system. After a couple of seconds the fuel pump switches off and waits to restart when the engine is cranked.

As priming the system takes only a couple of seconds some manufacturers don't bother with the brief priming run of the pump and just have the pump start when cranking.

Could be faulty supply, fuse, pump relay or the pump itself.
If the car is fitted with an immobiliser, perhaps that is the problem.

May 07, 2016 | 1998 Mercury Mystique

1 Answer

Could a solenoid that was initially wired wrong cause a fuel pump to stop priming or, burn the pump up?


You could have fried the motor in the pump.
If you have battery voltage at the pump with the pump relay is engaged, and a good ground, and the pump does not run, chances are the pump is cooked.

Jun 15, 2015 | 1987 Ford Ranger

1 Answer

DAN WEBSTER, expert! I need to know what I am doing wrong with priming a Monitor Lifter Pump 1103.


try priming it again but when it starts let the bleeder open until it starts and runs for a few seconds and close it , sounds like it is getting air bound and is not priming correctly

Nov 30, 2014 | Cars & Trucks

1 Answer

My suburban has to be primed to start


There is a separate circuit and relay that primes the fuel system when you start the vehicle. If you sit in a silent location and turn the key to the ON position (without cranking), you should hear the fuel pump run for about 5-6 seconds. This is to bring the fuel pressure up in order to let the vehicle start. Then the normal pump circuit takes over. Sounds like your priming circuit is not working. I would try the relay first.

Feb 07, 2014 | 1997 GMC Suburban

1 Answer

I have a 1991 ford F150 6 cylinder with dual tanks. I just changed the oil,oil filter,fuel filter,air filter,and master brake cylinder last week and the truck was running good(started every day since)....


Hi :) That is normal. When you first turn on the key the prime relay kicks in for the gas pump then shuts off. Once you start the engine the fuel pump is restarted buildes pressure as the engine needs it. When you shut the key off the pump shuts down.You could check the fuel pump relay which is different then the prime relay or check the spark module on the distributor housing. And the wire that go to all control module have a bad habbit of cracking and turning green with corrosion.

Mar 17, 2011 | Ford F-150 Cars & Trucks

2 Answers

New fuel pump new regulater .fuel pump runs but will not prime up and shut off


sounds like you hooked the hoses up wrong at the pump unit or you have a bad fuel filter...replace the filter first..then check those hoses and clamps.

Feb 07, 2011 | 1995 Ford Explorer

2 Answers

How do you prime the fuel injectors on an isuzu rodeo 1994 I4 2.6l engine? changed fuel pump and all fuses are good but not getting any fuel to system. i turned key on and let the new fuel pump kick on but...


What you need to do is turn the key on and let the fuel pump run. Turn the key off and repeat about 20 times or so. Eventually it will start it just takes some time to get it primed. You can also do that and on the fuel rail there is a re-leaf valve. Crack that open to get the air out until you get a steady fuel stream.

Jan 16, 2011 | Isuzu Rodeo Cars & Trucks

3 Answers

1997 nissan altima will not start


OK...Some cars use a "prime" relay and a "run" relay on the fuel pump. since manually priming it seems to work, I'd check and see if you have a similar system. If so, the prime relay may be bad.

Jul 30, 2009 | 2002 Nissan Altima

4 Answers

Engine wont start without priming with gas first, then runs well


i have the same problem on a 98 jimmy 4.3 4x4.
i replaced the fule pump and have good pressure.
new wiers & coil (good spark) no MIL & no codes.
will only start when primed. it will run & drive all day
with no problems.
but once it has been turned off (warm or cold) i will
have to prime it once again to start it.
i have another engine that was in it before it spun a bearing.
it ran fine so i know all parts are good.
i swaped the mass air flow and throttle body but i still have
to prime it everytime to start it. am i forgetting something?
should i swap out the intake with the injectors?
any help would be sweet. thanks.

Apr 28, 2009 | 2000 Chevrolet Blazer

1 Answer

Starts then quits


Was there fuel pressure before you changed everything? It could also be the pressure regulator sticking or bad. When you crank it over and let off the key you should hear the fuel pump run for a couple seconds and then shut off. If it is doing that then I would be looking to see if you have likes hooked up wrong at the back of the engine or try replacing the pressure regulator.

Dec 23, 2008 | 1994 Chevrolet S-10 Blazer

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kia Experts

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8514 Answers

Are you a Kia Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...