Question about 1993 Chevrolet K1500

1 Answer

Idels ok, and when problem started noted after 5 min driving...now sooner...not till 25mph now at slower speed...it seems to build up to a back fire , cough/sputter...lurches, it bogs down some then surge

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Chevrolet Master
  • 2,620 Answers

Check fuel pressure it should be 9-13 psi with engine running.You will have to remove fuel filter and install a fuel pressure adapter part #TA37650 to be able to check pressure.

Posted on May 22, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Temperture keeps rising when im only driving a few miles goes to 70 in ten mins and then goes to 90 and then goes back down, last night my car felt like it had lost power ,when i drove it this morning it...


Sounds like the thermostat is gone in the cooling system,when this goes it does not allow cooler water from the radiator to be exchanged for the hot water around the engine block.the reason you lost power is because the pistons got too hot and started to expand in the block,eventually this will lead to your engine ceasing totally and thats a new engine you would need. it may seem a little slower because you may have damaged piston rings in the engine.my advice is get the thermostat checked out and dont drive the vehicle untill this is fixed or else it may cease up

Mar 29, 2011 | Peugeot Liberte Cars & Trucks

1 Answer

Speedometer has been acting strange lately. Will be driving along and it almost acts like its running out of batteries... It reads fine then it slowly starts to read slower and slower till it doesn't read...


you might want to check with your dealer for any recall or service bulletins for this problem they specialize in these types of fixes sounds like theres some problem in the instrument cluster

Mar 07, 2011 | 2005 GMC Envoy

1 Answer

I can only get up to 25mph and the car will not drive or change gears, Happened all at once no warnings.


These cars are famous for trany problems, you may have a clooged converter, but a bad converter you would be able to go over 25mph for a while before it slowed down, you could drive for 5-10 mins, but if this happens all the time then the trany may need rebuilding,

Oct 16, 2010 | 1994 Ford Taurus

1 Answer

Volkswagen transporter 1.9 diesel van r reg starts no problem but has no acceleration. When out of gear and press accelerater no response for about omne min then very slowly builds up revs can drive but...


It seems like fuel pump gear is in wrong position. You need to remove drive belt and turn pump gear 360 degrees. Before you do that, you should know that there is 3 marks: first on flywheel, when 1 and 4 pistons is on top, second at the end of the camshaft and third in fuel pump gear (16 mm bolt). If you never do that before, I suggest you to go to mechanic, otherwise, you can do seriuos damage, like folded valves. 

Feb 02, 2010 | Volkswagen Camper Cars & Trucks

1 Answer

When I first start up and drive my V-6 95 mustang, its drives smooth for till it gets a little warm,, then when I come to a stop light, it begins to Idel real rough, LIKE a spark plug is bad, it does not...


hi, this is a common problem and the main problem is going to be with the oxygen sensor ( also called lambda sensor) replacing this should solve your problem.

When you first start your car you will find that it will run ok as the oxygen sensor only starts working when it reaches a certain temperature so this is most likely the cause of your problem. It can be expensive to get the part but it will solve your problem.

Let me know how you gwt on or if you need further assistance ok

Oct 10, 2009 | 1995 Ford Mustang

Not finding what you are looking for?
1993 Chevrolet K1500 Logo

96 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

75822 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8195 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...