Question about 1988 GMC Jimmy

2 Answers

So I have a 88 gmc s15 2.8 liter truck. It was running rough so I replaced the cap and rotor and it still ran rough so I replaced the plug wires. I followed the manuals firing diagram and not it wont fire up at all. Its the same as I found out the fixya page. Not sure what I should do next. .

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 752 Answers

Autozone.com. I think you replaced too much.

Posted on May 22, 2011

Ad
  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Should be embossed on the top front of the intake manifold, yes/no?

Posted on May 04, 2012

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Van running like its missing


the problem is not in the plugs , wires , cap , rotor but in dirty injectors or injector controls and wires
use a quality injector cleaner for a few tanks of fuel
ECM controlled cars do not a tune up as the computer does that 60 times a minute so all you need to do is to run the fault codes and fix the faulty sensors
fault codes are being recorded all the time and only the serious engine or transmission faults put the engine light on

Jun 21, 2017 | Cars & Trucks

1 Answer

4.3 running rough after tune up


THE FIRING ORDER MOST LIKELY IS WRONG,UNLESS U CRACKED THE IGNITION ROTOR WHEN INSTALLING

Sep 12, 2012 | 1999 GMC Jimmy

1 Answer

1997 gmc yukon backfiring and running rough


need to check engine compression, possible you have a burnt valve, also double check your firing order on plug wires on dist. cap

Sep 03, 2012 | 1997 GMC Yukon

1 Answer

Won't start fuel pump replaced new tank and relay have fuel after fuel filter runs if I put fuel down throttle body. this is on a4,3.


Nephew had similar problem on different vehicle - had spark to plugs, limited gas, everthing else checked. I did one thing first - check for two fuel filters - one in the tank was only screens and one in the line itself. Found a little in line filter just outside of engine compartment under car next to frame that looked like it had never been changed - partially clogged - replaced it.Almost ran but would not keep running. I had rotor and cap pulled - found that the screw holding rotor in place was loose. The rotor edge next to plug wire leads was chopped up and the cap's plug wire leads were heavily oxidized. Replaced them and got it running but a little rough. Pulled the spark plugs and found gaps from 25 - 100 ---replaced the plugs with correct gapping and it ran really well.

Aug 25, 2011 | 1991 GMC S-15 Jimmy

1 Answer

Three days ago i had to remove the intake manifold on my 1994 gmc yukon 5.7 liter had to remove throttle body and dist have replaced along with dist cap, rotor and coil the truck ran fine but now won't...


Check to make sure the coil wire is secured to the distributor cap and rotor.
Also check that the rotor is not cracked (even if new) and that the spark plugs are not loose - wires are not loose, frayed etc.
Also, make sure all connections on the battery, ground at chassi, and positive on starter are in good repair as well.
Please, let me know if you need further assistance.
carsandcomps,
Guru, Premium Expert @ Fixya.com

Jun 24, 2010 | GMC Yukon Cars & Trucks

1 Answer

Replaced rotor and distributor cap and truck was


sounds like you have the plug wires on the cap mixed up. reccomend recheck the order and make sure they are in the right order

Oct 11, 2009 | 1999 Chevrolet Silverado 1500

1 Answer

Starts and runs rough with black smoke as flooded


when you replaced the plugs/wires. Did you do the cap and rotor too
Also have your timing checked

Jul 10, 2009 | 1988 Chevrolet Blazer

1 Answer

Rough accleration through 2nd gear


Had a loose Distributor cap and spark plug. Changed out the plug wires anyway and truck runs great.

Jun 24, 2009 | 1989 GMC Sierra

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

168 people viewed this question

Ask a Question

Usually answered in minutes!

Top GMC Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Freddy

Level 3 Expert

1311 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a GMC Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...