Question about 1988 Oldsmobile Cutlass Ciera

1 Answer

Car turn over but won't start it had a noise in front of the motor sometime it will crank then start then shut off i change the mass airflow sen change the coil packs becuase they were cracked put new wires plugs i think its has to do with the timing im gonna take off the valve covers to see if the valves move what eles can i check car only has 89,000 thou miles its a same if i junk it....ps please help..

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Oldsmobile Master
  • 2,620 Answers

Check fuel pressure

Posted on May 23, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I rmv plug & coil on #6 cylinder in 08 DTS. When put bk correctly w no damage motor hd vibe, lack of pwr trans wldnt shift smoothly Code = misfire #5 cyl. Put new plug & coil in #6 still bad Help!


Sounds like you have an air measurement issue either a vacuum leak or a out of calibration Mass airflow sensor try disconnecting the electrical connector at the mass airflow sensor with the key off then run the vehicle with the sensor unplugged if you symptoms improve your mass airflow sens is bad if no change get a vacuum gauge on it you should have at least 19" of vacuum at idle if you dont or the needle is bouncing around you have a vacuum leak or bad intake valve also test compression on a known good cylinder like num 1 and num 5

Jun 11, 2015 | Cars & Trucks

1 Answer

Where is the egr valve located and the mass airflow sensor


the egr would have a tube coming from the exhaust and usually bolts to the intake, the mass airflow would be in between your air filter and the inake plenum, but the car doesnt use these sensors untel its in closed loop it wont enter closed loop untill the ect(engine coolant temperature) and the o2(oxegen sensor) heater curcuit is up to temp i would check to se if you have spark and fuel if not check for pcm codes but i would probably start with the crank sensor or pcm the crank sensor is the common

Oct 18, 2012 | 1992 Toyota Camry V6

1 Answer

Engine cut out while driving, won't start.


Lets start at the beginning.
If you have a V6 engine you have two cam sensors. And the problem could be the cam sensor(s) is not in sync with the crank sensor due to a problem with the sensor or the timing belt.
Code 340 is for bank one sensor one. You could have as many as 4 sensors depending on which engine you have.
The mass airflow meter code could keep the engine from starting.
The cruise control problem could be related to the cam-crank sensor issue or something else.
You should only have one crank sensor and it is usually near the crank pulley in the front of the engine.

Sep 29, 2012 | 2006 Dodge Stratus

1 Answer

I have a 2001 grand am and the car won't start. If


usually when the trac and service engine come on together it is the mass airflow sensor

Sep 29, 2011 | 2001 Pontiac Grand Am SE

1 Answer

My car won't start when you turn the key the fuel pump doesn't make the noise it does before you start , few people have said its the fuel pump relay , where would i find it and wot does it look...


if you dont hear the pump and you once did,probably pump bad,try starting fluid in air box-tube to mass air,if cranks and shuts of car isnt getting fuel,you can pull line to motor loose to see if gas is getting to motor,check filter for blockage,still no gas more than likely pump bad.

Aug 23, 2011 | Ford Fiesta Cars & Trucks

2 Answers

1999 nissan terrano diesel turbo is lacking power , brand new fuel pump and comp chip installed and has run like **** since, has been put through comp diagnosis but no fault showing,(is very slow 2 pickup...


Possibly the "Mass airflow sensor". I had a similar problem, basically the car behaved like it didn't have a turbo and was really slow. Unfortunately the Mass airflow sensor is expensive, about AU$800. Only failed once several years ago. Hope this helps.

May 13, 2010 | 1999 Nissan Pathfinder

2 Answers

Car will not start change out camshaft sen, crank


maybe a dicky cam sensor even if new! make sure the cam sensor is aligned correctly as if its out even a small amount the car will not run. check it is in place correctly.

Is the car trying to start? or are you getting nothing when turning the key?

Jan 17, 2010 | 2003 Mazda Mazda6

1 Answer

Will not stay started or will run rough after starting. We have changed plug, fuel pump/strainer & mass airflow senscor


is the motor a qg18de if so think u have same problem as me and its the veriable cam timing sprocket on intake cam stuck in full advance wich is 25 degres

May 05, 2009 | 2000 Nissan Maxima

Not finding what you are looking for?
Cars & Trucks Logo

58 people viewed this question

Ask a Question

Usually answered in minutes!

Top Oldsmobile Experts

yadayada
yadayada

Level 3 Expert

76649 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8522 Answers

Are you an Oldsmobile Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...