Question about 1995 Mercury Grand Marquis

1 Answer

Car gets a skipping and studdering at 45mph but when on the highway its not up to speed like it should be. I changed the sparks plugs and the fuel filter and still the same thing is happening

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Master:

    An expert who has achieved Level 3.

  • Master
  • 752 Answers

Spent too much money. Could be TPS. Have diagnostic done for codes.

Posted on May 21, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Van just stopped running on highway and rotor not turning


This shouldn't really be in computers. It's either a fuel or ignition system issue. If it doesn't studder or feel like it's shaking when the issue happens then more likely ignition. Could be Spark plugs, spark plug wires, distributor cap or if it has a newer ignition system coil packs are typical causes of your issue.

Sep 14, 2013 | 2000 Mercury Villager

1 Answer

Rough idle while in park, cutting out on highway


It could be something as simple as a vacuum line,but sounds fuel related. Possible pump.get a fuel pressure reading done and if pressure doesn't hold.....suspect fuel pump

Jan 23, 2013 | Ford Escape Cars & Trucks

1 Answer

2000 plymouth neon 113k miles misfire in cylinder #2 code read out by autozone. car feels like it studders when accelerating to get on the highway. i replaced all spark plugs...doing the wires tomarrow...


Not the spark plugs at all

Unless a wire burnt out,not that
You only get one of them in 50 years of driving

That leaves the ignition module,if you have one
or an individual coil for #2 if that applies

You can not have O2 Sensors in there over 100,000
miles or they slow down or quit. There goes your fuel
trim & thus your misfires as well

Clean your MAF Sensor
Check for vacuum leaks,every where on the car

I know how to convert km,I grew up in Ontario,500 miles
from here in N.J.
Point is ,10 years is too long on those O2 sensors, loose them

Sep 22, 2011 | Plymouth Neon Cars & Trucks

1 Answer

I have a 79 cj5, I had the distributor changed but it wont speed past 45mph. my mechanic now says it my be the carb.


I would think that a fuel pressure test was done, also check for a good solid blue spark from spark plugs, when you guess it cost money, what is the truck doing ?

Jul 28, 2011 | Jeep CJ5 Cars & Trucks

2 Answers

Engine seemed to skip at about 70 mph and service engine light came on. Then seemed to skip several more times at different speeds. Ran fine. Just continued to skip as we drove.


hi the engine is not skipping the problem is the engine is miss firing
that is caused by a bad .spark plug or -wires-or coil pack - when was the last time the
car had a tune up . check spark plug connections

Jun 12, 2011 | 2005 Nissan Altima

1 Answer

My 97 Legacy started to studder when stepping on the gas from a dead stop. It does not seem to studder at higher speeds. Do you thing the Fuel filter may need to be changed?


My 97 Legacy started to studder when stepping on the gas from a dead stop. It does not seem to studder at higher speeds. Do you thing the Fuel filter may need to be changed?

May 10, 2010 | 1997 Subaru Legacy

2 Answers

No power when on highway


clogged cat converter. thats my experience

hope2help shack

Apr 18, 2009 | 1986 Oldsmobile Ciera

1 Answer

Engine studdering


i hate to say i had to replace the intake gasket. but do a little tune up first change fuel filter plugs wire spark plugs besure to get the spark plugs your engine call for.some call for platinum. the 98 on up 2000s model call for platinum.have some one check your fuel pressure . it should be 41 to 47 psi. if you know somebody with a code scanner . tell them to scan your car make sure your torque converter on tranny not staying locked up. check under hood for vacuum leaks. good luck

Mar 12, 2009 | 1999 Oldsmobile Alero

Not finding what you are looking for?
1995 Mercury Grand Marquis Logo

104 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mercury Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

fordexpert

Level 3 Expert

5520 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Are you a Mercury Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...