Question about Mazda Protege

1 Answer

Replaced up stream 02 sensor heard popping in engine whit smoke comes out sometimes not all the time when first started only sometimes it boggs a little bit especially when going up hill

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 273 Answers

Sounds like you could have a blown head gasket. Or even a clogged CAT converter. Hope this helps, James Booth

Posted on May 21, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can't find a leak on 2002 Toyota tundra with P0171


engine too lean, this can be a 02 sensor fault or a timing problem, could called also be a leak in the manifold gasket. try a smoke test, cheap way is buy a cigar and take off the intake pipe, breath in the cigar but not inhale and blow into the intake with the throttle open, and then close it do this a few times and you will see smoke coming out where its leaking, sometimes you will need to put your hand over the intake as it can escape out the idle valve. this should help you find a leak.

Jul 28, 2017 | Toyota Cars & Trucks

1 Answer

2001 Chevy Venture hard to start and grey smoke.


In the older cars, before all the emission laws added so much electronic garb, black smoke meant a fuel problem and grey smoke indicated a problem with internal engine parts like piston rings. Hope this helps.

Aug 02, 2012 | 2001 Chevrolet Venture

1 Answer

1999 GMC suburban hesitates start, when first starts then will **** and misfire after about a few blocks of driving......takes a bit for it to stop misfire /jerking and then it runs fine. Sometimes, not...


It might be your coolant temp. sensor-not the sender for your dash gauge, but the sensor that tells the computer the engine temp. I'd also replace the spark plugs. If they have a sooty, black coating your engine is running rich. Does the engine light still come on? If same code, you need to check that circuit out more fully.

Oct 26, 2011 | 1999 GMC Suburban

1 Answer

Black smoke and lack of power from BMW x5d. I have checked all turbo pipes for breakage and they are fine, there is no noise from the turbo which generally means it's fine I heard a pop when this...


Perform an ODBII scan and look for a Mass Air Flow sensor fault. The pop you heard was most likely a back fire and could have damaged the MAF sensor. A bad MAF sensor can result in overly rich (black smoke) fuel mapping. Pull the intake duct off of the turbo and see if the impellor will spin freely by turning it with your finger. Do you have boost pressure on the dash gauge?

Jun 27, 2017 | Cars & Trucks

1 Answer

I have a 1998 ford windstar and i need upstream & downstream 02 sensor but i dont know if i need 1 or 2 upstream sensors.


assueming it has the v-6 in it look at the exhaust pipe comming off the side of the engine there will be two up stream 02 sensors which are heated and one downstream past catalitic conveter. If may have the second style with the Y cross over with 1 upstream before the cat and one after. The difference between the 0-2 sensors is the upstrean are heated so it goes into closed loop faster. I find that on most of these the up stream 02 sensor heaters have failed. You can go to a Autozone and they can pull the codes for you and tell you which side it is that needs to be replaced. However 02 sensors get old after time and they start shifting slowly, if it shifts slowly then it's called a lazy 02 sensor. And will send a code to the computer, if you get the trouble code of the 02 sensor heater is bad you will have to change it, I recommend Replacing both. The reason is if one is going bad the other will soon follow. You can buy a socket wrench For the 02 sensors for 12 dollars makes it real easy to replace the 02 sensors when they are COLD. Hope this helps and thanks for using fix-ya.

Sep 14, 2010 | 1998 Ford Windstar

1 Answer

While maintaining speed at around 2,000 rpm the motor seems to cut power to the transmission and I slowly lose rpm till it picks back up and then sputters so on and so on... have replaced plugs, fuel...


check your 02 sensors,also sometimes that could be from clogged cat.converters,usually from bad gas, i had the same problem,but lucky for me, i went up a steep hill,i forced it and i heard a loud pop,black smoke,then i got my power back,but ive been told that could be dangerous as you can destroy ur engine from back flow,good luck

Aug 06, 2010 | 1994 Honda Civic

1 Answer

240 wont go over 2000 rpms starts to **** then blk smoke


I'm thinking MAP(Manifold absolute pressure sensor) but a reliable mechanic should be able to scan your ECU and find out for sure.Good Luck.

Apr 24, 2010 | 1989 Nissan 240SX

1 Answer

I have 2008 toyoya tocoma truck only getting 13 mpg. the check engine light on, had it scope out said o2 sensor open, replced sensor had light cancel but came back on. still have problem


Are you sure you replaced the right 02 sensor? Some vehicles have up to 4 02 sensors and being the ones that have a seperated duel exhaust system. You will have an 02 sensor located upstream of the catalytic converter and one down stream of the converter so make sure you replaced the right on. If you used a scanner to tell you it was an 02 sensor it should have also told you bank one or bank two which translates to drivers side or passengers side will also tell you up stream or down stream.

Dec 01, 2009 | 2008 Toyota Tacoma

2 Answers

Check engine light is on


P0135 02 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1)
P0136 02 Sensor Circuit Malfunction (Bank I Sensor 2)
check for a blown fuse, if it is blown replace it, if it blows again after engine is started you have either a shorted O2 sensor or the wiring leading to the up stream or down stream sensors.

Apr 22, 2009 | 2001 Chevrolet Metro

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

48 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mazda Experts

yadayada
yadayada

Level 3 Expert

76109 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Mazda Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...