Question about 2006 Ford Taurus

1 Answer

Engine starts missing when coming under load more noticeable when climbing a hill. Have replaced o2 sensors made no difference

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 252 Answers

Hello first of all

No that will not really help what controls missing is bad fuel air mixture depending on what o2 sensor you change this may or may not affect this only the o2 sensor before the cat converter will affect this as it runs mixture.

That being said here is what i would check being a mechanic for 5 years with ford and 3 with bmw first check spark in all cylinders make sure it is blue not orange do this by pulling out plugs leave them connected to wire and have someone start the care and check the color of spark.

If blue in all your good if orange in any replace the coils and or coil if you have more that one.

Then replace the camshaft position sensor and if possible the crankshaft position sensor the crank controls starting spark and the cam running spark but they work together.

If this all fails and you have had a recent tune up plugs wires coils air filter fuel filter ect

If all this fails you need to see a shop as unless you have alt of tools and time its beyond most folks reach.

I hope this helps if so please 4 thumbs up thanks

Posted on May 21, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

94 blazer 1500 starts idles or rev to 5000 when in park or neutral. in drive idles ok but stumbles and dies when you accelerate under load.it takes awhile to reach 75 mphd it will kick down to climb a hill...


You either have a defective idle speed control valve or you have a huge vacuum leak on the engine like an intake manifold or warped throttle valve or throttle bore opening around the throttle valve, I have seen both...

Jan 08, 2017 | Cars & Trucks

3 Answers

7.5l MFI/SFI timing (?) problems


Hi, you describe a chugging even on moderate hills, is your transmission shifting properly? It sounds like it's stuck in overdrive. Or a plugged injector or two that maybe push out fuel OK in warm up mode but not after. So if your transmission is downshifting when is should and you still have no power, I would have the injectors checked out. Good luck, chuckb

Apr 06, 2009 | 1994 Ford F250 Supercab

1 Answer

No power when going up hill


Read the engine light on the OBDII then post the code if your code reader doesnt have the explanation of the code ,although i would suspect a faulty O2 sensor not giving the right fuel ratio but ? iam always wrong here when i guess things

May 20, 2013 | Kia Sorento Cars & Trucks

1 Answer

Excessive white smoke out of blow by


Just letting you know that white is water, blue is oil and black is gas coming out of the exhaust.

Jul 20, 2017 | Cars & Trucks

2 Answers

Missing when accelerating and on hills


I would recommend that you change the plugs.

Mar 22, 2011 | Toyota Camry Cars & Trucks

1 Answer

Missing under load, When accerating or climbing a hill my LOW milage 4runner is starting to miss. what could it be? Spark plugs or ?


Start with the simple things first. When was the last time you had a complete tune up? "Missing" could indicate bad spark plugs, bad spark plug wires, or bad cylinders. Change the plugs first, then go from there.

Nov 06, 2010 | 1998 Toyota 4Runner

1 Answer

Engine skips


That sounds like a dirty EGR valve...I had the same problem. Change the EGR valve and your problems shall be gone.

Jan 12, 2010 | 1995 Cadillac DeVille

2 Answers

Po320 code and code po303 2004 lincoln navigator


Replaced a camshaft sensor still running rough & engine light still on, 2004 lincoln nav. 5.4 liter

Jan 02, 2010 | 2004 Lincoln Navigator

1 Answer

On long pull service engine light will flash then go off after hill is climbed runs fine will not store code


This is normally caused by the O2 sensor detecting a fluctuation in the readings beyond the set limits for your engine. Very normal especially when driving over hills.

Nov 04, 2009 | 2001 Chevrolet Astro

Not finding what you are looking for?
2006 Ford Taurus Logo

172 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

75817 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22156 Answers

fordexpert

Level 3 Expert

5495 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...