Question about 2006 Ford Mustang

1 Answer

While driving the car in the rain the lights and radio stooped working all together, than a series of warning lights went off. I stopped the car and when I tried to restart it, the car would start but I was unable to shift out of park and I still had no lights or radio. After letting the car sit for an hour or so it started working again.

Posted by on

  • Steve Allison
    Steve Allison May 20, 2011

    Not certain about this so don't offer as a solution- Two possibilities and could be related; loose belt allowing the belt to slip when wet and the problem with the tranny could be related to low system voltage and the anti-theft system acting screwy because of it.

×

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Ford Master
  • 4,369 Answers

Maybe your ignition switch is moving dlightly out of the on position.

Try applying sight turing effort in each direction to see if the warning lights go off and the radio works, and the shift interlock solenoid clicks when you step on the brake pedal.
May need a new lock cylinder or ignition switch.

Posted on May 20, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Can a popped fused cause for all lights to not come on?


check your fuses first .as it can be a failing bulb failure warning relay.

Dec 05, 2013 | 1999 Isuzu Rodeo

1 Answer

2007 Toyota Tacoma air bag light came on and radio stopped working...


Have you tried replacing fuses? i would look there first. a blown fuse is easy to see.

Jul 27, 2012 | 2007 Toyota Tacoma Access

1 Answer

Went to start the car this morning and wouldnt turn over. Tried on a couple of occasions and was not even near to starting. All lights, radio, heater, etc working okay and not had any problems ever before...


Try jump starting, see if it starts then. Lights, radio, etc.. don't draw nearly the amps that your starter does. Batteries don't always give warning when then decide to "go south". If you can get it started by jump starting, stop by a local Autozone, Advance, etc.. auto parts store and have them do a charging system test and to load test your battery. They offer this service for FREE
Another Note: When was timing belt last replaced? If it's a 325 of that year it should be done every 60k (If it's 318 ignore the above belt issue)

Feb 28, 2011 | 1991 BMW 3 Series

1 Answer

My dash lights went out in my 04 alero, the warning lights all work but the back lights such as the gas gauge and speed-o-meter are out and I do not know why.


Did your radio go crazy too? Mine does this when it rains and I discoverd that my fuse box was getting wet. I was told I had a leak in the windshield.My lights would come on at night when this happened and run my battery down.

Mar 01, 2010 | 2004 Oldsmobile Alero

1 Answer

On my BMW 528i while driving radio stops working,


low power, bmw ecu has some code that starts shutting down systems on low power. so poor charging from the alternator to the battery.

this could also be a wet ecu tracking false codes.
i don't have direct experience with a series 5 but also check your ecu condition.

the ecu compartment is under the windshield on the passenger side on E36

you gain acess to it under the hood....
this compartment gets wet, the ecu lays on a flat surface in that
compartment.

the bottom side of the circuit board gets wet and starts corrosion.

remove the ecu, take the bottom plate off, clean the bottom of the circuit
board with alcohol and a soft tooth brush.

you should be able to see the signs of corrosion or conductive build up.

this gunk bridges solder points doing all sort s of wierd things to your
car, including false sensor readings from asc/abs controllers and other
sensors....

all the way to engine failure and worst case burnt and shorted wiring
harness.

I'm on my 3rd ecu, took me and the repair boys a few years to figure this
one out.

BTW: i would get that ecu mounted above that flat surface, use some sort
of standoff to raise it so that it is not laying in the wet.

Jan 27, 2010 | 2000 BMW 5 Series

1 Answer

Traction systen warning message.The right turn signal also blinks rapidly if turned on,both dashboard grenn turn signal lights also intermittently come together venture 2001.


traction system warning message.The right turn signal also blinks rapidly if turned on,both dashboard turn signal lights also on come together venture 2001.This happens when it is cold raining and the automatic head lights are on and the brake pedal is depressed.

Oct 09, 2009 | 2001 Chevrolet Venture

3 Answers

91 accord, This Girl needs help quick!!!!!!


I HAVE THE SAME PROBLEM, ALL OF A SUDDEN THE WHOLE INSTRUMENT PANEL WENT OFF NO RPM, NO TEMP, NO CLOCK, NO ENGINE LIGHT, OR ANY OTHER WARNING LIGHTS, ONLY THE TURNING SIGNALS AND THE BATTERY LIGHT WORKED. SEAT BELTS AND WINDOWS STOPPED WORKING. MY RADIO HAS BEEN INSTALLED FOR OVER 4 MONTHS SO I REALLY DOUBT IT IS THE RADIO. IF ANYONE KNOWS WHAT IT COULD BE PLEASE LET IT BE KNOWN. ALL FUSES ARE GOOD ALSO.

Mar 16, 2009 | 1991 Honda Accord

1 Answer

Headlight and hazard light and horn and aftermarket radio,


Check your neutral safety switch. I had the same problem during a hard rain, hit a bump and everything went out.

Feb 28, 2009 | 1988 Chevrolet Nova

2 Answers

Weather related electrical problems


I had this problem with mine. Do not ever use a automated car wash on your ALERO----it destroys the seal around the window. Then, when you drive in rain, water leaks into the fuse box, shorting it out. I had to replace the fuse box ($500). Hope this helps.

Jul 23, 2008 | 2003 Oldsmobile Alero

Not finding what you are looking for?
2006 Ford Mustang Logo

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

fordexpert

Level 3 Expert

5537 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...