Question about 1997 Nissan Pickup

2 Answers

97 nissan xe pu automatic 2.4 starts stalling and running rough once it is warmed up. Starting shaking a bit too when driving down the road. Starts right back up but after it is warm will just turn right off below 20 mph ... doesnt shutter or anything...lights just come on...battery and oil. All fluids are fine, and oil was just changed 2 mos ago with a new fuel filter.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Its the heat exchanger or the egr needs cleaning or replaced

Posted on Oct 22, 2012

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • Nissan Master
  • 1,949 Answers

Plugs and wires

Posted on May 19, 2011

  • 6 more comments 
  • Bonnie B May 19, 2011

    plugs and wires are good...changed not long ago

  • Shane Gannon May 19, 2011

    check vacuum lines then one probaly got broke because they are old(while doing tuneup))

  • Bonnie B May 19, 2011

    plugs and wires were changed awhile ago and it just started this..

  • Shane Gannon May 19, 2011

    i would still check vacuum lines because it dieing as vacuum lowers

  • Bonnie B May 19, 2011

    will do...thanks so much...not easy being an older woman driving an older truck...so sincerely appreciate your suggestions and advice...:)

  • Shane Gannon May 19, 2011

    just sorry i cant do more from here.........good luck and dont be affraid to ask me more.....

  • Bonnie B May 19, 2011

    Will do that too....you have given me some peace of mind so dont under estimate your advice....:) God Bless you and your family...

  • Bonnie B May 19, 2011

    just was told by a local mechanic that my 97 nissan pu xe needs a mass air flow sensor and the part is $439. I called a local Auto ZOne who says that in his computer it shows that my vehicle is not equipped with a mass air flow sensor??? Now I am really confused...am I being taken or is auto zone have incorrect info?

×

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1991 F350 w/460 cu starts but runs rough until warm.


sounds like auto matic choke problem try a manual choke

Jan 02, 2014 | Cars & Trucks

1 Answer

97 3.9 dakota when it's cold outside and I start my truck it'll start right up but idle down til it quits . Start it again and it will idle.. Go down the road and it misses bad until it warms up. After it...


Here are the most common causes of idle surge, rough idle esp when cold and stalls at stops, slow idle speed, erratic idle speed, rough idle and engine hesitation (and other problems), it is in most cases the idle speed control air-bypass valve and or throttle valve and upper intake, these area's get full of gunk and combustion residue over the miles and cause idle issues (stalls, low idle) like yours, Get a can of intake cleaner from any local parts store, not carb spray, intake cleaner, it is made by a company called CRC, remove the air intake hose to the engine, hold the idle high so the engine won't stall, then spray the can of cleaner into the intake while keeping the engine running, use at least 1/2 the can, shut down the engine and disconnect the battery for 5 minutes, then restart and complete a number of mixed driving cycles, town, freeway, stop and go etc., after a few days the problem will go away as the system will relearn to the clean intake.

Jul 09, 2017 | Cars & Trucks

1 Answer

96 chevy s10 v6 stalls after i start it up


This problem is commonly caused by a dirty automatic idle speed control valve and throttle valve but always run a OBD2 fault code as well as the cleaning procedure. Buy a can of throttle valve cleaner (do not use carburetor spray cleaner!) from NAPA or Carquest (made by CRC chemicals) and spray it into the air intake while the engine is running, use up about 1/2 the can, engine will try to stall hold the speed up, shut it down and let it soak for 30 minutes, restart and blow out the remaining fluid, shut it down and disconnect the negative battery cable for 5 Min's to reset the base idle control

Oct 18, 2012 | Cars & Trucks

1 Answer

Nissan sunny carburetor stalls rpm cranks


Check fuel pressure test and air intake system.

Aug 20, 2012 | Nissan Sunny Cars & Trucks

1 Answer

991 Nissan Pathfinder XE-V6, @160,000 miles, Automatic Transition, 4x4. Replaced left side exhaust manifold gasket, new cap & roter @2500 miles ago, new Platinum plugs @10,000 ago Truck star


run the fault codes to find which sensor is failing from internal heat build up
when allowed to cool it works fine until it gets hot again

Mar 26, 2017 | 1991 Nissan Pathfinder

1 Answer

Buick 97 lesabre, runs rough when warm


Buick 97 lesabre, runs rough when warm

Jan 25, 2012 | 1997 Buick LeSabre

2 Answers

97 cavalier starts and runs ok from a cold start after a few minutes of warm up it starts to run rough and miss. If i try to drive it it will start out ok but won't shift automaticly but shifts fine m


Sounds like possibly more than on problem, crankshaft position sensor, or ignition module likely on starting prob which maybe affecting shifting due to hard code in ecm, or shift prob could be shift solenoid in valve body of transmission. Both parts readily available from local parts store

Nov 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

97 lumina, 3.1. Starts runs smooth, drive for 30


I just recently have been fighting the same problem with the same make/model/year vehicle. For myself, I would drive off and on through the day and it would run fine. Then suddenly after a start it would run rough and die. I would have to wait 20 to 60 mins before it would start again. I had it checked and fuel pump was only putting out around 19 psi. It should be around 41 psi. Had fuel pump replaced and no more problems. Furthermore, now it runs so much better. It's funny how over time I didn't notice how the performance was slowly degrading. Unfortunaley fuel pumps for this car run around $300.

May 25, 2010 | 1997 Chevrolet Lumina

1 Answer

97 Jetta won't start


tyr disconnecting the temp sensor unit and try starting it

Jan 01, 2009 | 1997 Volkswagen Jetta

2 Answers

1984 nissan 300zx running erratic


Is the MIL light on on the dash?

Nov 20, 2008 | 1984 Nissan 300ZX

Not finding what you are looking for?
1997 Nissan Pickup Logo

278 people viewed this question

Ask a Question

Usually answered in minutes!

Top Nissan Experts

yadayada
yadayada

Level 3 Expert

76682 Answers

Phil Lovisek
Phil Lovisek

Level 3 Expert

726 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22219 Answers

Are you a Nissan Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...