Question about Ford Taurus

1 Answer

I just replaced the altenator Saturday and I replaced the battery today. My battery light came back on to night what might be the problem?

Posted by on

  • john44147 Jan 15, 2009

    The battery and alternator has been replaced on my 2001 Crown Vic and the battery light will come on occasionaly. When driving on the highway the light will come on for 80-100 miles and then go back off. Sometimes it will come on while driving around town and eventually go off. What is the problem?

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 702 Answers

Check the plug going to the alternator. There should be a 3 or 4 wire plug on the back or side of the alternator. If one of those wires is burnt, the alternator will not charge.

Posted on Aug 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Battery being drained over night


Check to be sure that your hood light is turning off when you close the hood. Seriously. (Common problem.)
Remove the bulb from the hood light to see if the problem persists. If the battery no longer drains, replace the hood light assembly.
Also, run the car for a short while, then turn the car off. Leave the car off for an hour, then feel the back of the alternator. If it is hot, the diodes are bad in the alternator.

Jul 17, 2014 | 1999 Ford Explorer

1 Answer

Battery light came on


could be moisture in altenator or connections of altenator or battery

Jun 06, 2012 | 2010 Scion tC

2 Answers

I have a new battery but the fire keeps being drained, i jump it off and it runs but today the battery light came on the the radio quit working, the windows on the drivers side stopped working, the speed...


Get the battery recharged and have the alternator tested . Voltage at battery with the car running should be 13.5-14 volts.If the battery light came on with engine running that indicates a bad alternator .NEVER remove battery cables with engine running , tests nothing and could cause ecu failure.

Feb 13, 2011 | 1996 Ford Taurus

2 Answers

Just got new battery but the batt. light is on.I also got the alternator tested and it was good


Check all connections and especially the ground connections...there should be two ground locations one at the engine block and one at the body

Jan 23, 2011 | 2001 Chevrolet Venture

2 Answers

2002 chevy tahoe, draw on battery, new battery, altenator good, discounected pass-power seat(heard they go bad)...don't know what to do?


try unhooking the power wire off the back of altenator it may charge but if a diode is stuck it will drain your battery if this is the problem the altenator will still charge but will drain your battery over night

Jan 17, 2011 | Chevrolet Tahoe Cars & Trucks

1 Answer

Bought a 1997 mercury sable today, guy said it needed a starter, charged dead battery and replaced starter. It fired right up, was driving it home it died, oil light, battery light, and check engine light...


Try checking the altenator. If the starter and battery were gimpy, the altenator may have a blown regulator too!. It sounds like there is a short in the system causing this problem. Most likely the altenator or component in the charging loop. WF

Sep 15, 2010 | 1997 Mercury Sable

1 Answer

MY CHECK CHARGE SYSTEM LIGHT AND LITTLE BATTERY LIGHT KEEPS GOING OFF. I'VE HAD THE WIRING HARNESS TO THE ALTERNATOR REPLACED, THE VOLTAGE REGULATOR REPLACED AND TODAY A NEW BATTERY PUT IN. NOTHING IS...


The first question for you is, What is the charging output for the altenator at idle?? If less than 12.3 volts, replace altenator. Typically, the altenator gets tested at 2500-3000 rpm on a bench tester. Your problem may be in the low rpm output range.

Nov 27, 2009 | 2002 Ford Explorer

1 Answer

Cars lights are going bright and dim . changed out battery today and alt tested fine.car ran fine again until tonight then back to losing power


mcdevito75 here, Sounds like the regulator inside the alternator, re test altenator with the headlights off, then on, any lower reading from the altenator with the headlights on, could mean a bad regulator, in the altenator, all 1 unit altenator gets changed.

Nov 10, 2009 | 2004 Mitsubishi Eclipse

Not finding what you are looking for?
Cars & Trucks Logo

Related Topics:

251 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60792 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...