Question about 1996 Chevrolet S-10 Pickup

2 Answers

Starts up ok. tries to die though when idiling and will backfire and sputter. giving it gas to keep it going or revving it up more starts to cause the little fireball effect

Posted by on

  • drake4d5 Aug 14, 2008

    noone has messed with anything only 1 person owned the truck which was my uncle
    i had someone look at it today and they told me the fuel pump was prolly bad?
    but iv heard it could be the timing belt also?
    we replaced the fuel filter cuz it was plugged up from rust n stuff also have replaced the spark plugs and wires


×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

Sounds like it might be off on the timing. has anyone mess with the distributor, or it might need cap, rotor,plugs, plug wires.

Posted on Aug 14, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer



did you have your fuel pump looked at! mine did the same thing ,had to replace tank, cause of small rust holes and fuel pump was bad. this cost ed me 850.00 to have fixed. hope you have better luck!


munchkinnma

Posted on Aug 14, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

What do these codes mean on a diagnostics check? c, ev, o, oh,e? what are these numbers for ISO9141 KWP2000 and why does it steady blink on monitor then say backfire problems?


you need to read the manual for the machine you are hooking to the vehicle .
These are errors not codes you need to understand how it works better.

Feb 16, 2016 | 1997 Chevrolet Lumina

2 Answers

I have a 1993 ford festiva its a good little car it runs good when the engine is cold but when it warms up it sputters and dies on me when it dies it fires right back up like nothing ever happened It...


If it has an automatic choke, this will keep it revving more when the engine is cold and less when hot. Maybe adjust the idle setting screw on the carburettor so it revs slightly more. Try that before it is running hot. Only increase the revving gradually to the stage where stalling would be avoided when hot. Gradually so that there is not too much revving when cold. Adjusting and testing over a few runs could be a good strategy

Feb 28, 2014 | Ford Festiva Cars & Trucks

2 Answers

Backfire, Black smoke from exhaust, spitting and sputtering


If you have not replaced plugs start there A bad map sensor will also cause black smoke and poor running

Feb 15, 2014 | Dodge Durango Cars & Trucks

1 Answer

97 kia sephia, replaced battery, plugs, wires, cap, rotor, air filter, fuel filter, added heet water removal and lucas fuel injector. It sputters, backfires/pops when accelerating and it has no power,...


As you have replaced all the obvious things that could cause the symptoms it may be a good idea to have a cylinder compression test done , if comes back OK i'd try a fuel addative , one that covers the catalytic convertor , as there are many sensor's involved in the fuel/exhaust system as you know , this addative will clean any residue affecting there reading's , hope this helps

Apr 06, 2017 | 1997 Kia Sephia

1 Answer

1993 Chevy Silverado PU 1500, backfire, sputter, die


they might have not put the proper gap on the plugs..and might have over filled the engine with too much oil..

Apr 01, 2010 | 1993 Chevrolet K1500

1 Answer

Backfiring sputtering, won't start


Could be lots of things. Could be plugs or wires or a combination of both are going bad. Probably time to change all of them any way.

Sep 30, 2009 | 1995 Ford Probe

1 Answer

89 chevy beretta gt- surges at idle, backfires and hesitates


Hi! I had the same problem with my 88 2.8 Ltr. Had dirty fuel Injectors. Put in fuel Inj. cleaner in gas tank, after a couple of days, runs like a dream,no more problems. Give it a try. Take care,Leo B. Flushme@shaw.ca

Jan 03, 2009 | 1989 Chevrolet Beretta

Not finding what you are looking for?
1996 Chevrolet S-10 Pickup Logo

Related Topics:

89 people viewed this question

Ask a Question

Usually answered in minutes!

Top Chevrolet Experts

yadayada
yadayada

Level 3 Expert

70346 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

22041 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6869 Answers

Are you a Chevrolet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...