Question about 1994 Eagle Talon

1 Answer

After the car has been running for awhile it will die, but i can start it back up i have changed the mass air flow sensor and the coolant sensor seeing the they all half to do with the idling of the car

Posted by on

  • mytalon24 Oct 16, 2008

    I have the same problem with my 93 talon 2.0 when i bought it the car ran fine no problems but when i started the cleaning process i was detailing the interior and i had the car running and it just shut off. cranks fine but will not start up.

×

1 Answer

I have the same problem with my 94 Talon Tsi AWD. I was reading on the DSM site that there is a Reed Switch inside the instrument cluster where the tachometer is. They say its one of the cars speed sensors and when it malfunctions the ECU for the car wont recognize the car is moving and cut the car off. I dont know exactly where the reed switch is inside the cluster I have to get out my service manual to see that, Im going out later this week to get a whole new cluster ill let you guys know if that fixes the problem.

Posted on Oct 28, 2008

  • Ronnie bray Jul 12, 2012

    The reed switch is located behind the speedo,if you can just replace the speedo cluster,I don't know of they make replacements for the Rees switch anymore

  • Ronnie bray Jul 12, 2012

    It's wrapped around the input for the speedo

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Dying, not starting after it's been warmed up. Runs beautiful on cold engine. Replaced plugs, wire, cap, rotor and crank position sensor, no luck.


Your car cold start valve puts more gas into the system keeping your engine running higher RPM. When you car warms up, the cold start valve will stop working and your car RPM will drop. What you could have is a vacuum hose disconnected which puts more air into your engine - therefore when you press on the gas pedal, your engine would shut off or you find lack of power and then shut off.

Mar 27, 2015 | Cars & Trucks

3 Answers

2003 Nissan Altima 2.5L Service Engine Soon Light is on, Auto Zone says codes are for MAF and O2 Sensors. Car hard to start after driving a while but when starts appears to run smooth. Auto Zone thi


ok lets start with the codes they say your getting. P??? which 1's and how many. there are few o2 sensors, are they next to the Exhaust next to the converter? MASS AIR FLOW -MAF use this, for now i am guessing, until i see the correct codes your are getting. this could be the 1 you may have below, please read it........
  • P0103
    Mass Air Flow Sensor Circuit High Input
  • Possible causes
  • Faulty mass air flow sensor
    - Intake air leaks
    - Dirty mass air flow sensor
    - Dirty mass air filter
    - Mass air flow sensor harness is open or shorted
    - Mass air flow sensor circuit poor electrical connection
  • Before replacing the mass air flow sensor, try replacing the air filter and cleaning the air flow sensor with low compress air or mass air flow sensor cleaner. Reset code and drive vehicle. If the code comes back, it may be necessary to replaced the mass air flow sensor.
  • possible symptoms Engine Light ON (or Service Engine Soon Warning Light)
    - Engine stall
    - Engine running rough
    - Excessive fuel consumption
    - Excessive smoke
  • the code is generated when An excessively high voltage from the sensor is sent to Engine Control Module (ECM).
2003 NISSAN Altima Sedan OBDII Codes List

Oct 22, 2014 | 2003 Nissan Altima

1 Answer

What does the mass air flow sensor look like?


The mass air flow sensor works in conjunction with the oxygen sensor & the engine control system. While the oxygen sensor...--------------------------------------------------------------------------------------
CARPROG FULL

Dec 18, 2012 | Cars & Trucks

2 Answers

PO103 and 116 code on a 1997 jetta 2.0


P0103 - Mass or volume air flow circuit high input.

Symptoms: Engine stalls, running rough, excessive fuel consumption, excessive smoke from the tail pipe, check engine light on.

Possible Causes: Dirty mass air flow sensor, dirty mass air filter, mass air flow sensor harness is open or shorted, mass air flow sensor electrical circuit poor connection, intake air leaks, faulty mass air flow sensor.

P0116 - Engine coolant temperature circuit range/performance.

Symptoms: Check engine light on.

Possible Causes: Low engine coolant level, ECT sensor harness open or shorted, ECT electrical circuit poor connection, faulty engine coolant temperature sensor (ECT), faulty engine coolant thermostat.

Apr 27, 2011 | Volkswagen Jetta Cars & Trucks

1 Answer

95 ford tarus wagon 3.8 won't start. Air Flow Sensor?


u may need to have ur computer reset, u dont say if u have any warning lights on the dash. other fuelling system sensors tie in with the air flow sensors. plug ur diagnostic port in at a garage and see what fault code reads.

Jun 17, 2010 | 1995 Ford Taurus

1 Answer

Start car is fine but once hits idle speed the engine hesitates and then dies. I disconnected the mass air flow sensor and car ran better, then hooked it back up and the engine died instantly. Is this a...


i would agree with your diagnosis. i had a similar problem with a crown victoria. disconnecting the maf sensor made it run better. i replaed the sensor and have had no problem since

May 08, 2010 | 1999 Subaru Forester

Not finding what you are looking for?
1994 Eagle Talon Logo

Related Topics:

90 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eagle Experts

yadayada
yadayada

Level 3 Expert

61037 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Stewart Dibbs

Level 2 Expert

267 Answers

Are you an Eagle Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...