Question about 2005 Ford Mustang

1 Answer

Gas gauge Gas guage not working properly, it works fine for a while then goes haywire hanging up.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,586 Answers

Repair or replace the sending unit in the tank.

Posted on Aug 14, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Also my gas guage is stuck on full. it goes to empty when I turn ignition swith to off.do I need a new guage ?


It could be the gauge or the sender, in the fuel tank, or the fuse to the sender. On some Hondas there's a voltage regulator, in the gauge assembly, holding fuel gauge and some others to 8V.

May 03, 2015 | Cars & Trucks

1 Answer

Gas gauge working good but truck stalls at 1/2 tank


THIS MEAN YOU NEED TO CHECK THE LEVEL SENSOR INSIDE THE GAS TANK MAYBE GIVES WRONG READING









Apr 03, 2014 | 2004 Ford Explorer

1 Answer

The gas gauge for the front tank on my 1992 F150 is stuck past full


You probably have a ground wire not making contact to ground on the front tank sending unit. OR the sending unit itself inside the tank is faulty. Either way, when a gas guage goes to full all the time (empty or full), this indicates that NO ground is available for the sending unit.

Apr 02, 2013 | 1992 Ford F150 SuperCab

2 Answers

The gas guage and temperature guage in my 02 cavalier are not working properly. half of the time the temp guage stays below 40 and will not go up and when i fill up the car and start it the gas guage will...


Hi, take the connector off the temp sensor, turn the key on, and have someone watch the gauge while you insert a paperclip to short the terminals together inside the connector. If the gauge goes from one extreme to the other when the terminals are connected, the cluster is probably OK. It may just be that both sensors are bad.

temp sensor location, 2.2 liter engine:
jturcotte_1822.gif


2.4 liter engine:
jturcotte_1823.gif

Jun 11, 2011 | 2002 Chevrolet Cavalier Coupe

1 Answer

79 c10 - guages all read low except gas guage which reasd high. Truck runs fine. Lights work, even the dash lights work good.


It sounds like you might have a poor ground connection somewhere. You can test each individual gauge for full travel by grounding the wire the goes the each gauges individual sender. In other words to check the temp gauge, ground the wire that goes to the temp sender. The temp sender is in the left cylinder head between the #1 and #2 spark plug ( looks like a brass pipe plug with a single wire coming from it) if you ground the wire with the key on (engine off) the gauge should go to the end of the scale (hot) with the wire off it should go to full cold. You can do this with the gas gauge too but not the amp gauge or volt meter. If the volt gauge is reading low (if it has one) and you know that battery voltage is good (don't guess, measure with a multi-meter) there has to be a poor connection somewhere.

Jan 24, 2011 | Chevrolet C1500 Cars & Trucks

1 Answer

2000 Astro, I replaced fuel pump a month ago. Worked fine. Now gas guage is not working, just hangs down below E. Where is the dang fuse, so I can check it? I have the owner's manual, I don't see a listing...


It sounds like a problem with the fuel gauge sender unit which is usually combined with the fuel pump. Since you have just replaced the pump, check the wiring connections at the connecting plug.

Aug 20, 2010 | 2000 Chevrolet Astro

1 Answer

My gas gauge works (not incredibly accurate, but works). When i stop for more than a few seconds the gauge goes to empty. when i start moving it goes back to full and slowly comes down to where the gas...


As far as the gas gauge level goes, it sounds to me like it could be the float ball system that is inside of the gas tank, which is connected to the fuel pump.I dont think your guage in the dash is broke, but i could be wrong. Sounds like something in the fuel pump area

Nov 20, 2009 | 1998 Dodge Ram 1500 4WD

2 Answers

Rear lights out ,gas guage haywire ,temp gauge out 318ti bmw1997


It very likely may be your alternator. I had the same problem. I took it to the dealership three times and the technicians were stumped as well. Finally, I found this article that talks about it, which led them to change the alternator:
http://yourhandymanzone.com/Your_Handyman_Zone_How_To_Pages_Vehicle_Car_Zone_Cars_Trucks_Vans_Alternator_Gauges_Go_Up_And_Down_Like_Crazy.htm

May 02, 2009 | 1997 BMW 318

2 Answers

Gas gauge not working property


Pontiac has a problem with the sender for the fuel guage. A quart of transmission fluid in a full tank of gas usually fixes it. The "engine" light, won't be on because of that. Quite often that is the air filter or fuel cap.

Oct 01, 2008 | 2004 Pontiac Montana

Not finding what you are looking for?
2005 Ford Mustang Logo

Related Topics:

164 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Experts

yadayada
yadayada

Level 3 Expert

60769 Answers

Colin Stickland
Colin Stickland

Level 3 Expert

21949 Answers

Fordexpert

Level 3 Expert

5331 Answers

Are you a Ford Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...